VirtualBox

Ticket #2966 (closed defect: duplicate)

Opened 5 years ago

Last modified 5 years ago

Error: Shrink hard disk operation is temporarily unavailable!

Reported by: kgardas Owned by:
Priority: major Component: virtual disk
Version: VirtualBox 2.1.0 Keywords:
Cc: Guest type: other
Host type: other

Description

Hello, when trying to compact Ubuntu 8.04 image in VirtualBox 2.1.0 running in Solaris Express Developer Edition 1/08 I always get this error message:

karel@silence:/ufs0/vbox$ VBoxManage modifyhd /ufs0/vbox/ubuntu804.vdi compact VirtualBox Command Line Management Interface Version 2.1.0 (C) 2005-2008 Sun Microsystems, Inc. All rights reserved.

Error: Shrink hard disk operation is temporarily unavailable!

What exactly does it mean? That I shall still keep trying, or that the feature is disabled in 2.1.0 release? I've never tried compacting of Ubuntu disks, but I remember to compact Windows NTFS based disks several times while using VBox 1.6.x.

Change History

comment:1 Changed 5 years ago by wendal

It appears in the source code that this in an unconditional error message.

273 	#if 1
274 	RTPrintf("Error: Shrink hard disk operation is temporarily unavailable!\n");
275 	return 1;

It will probably re-enabled in a later release.

comment:2 Changed 5 years ago by awilkins

That said, this is not a helpful error message ; there are more than one issues devoted to it already.

My suggestion is that it would have been better to create a ticket for this right from the start, and have the error message link to it, as well as being worded more clearly.

comment:3 Changed 5 years ago by pjw1965

duplicate of #2833

comment:4 Changed 5 years ago by sandervl73

  • Status changed from new to closed
  • Resolution set to duplicate
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use