VirtualBox

Ticket #2808 (closed defect: fixed)

Opened 5 years ago

Last modified 5 years ago

NAT port forwarding not working after upgrade from 2.0.4 to 2.1.0 -> fixed in SVN

Reported by: lalala Owned by:
Priority: major Component: other
Version: VirtualBox 2.1.0 Keywords: nat
Cc: Guest type: Linux
Host type: Windows

Description

I have configured and running NAT port forwarding in version 2.0.4. (XP SP3 Host, Ubuntu Intrepid Guest).

After upgrade to 2.1.0 NAT port forwarding not working.

Downgrading to 2.0.4 and it works again.

VBoxManage getextradata intrepid enumerate

VirtualBox Command Line Management Interface Version 2.0.4
(C) 2005-2008 Sun Microsystems, Inc.
All rights reserved.

Key: GUI/SaveMountedAtRuntime, Value: yes
Key: GUI/LastWindowPostion, Value: 102,35,800,644
Key: GUI/Fullscreen, Value: off
Key: GUI/Seamless, Value: off
Key: GUI/AutoresizeGuest, Value: on
Key: VBoxInternal/Devices/pcnet/0/LUN#0/Config/ssh/HostPort, Value: 2222
Key: VBoxInternal/Devices/pcnet/0/LUN#0/Config/ssh/GuestPort, Value: 22
Key: VBoxInternal/Devices/pcnet/0/LUN#0/Config/ssh/Protocol, Value: TCP

Change History

comment:1 Changed 5 years ago by Hachiman

thank you for reporting, I've been able reproduce the problem and will update the progress here.

comment:2 Changed 5 years ago by lalala

I test upgrade 2.0.4 to 2.0.6 and it works

comment:3 Changed 5 years ago by frank

Ok, this seems to be a Windows-host-only problem. Anybody seen this on other hosts?

comment:4 Changed 5 years ago by Hachiman

The problem is detected and fixed. Fix will be included in next release.

comment:5 Changed 5 years ago by sandervl73

  • Summary changed from NAT port forwarding not working after upgrade from 2.0.4 to 2.1.0 to NAT port forwarding not working after upgrade from 2.0.4 to 2.1.0 -> fixed in SVN

comment:6 Changed 5 years ago by rafaelsantini

When will be the next release? I'm trying to downgrade from 2.1.0 because I really need NAT port forwarding. Can you send me a build with this fix?

comment:7 Changed 5 years ago by sandervl73

  • Status changed from new to closed
  • Resolution set to fixed
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use