VirtualBox

Ticket #2790 (closed defect: duplicate)

Opened 5 years ago

Last modified 5 years ago

kernel oops (sleeping function called from invalid context at include/linux/pagemap.h)

Reported by: axet Owned by:
Priority: major Component: other
Version: VirtualBox 2.1.0 Keywords:
Cc: Guest type: Windows
Host type: Linux

Description

dmesg

device wlan0 entered promiscuous mode
BUG: sleeping function called from invalid context at include/linux/pagemap.h:294
in_atomic():0, irqs_disabled():1
Pid: 13259, comm: VirtualBox Not tainted 2.6.27.7-134.fc10.i686 #1
 [<c0425f38>] __might_sleep+0xc6/0xcb
 [<c0479a82>] lock_page+0x15/0x2f
 [<c047b4a3>] handle_mm_fault+0x417/0x6d1
 [<c06a96fa>] do_page_fault+0x2fb/0x6ce
 [<c06a93ff>] ? do_page_fault+0x0/0x6ce
 [<c06a7cd2>] error_code+0x72/0x78
 [<c04026bf>] ? __switch_to+0xb9/0x139
 [<c042904a>] ? finish_task_switch+0x2f/0xb0
 [<c06a647f>] ? schedule+0x6ee/0x70d
 [<c047b74a>] ? handle_mm_fault+0x6be/0x6d1
 [<c06a7a93>] ? _spin_unlock_irqrestore+0x22/0x38
 [<c0443018>] ? clocksource_get_next+0x3c/0x43
 [<c0420939>] ? __enqueue_entity+0xe3/0xeb
 [<c04223a3>] ? enqueue_entity+0x203/0x20b
 [<c041d92c>] ? resched_task+0x3a/0x6e
 [<c04245c3>] ? check_preempt_wakeup+0x16f/0x177
 [<c04418c8>] ? getnstimeofday+0x3c/0xc9
 [<c041362f>] ? lapic_next_event+0x15/0x1c
 [<c04442a6>] ? clockevents_program_event+0xd4/0xe3
 [<c0445151>] ? tick_dev_program_event+0x28/0x95
 [<f9494360>] ? supdrvIOCtlFast+0x40/0x55 [vboxdrv]
 [<f9494107>] ? VBoxDrvLinuxIOCtl+0x0/0x164 [vboxdrv]
 [<f9494137>] ? VBoxDrvLinuxIOCtl+0x30/0x164 [vboxdrv]
 [<c06a647f>] ? schedule+0x6ee/0x70d
 [<c06a647f>] ? schedule+0x6ee/0x70d
 [<f9494107>] ? VBoxDrvLinuxIOCtl+0x0/0x164 [vboxdrv]
 [<c049a242>] ? vfs_ioctl+0x22/0x69
 [<c049a4d3>] ? do_vfs_ioctl+0x24a/0x25d
 [<c049a526>] ? sys_ioctl+0x40/0x5a
 [<c0403c76>] ? syscall_call+0x7/0xb
 =======================
[axet@axet-laptop ~]$ 

Change History

comment:1 Changed 5 years ago by frank

As far as I can see, this is actually not a kernel oops but a kernel warning. I assume you are on Fedora? What did you do to get this: Did you only load the kernel module or did you start a VM? How busy was your machine?

comment:2 Changed 5 years ago by axet

  • fedora 10
  • start vm with windows xp
  • i tried to apply last updates on windows xp with ie7 installation

comment:3 Changed 5 years ago by frank

  • Summary changed from kernel oops to kernel oops (sleeping function called from invalid context at include/linux/pagemap.h)

comment:4 Changed 5 years ago by frank

  • Status changed from new to closed
  • Resolution set to duplicate

Duplicate of #2556.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use