VirtualBox

Ticket #2779 (closed defect: duplicate)

Opened 5 years ago

Last modified 5 years ago

UNIX Guest Additions - X11 window stuck at 640x480 => duplicate of #2783

Reported by: sej7278 Owned by:
Priority: major Component: guest additions
Version: VirtualBox 2.1.0 Keywords: xorg, X11, additions
Cc: Guest type: Linux
Host type: Linux

Description

Fedora 10 64-Bit host.

Any Linux guest (Debian 4.0, RHEL 5u2, Ubuntu 8.04) has its X11/xorg stuck at the Framebuffer 640x480 resolution.

Its possibly a QT4 redraw bug as if you click the window's close icon, the menu thing pops up asking if you want to power off, acpi off etc; and it forces the window to redraw to 1024x768.

Resizing and seemless still don't work though, and fullscreen works but the resolution is stuck at 1024x768 (even on my 1280x1024 monitor).

Also mouse integration doesn't work on Solaris 10u6 64-Bit guests, although it doesn't seem to have the resolution problems of Linux (and Linux mouse integration works).

Problems only seems to occur with guests with Additions installed (be that 2.0.6 additions or 2.1.0 additions), if you boot to a kernel without the Additions, then the resolution problem goes away, although then you don't get mouse integration etc of course.

Change History

comment:1 Changed 5 years ago by michael

  • Status changed from new to closed
  • Resolution set to duplicate
  • Summary changed from UNIX Guest Additions - X11 window stuck at 640x480 to UNIX Guest Additions - X11 window stuck at 640x480 => duplicate of #2783

Marking as a duplicate of #2783, as that ticket has more comments.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use