VirtualBox

Ticket #2783 (closed defect: fixed)

Opened 5 years ago

Last modified 5 years ago

window is not resized when the X is restarted -> fixed in SVN

Reported by: stephanecharette Owned by:
Priority: major Component: guest additions
Version: VirtualBox 2.1.0 Keywords: X resize desktop
Cc: Guest type: Linux
Host type: Linux

Description (last modified by frank) (diff)

When a Debian Etch 4 64-bit guest is taken from text-mode into X, the VirtualBox window is not resized correctly. It stays the same size as the 80x25 text-mode console. The X desktop is then incorrectly drawn within this too-small window. (See attached.)

Repro steps:

  1. start Debian Etch 4 64-bit guest
  2. start a terminal window
  3. at the prompt, type "sudo /etc/init.d/gdm stop"
  4. the VB window will be resized, and you should now be in a text-mode console window
  5. login
  6. type "sudo /etc/init.d/gdm start"
  7. X will now start, but the VB window will remain the same size as it was for the text-mode console; the desktop will look "scrambled" as shown in the attached image

Note how the VB window wont correctly resize any bigger. It seems fixed at this size. (See attached image #2.)

To fix this problem:

  1. press: <HOST>+CTRL+F1
  2. one you are at the guest's text console, press ALT+F7 to return to X

The VB window will resize itself to accommodate the full desktop, and no redraw problem remains.

Attachments

large_desktop_in_small_window.png Download (78.5 KB) - added by stephanecharette 5 years ago.
scrambled desktop when a large desktop is forced to display in a small VB window
large_desktop_in_large_window.png Download (76.7 KB) - added by stephanecharette 5 years ago.
scrambled desktop is not fixed/redrawn even when the VB window is enlarged

Change History

Changed 5 years ago by stephanecharette

scrambled desktop when a large desktop is forced to display in a small VB window

Changed 5 years ago by stephanecharette

scrambled desktop is not fixed/redrawn even when the VB window is enlarged

comment:1 Changed 5 years ago by martin.heimes

same here with debian etch 32bit guest except that the contents of the too small window is not scrambled, just cut off.

same workaround

debian lenny host 32bit if that matters

comment:2 Changed 5 years ago by jrobbo

I'm having the same problems, running Ubuntu 8.10 as my host, and RedHat 5.3 as a guest, both are 32-bit. The workaround provided above works for me

comment:3 Changed 5 years ago by frank

This looks like a duplicate of #2779.

comment:4 Changed 5 years ago by sej7278

Workaround doesn't fix resizing - now its just stuck at 1024x768 instead of 640x480.

Seemless mode still doesn't work.

It kind of is a duplicate of my ticket 2779, although there I add comments about Solaris, another workaround and a possible cause.

Apparently Sun QA tested Linux guests - I'd like to know which guest/host combination they used as it seems nobody else has gotten it to work.....

comment:5 Changed 5 years ago by abitgroggy

Same initial problem on Centos 5.2 with all latest updates (kernel 2.6.18-92.1.22.el5).

Work around listed here fixes login window size and allowed me to reconfig display and adjust size as desired after login.

Right now the copy/paste is not working, but it has never been 100% reliable.

Hopefully 2.1.1 will fix all so no work around is required.

comment:6 Changed 5 years ago by martin.heimes

same problem with Ubuntu 6.06 guest ... just for the record

comment:7 Changed 5 years ago by mstevens

I'm also seeing this problem, Windows Vista host, Debian stable guest.

comment:8 Changed 5 years ago by michael

Marked #2779 and #2877 as duplicates.

comment:9 Changed 5 years ago by frank

  • Description modified (diff)

comment:10 Changed 5 years ago by michael

  • Summary changed from window is not resized when the X is restarted to window is not resized when the X is restarted -> fixed in SVN

This should be fixed in the development sources.

comment:11 Changed 5 years ago by sandervl73

  • Status changed from new to closed
  • Resolution set to fixed
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use