VirtualBox

Ticket #2709 (closed defect: fixed)

Opened 5 years ago

Last modified 4 years ago

vbox aborts (instantly dies) frequently after latest upgrade - VirtualBox[8779]: segfault at 00000014 eip b607bc36 => Fixed in SVN

Reported by: alphabeat Owned by:
Priority: major Component: other
Version: VirtualBox 2.0.6 Keywords: segfault
Cc: Guest type: Windows
Host type: Linux

Description

Ubuntu 8.04 running latest vbox which a WinXP SP3 machine with a VPN and VNC viewer running with ShieldDeluxe virus scanner.

Periodically (without obvious event) the machine just aborts usually when I move to another application in Ubuntu.

Ubuntu 8.04 with latest patches dmesg after event:

[16416.375688] VirtualBox[6478]: segfault at 00000044 eip b60a9c36 esp b3f8c260 error 6 [20239.864500] VirtualBox[7413]: segfault at 0000001c eip b606ac36 esp b3f3c260 error 6 [86623.758037] VirtualBox[8779]: segfault at 00000014 eip b607bc36 esp b4055260 error 6

This wasn't happening before the latest vbox upgrade to what I assumeis the latest version of vbox.

Attachments

vb.log Download (32.3 KB) - added by george_s 5 years ago.
log after crashing/dying VB2.1.0

Change History

comment:1 Changed 5 years ago by smartcat99s

This is happening to me quite a bit on Arch Linux as host with the upgrade to VirtualBox 2.1.0 (64bit PUEL). Windows XP SP3 is the guest. The first two segfaults were when 3D acceleration was on, the last one was when it was off.

It usually only takes less than 5 minutes from initial boot to segfault.

Host /proc/version: Linux version 2.6.28-rc6-blackice1 (root@atlantis) (gcc version 4.3.2 (GCC) ) #1 SMP PREEMPT Thu Nov 27 11:05:25 CST 2008

VirtualBox[15959]: segfault at 2b ip 00007fd6ad050d07 sp 00007fd6a8540630 error 6 in VBoxDD.so[7fd6acfb1000+1b0000]
VirtualBox[16052]: segfault at 3fc000000b9 ip 00007f27f1c43d07 sp 00007f27ed133630 error 6 in VBoxDD.so[7f27f1ba4000+1b0000]
VirtualBox[16104]: segfault at fffffffffffffff8 ip 00007fefec399352 sp 00007fefe392ad18 error 6 in libstdc++.so.6.0.10[7fefec2d9000+f0000] 

comment:2 Changed 5 years ago by frank

alphabeat, please could you provide a  core dump? Please contact me at frank _dot_ mehnert _at_ sun_ dot_ com. Please don't forget to report the exact package you used. smartcat99s, a core dump from you would be less informative (because I don't have ArchLinux here) but could help anyway.

comment:3 Changed 5 years ago by george_s

I'm also getting random crashes in Fedora 10

Dec 22 12:00:31 xxxxxx kernel: VirtualBox[4176]: segfault at 19 ip 017fa0ef sp b5323f50 error 6 in VBoxDD.so[1750000+1b2000]

comment:4 Changed 5 years ago by bb83

Same problem here: VirtualBox[6183]: segfault at 31 ip 00007f5848db8cb7 sp 00007f58482c2c80 error 6 in VBoxDD.so[7f5848d1d000+1b0000]

comment:5 Changed 5 years ago by wnicholls

Confirm - on Hardy Ubuntu 64bit host, Windows XP SP3 guest, using VBox 2.1 packages from  http://download.virtualbox.org/virtualbox/debian hardy

Architecture: amd64 Version: 2.1.0-41146_Ubuntu_hardy Config-Version: 2.1.0-41146_Ubuntu_hardy

I'd get to do work for 10-15 minutes, then it would abort instantly, just vanish. Usually while compiling under MS Visual Studio (2008), so maybe when processor hits high load? Not using VT-x. Asus laptop, Intel Core Duo. /var/log/messages shows:

Dec 28 20:41:15 laputa kernel: [12915.023802] VirtualBox[8152]: segfault at 31 rip 7f9a1f936147 rsp 419e2c30 error 6 Dec 28 23:33:18 laputa kernel: [22880.913114] VirtualBox[26994]: segfault at 31 rip 7fe5eb321147 rsp 40286c30 error 6 Dec 29 10:37:07 laputa kernel: [ 4056.707580] VirtualBox[505]: segfault at 3931829c98 rip 7f5107ca413c rsp 402ecc30 error 7 Dec 29 21:52:43 laputa kernel: [ 5296.111180] VirtualBox[13824]: segfault at 178 rip 7fa26e4c713c rsp 40938c30 error 6 Dec 29 22:08:44 laputa kernel: [ 6244.682717] VirtualBox[396]: segfault at 31 rip 7f8746659147 rsp 41377c30 error 6

I don't know enough to tell how many variations there are, ASLR could account for some of it.

I've gone back to 2.0.6 - so far this seems stable.

comment:6 Changed 5 years ago by bb83

Same behavior! arch64 / Guest: winxpsp3

comment:7 Changed 5 years ago by george_s

core dump uploaded to incoming.

comment:8 Changed 5 years ago by frank

George, your core dump is interesting. What did you exactly and how easy it is to reproduce the problem? This is something NAT-related. Which guest are you using? Did you experience similar crashes with VirtualBox 2.0.6 as well? Can you attach a VBox.log of such a crashing session?

comment:9 Changed 5 years ago by george_s

Hi Frank,

The crashes generally happen almost daily but randomly (for the core dump I had to leave VB running overnight and it crashed on the second day). I cannot put a finger on anything in particular that causes this. Guest is Windows XP SP3 (32 bit) on 32 bit Fedora 10 host. I had no problems like this using VB 2.0.6. Is this related to ticket #2974? I will try to reproduce and attach a log.

Changed 5 years ago by george_s

log after crashing/dying VB2.1.0

comment:10 Changed 5 years ago by george_s

Hi Frank,

Log attached.

comment:11 Changed 5 years ago by robertdale

I can always reproduce this problem. Windows XP guest on Fedora 9 (2.6.27.9-73.fc9.x86_64) using Firefox 3 to do math homerwork using MyMathLab at mathxl.com.

Jan 13 19:09:19 superluminal kernel: VirtualBox[3004]: segfault at 31 ip 00007f8481804ef7 sp 0000000040074c10 error 6 in VBoxDD.so[7f848176e000+1a9000]

If there's something more I can do to help debug the problem let me know!

comment:12 Changed 5 years ago by frank

  • Summary changed from vbox aborts (instantly dies) frequently after latest upgrade - VirtualBox[8779]: segfault at 00000014 eip b607bc36 to vbox aborts (instantly dies) frequently after latest upgrade - VirtualBox[8779]: segfault at 00000014 eip b607bc36 => Fixed in SVN

Robert confirmed that the problem is most probably fixed. Thanks for the report.

comment:13 Changed 5 years ago by george_s

Hi Frank

VirtualBox-2.1.1-41544-Linux_x86.run has been running continously without issues for approx 48 hours.

Thanks for fixing this.

Regards.

comment:14 Changed 5 years ago by george_s

There may still be issues with the NAT networking.

Instead of segfaulting and dying there may be random disconnections in XP SP3.

Clearly not so serious a problem.

comment:15 Changed 5 years ago by smartcat99s

I am still segfaulting regularly on 2.1.2r41885. I often have less than 5 minutes from boot to segfault (Arch64 host, precompiled PUEL VB).

comment:16 Changed 5 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

These SEGFAULTs should be finally gone with 2.1.4. Please open separate issues for other problems.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use