VirtualBox

Ticket #2974 (closed defect: fixed)

Opened 5 years ago

Last modified 5 years ago

Virtualbox 2.1 Crash - possibly due to new NAT code Problem

Reported by: ariel Owned by:
Priority: critical Component: network/NAT
Version: VirtualBox 2.1.0 Keywords: nat
Cc: Guest type: Windows
Host type: Linux

Description

Many people are reporting hard crashes with VB 2.1 when using applications that use the network like email clients.

In many reports I've seen, and in my particular case, this is with Ubuntu 8.10 AMD64 Host, WinXP SP3 guest, having several crashes per day typically when using outlook (trying to send an email, or forcing a refresh). The logfile does not show anything, but I see this with dmesg:

VirtualBox[11017]: segfault at 35 ip 00007f48ae153147 sp 00000000401cac10 error 6 in VBoxDD.so[7f48ae0c0000+1ad000]

This is the forum thread were reports have been accumulating in the past few days:

 http://forums.virtualbox.org/viewtopic.php?p=53289#53289

People report that a workaround is not to use NAT - use host interface networking instead.

Attachments

VBDump.tcpdump Download (58.3 KB) - added by andyward 5 years ago.
tcpdump of virtualbox crashing

Change History

comment:1 Changed 5 years ago by nathan.modrzewski

I'm also getting this error running VirtualBox on Ubuntu 8.10. The guest OS is Windows XP SP3, using NAT networking.

The kernel contains these messages with the "VirtualBox" string:

[ 7495.747392] VirtualBox[6627]: segfault at 19 ip b4b119ff sp b3713f70 error 6 in VBoxDD.so[b4a69000+1b4000] [ 8161.743527] VirtualBox[8218]: segfault at 12 ip b47bb9f9 sp b3404f70 error 6 in VBoxDD.so[b4713000+1b4000] [16296.430618] VirtualBox[8671]: segfault at 19 ip b4a849ff sp b2aa5f70 error 6 in VBoxDD.so[b49dc000+1b4000] [17063.860594] VirtualBox[10020]: segfault at 19 ip b47639ff sp b4531f70 error 6 in VBoxDD.so[b46bb000+1b4000] [44589.818479] VirtualBox[13172]: segfault at 34 ip b49a09f9 sp b299af70 error 6 in VBoxDD.so[b48f8000+1b4000] [49690.032169] VirtualBox[21616]: segfault at 1d ip b4a3f9ff sp b2a28f70 error 6 in VBoxDD.so[b4997000+1b4000]

Thanks,

-- Nathan

comment:2 Changed 5 years ago by frank

We've got a core dump from George, see #2709, sounds like related. We are currently trying to reproduce the problem. The easier we can reproduce the problem the sooner we can fix it.

comment:3 Changed 5 years ago by frank

  • Component changed from network to network/NAT

comment:4 Changed 5 years ago by bhebing

The forum article only mentions linux hosts. However, the problem also exists on Windows. In my case Windows Vista Business SP1 32-bits. The relevant bit from the event log:

Faulting application VirtualBox.exe, version 0.0.0.0, time stamp 0x4948cd1a, faulting module VBoxDD.DLL, version 0.0.0.0, time stamp 0x4948cd62, exception code 0xc0000005, fault offset 0x00072bf6, process id 0x1ec8, application start time 0x01c97aea0593ad70.

Looks like the same module (VBoxDD).

Changed 5 years ago by andyward

tcpdump of virtualbox crashing

comment:5 Changed 5 years ago by andyward

I just uploaded tcpdump output of VBox crashing on my PC. I'm running version 2.1.2 on a fedora 10 x86_64 host (2.6.27.12 kernel) and guest is XP SP3 32-bit. I'm using NAT networking. Not sure if it's related but the crash appears to coincide with a window size change on the guest (32896 bytes to 49408) following a large (8.5k) packet.

Andy

comment:6 Changed 5 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

The crash should be actually fixed in 2.1.4.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use