VirtualBox

Ticket #2605 (closed defect: fixed)

Opened 5 years ago

Last modified 5 years ago

Crash with snow screen with guest Windows XP SP2

Reported by: hkfastfood Owned by:
Priority: critical Component: other
Version: VirtualBox 2.0.6 Keywords: crash shared folder
Cc: forum.me@… Guest type: Windows
Host type: Mac OS X

Description

VBox crashes 2 times a day for the last few days. I think it may be related to shared folder. Case 1: When I open an Excel file in Mac OS X 10.4 (Tiger) and never close the Excel file, for unknown no. of hours, I saved it. Then crash the VBox and snow screen. Case 2: My MS Outlook 2003 points to a personal file located in Mac OS X folder (through the shared folder). Not repeatable; but, when I compose a new email and press the "Send" button, then crash again and the same snow screen. Case 3: When I open the file Explore showing the shared folder files and leave it here to have lunch, after that, when I double click an Excel to open it, VBox crashed and snow screen shown.

For your information, I always connect with VPN using checkpoint.

Attachments

VBox.log.1 Download (59.4 KB) - added by hkfastfood 5 years ago.
log-file-1
VBox.log Download (54.9 KB) - added by hkfastfood 5 years ago.
log-file-0
VBox.2.log Download (51.9 KB) - added by hkfastfood 5 years ago.
log as at 26-nov-2008 10:00 something
Snapshot 2008-11-26 22-26-10.jpg Download (301.4 KB) - added by hkfastfood 5 years ago.
cannot find minidump folder in my guest
windows.log Download (12.0 KB) - added by hkfastfood 5 years ago.
dir c:\windows log

Change History

Changed 5 years ago by hkfastfood

log-file-1

Changed 5 years ago by hkfastfood

log-file-0

comment:1 Changed 5 years ago by hkfastfood

I just upgrade from 2.0.4 to 2.0.6 two days before including the Guest Addition from 2.0.4 to 2.0.6. And today still crash. Attach the latest vbox log file for investigation.
Really really Sun would fix this issue because this bug would STOP VBox goes for PRODUCTION. If just for fun and home user, it is fine. But for office user, VBox can do nothing with Parallels Desktop and VMWare if they never read and reply public track like this one.
Sad...

Changed 5 years ago by hkfastfood

log as at 26-nov-2008 10:00 something

comment:2 Changed 5 years ago by sandervl73

Calm down. Support is on a best effort basis here. Yelling won't encourage us to help you.

comment:3 Changed 5 years ago by sunlover

  • Version changed from VirtualBox 2.0.4 to VirtualBox 2.0.6

Could you attach the crash minidump from the guest (\Windows\Minidump\Mini*.dmp)?

Changed 5 years ago by hkfastfood

cannot find minidump folder in my guest

comment:4 Changed 5 years ago by hkfastfood

Thank you for helping but I cannot find the minidump folder in my guest (please see attached JPG) and in Mac OS X folder. What's next?

comment:5 Changed 5 years ago by sunlover

On the screenshot I see only a small part of the \Windows directory. Can you scroll down the list to directories with names, which begin from a alphabet character? For example: Fonts, Help, ..., system, system32...

Changed 5 years ago by hkfastfood

dir c:\windows log

comment:6 Changed 5 years ago by hkfastfood

The screen captured is already sort. By the way, I dir the c:\windows to a log and really does not have the minidump directory. Kindly advice.

comment:7 Changed 5 years ago by sunlover

Most likely minidumps are disabled on your system. Please have a look at  http://support.microsoft.com/kb/315263 There is some information about enabling minidumps: "Configure the dump type".

comment:8 Changed 5 years ago by hkfastfood

Actually the minidump is already enable %SystemRoot%\minidump. For safety, 2 hours ago I change it to c:\minidump (yes, I was mkdir in c:\minidump).

Few minutes ago, Vbox snow screen shown again. However, it is empty in c:\minidump. I have double checked "error reporting" in my VM is ON. It's strange.

For your information, I switch on the VPN and with latest patch on MS Office 2003. MS Outlook 2003 is ON. There is a personal folder points to my Mac OS X through Vbox shared folder. Anti-virus uses Avast! Home Edition.

This time I open the Firefox and using web mail (Horde). Click the attachment [Browse] button. A pop-up for me to select files. I choose "My Network Place" and click the first level "Shared Folder" of my Mac. Then snow screen comes up. I then use Mac Activity Monitor to view the Virtual Box, the CPU goes up high to 110% of the core 2 dual CPU.

Then I "Quit Virtual Box" using "Send Shut Down Signal".

Start the VM, and "cmd" to see "c:\minidump" folder and find nothing there as well as c:\windows (even no minidump folder as there never exist this folder).

This case I wonder that the VM might not be hanged otherwise, the "Send Shut Down Signal" should not work. However, the video got a bug and eats up CPU to refresh or fix the screen causing by traversing to shared folder. Just a crazy observation.

comment:9 Changed 5 years ago by hkfastfood

After the crash, I stop using it for few hours. Planning to test if only happens with Firefox webmail - horde - attachment. The answer is yes, I can repeat the snow screen while double clicking the VBOX shared folder just in the Network Places.

Then, I stop/start the same VM and want to repeat it once more but cannot.

However, when I try stop/start (normal Windows shutdown) for 3 times, I can repeat this snow screen by #1 click the VBOX shared folder #2 down for 2 levels and then #3 press the up one level of directory from the dialogue box. The snow screen comes up.

The CPU from Activity Monitor goes up to 100%.

I guess that even you do not have my VM you can easily encounter the snow screen. Hope my test could help to resolve this annoying issue.

comment:10 Changed 5 years ago by hkfastfood

Greetings to you.

Just resume the VM from "Saved State" this morning which contains no running application, no VPN connection, no MS Outlook. I then open the firefox and use webmail to repeat the snow screen. So, I go to new an email. From there, I click the attachment button. A pop-up dialogue box comes up asking for attachments. Click the "My Network Places" on the right hand side. And, then DOUBLE CLICK (not pressing the OPEN button) the "Vbox shared folder". Ooops, it crashed and snow screen.

I cmd-Q the Vbox and select "Send Shutdown Signal". It is closed normally. Again, there is nothing inside C:\Minidump.

From the few tests done today and yesterday, the so-called crash can be simulated and repeated. One strange point is that I cannot find the 'Entire Network' from the normal file explorer. But this 'Entire Network' can be found in the pop-up file dialogue box for browser and other applications such as MS Word, MS Excel, etc. For my daily general access, I map drive Z: to the top shared folder in my Mac.

Just guess it is caused by the accessing the shared folder too quick before the related process runs in a stable state - multi-threading issue???. :) Just a silly guess and very layman.

Much much appreciate if sunlover provides an assistance on this issue. Many thanks in advance.

comment:11 Changed 5 years ago by sunlover

Could you please try with VirtualBox 2.1.2. Make sure that the guest additions are also updated to 2.1.2.

comment:12 Changed 5 years ago by hkfastfood

Thank you so much for the hard works of the VBox team.

2 things.

First, I mapped to 2 shared folders in my MacBook which contains limited folder levels and files in VBox 2.1.0 version with the corresponding GuestAddition installed. It works fine. And, no performance trade off and crashes.

Second, I install VBox 2.1.2 and its GuestAddition. Then mapped to the Documents of the Mac which caused crashes many times in before. This time it works fine in all aspects but a little bit overall performance dropped.

Thank you so much. This issue is settled.

comment:13 Changed 5 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use