VirtualBox

Ticket #2557 (closed defect: invalid)

Opened 5 years ago

Last modified 4 years ago

Windows XP guest BSOD crash

Reported by: myxiplx Owned by:
Priority: major Component: other
Version: VirtualBox 2.0.4 Keywords:
Cc: Guest type: Windows
Host type: Linux

Description

Virtualbox 2.0.4 seems much better than 2.0.2, but I just had Windows XP BSOD and reboot on me. At the time I was just connecting an RDP session to one of our servers, so again it looks like this might be network related.

I have the Windows XP crash dump (attached), and the full VirtualBox log. I've not attached the VirtualBox log since it's 13MB in size - it appears that the virtual machine kept running fine this time. Please let me know if you do need that file.

The windows event log reported an event 1001 - Save Dump, with description:

The computer has rebooted from a bugcheck.  The bugcheck was: 0x10000050 (0xf8321000, 0x00000000, 0xf441be51, 0x00000000). A dump was saved in: C:\WINDOWS\Minidump\Mini110308-01.dmp.

I believe the relevant section from the VirtualBox log is this, but to me it doesn't appear to have much to say regarding the crash:

95:59:23.373 Display::handleDisplayResize(): uScreenId = 0, pvVRAM=b1a19000 w=1224 h=808 bpp=0 cbLine=0x640
95:59:23.373 VBVA: Disabled.
95:59:23.405 Display::handleDisplayResize(): uScreenId = 0, pvVRAM=b1a19000 w=640 h=480 bpp=0 cbLine=0x140
95:59:24.421 Changing the VM state from 'RUNNING' to 'RESETTING'.
95:59:24.734 CPUMSetGuestCpuIdFeature: Enabled APIC
95:59:24.734 PIT: mode=3 count=0x10000 (65536) - 18.20 Hz (ch=0)
95:59:24.734 SharedFolders host service: disconnected, u32ClientID = 1
95:59:24.747 PIIX3 ATA: Ctl#0: finished processing RESET
95:59:24.847 PIIX3 ATA: Ctl#1: finished processing RESET
95:59:24.963 Changing the VM state from 'RESETTING' to 'RUNNING'.
95:59:24.977 Guest Log: BIOS: VirtualBox 2.0.4
95:59:24.977 PIT: mode=2 count=0x10000 (65536) - 18.20 Hz (ch=0)
95:59:24.998 PIIX3 ATA: Ctl#0: RESET, DevSel=0 AIOIf=0 CmdIf0=0xe0 (-1 usec ago) CmdIf1=0x00 (-1 usec ago)
95:59:24.998 PIIX3 ATA: Ctl#0: finished processing RESET
95:59:24.998 Guest Log: BIOS: ata0-0: PCHS=16383/16/63 LCHS=1024/255/63
95:59:24.998 PIIX3 ATA: Ctl#1: RESET, DevSel=0 AIOIf=0 CmdIf0=0xa0 (-1 usec ago) CmdIf1=0x00 (-1 usec ago)
95:59:24.998 PIIX3 ATA: Ctl#1: finished processing RESET
95:59:24.999 PIT: mode=2 count=0x48d3 (18643) - 64.00 Hz (ch=0)
95:59:25.004 Display::handleDisplayResize(): uScreenId = 0, pvVRAM=b1a19000 w=640 h=480 bpp=32 cbLine=0xA00
95:59:26.980 PIT: mode=2 count=0x10000 (65536) - 18.20 Hz (ch=0)
95:59:26.980 Guest Log: BIOS: Booting from LAN...
95:59:26.987 Guest Log: PXE ROM built on May 14 2008
95:59:26.988 PCNet#0: Init: ss32=0 GCRDRA=0x0009cfe2[1] GCTDRA=0x0009cfea[1]
95:59:26.996 Guest Log: BIOS: *** int 15h function AX=D04F, BX=4F43 not yet supported!
95:59:26.996 Display::handleDisplayResize(): uScreenId = 0, pvVRAM=00000000 w=720 h=400 bpp=0 cbLine=0x0
95:59:26.997 PCNet#0: Init: ss32=0 GCRDRA=0x0009cfe2[1] GCTDRA=0x0009cfea[1]
95:59:27.027 Guest Log: msgtype: 2
95:59:27.028 Guest Log: subnet: 255.255.255.0
95:59:27.028 Guest Log: srvid: 192.168.1.10
95:59:27.028 Guest Log: router: 192.168.1.27
95:59:27.028 Guest Log: Client_IP: 192.168.1.192
95:59:27.029 Guest Log: Gateway_IP: 192.168.1.27
95:59:27.029 Guest Log: msgtype: 2
95:59:27.029 Guest Log: srvid: 192.168.1.39
95:59:29.011 Guest Log: class: PXEClientBIOS: *** int 15h function AX=D04F, BX=4F43 not yet supported!
95:59:29.012 PCNet#0: Init: ss32=0 GCRDRA=0x0009cfe2[1] GCTDRA=0x0009cfea[1] (CSR0_MISS disabled)
95:59:29.013 Guest Log: msgtype: 5
95:59:29.013 Guest Log: srvid: 192.168.1.10
95:59:29.013 Guest Log: subnet: 255.255.255.0
95:59:29.013 Guest Log: router: 192.168.1.27
95:59:29.013 Guest Log: Client_IP: 192.168.1.192
95:59:29.013 Guest Log: Gateway_IP: 192.168.1.27BIOS: *** int 15h function AX=D04F, BX=4F43 not yet supported!
95:59:29.014 PCNet#0: Init: ss32=0 GCRDRA=0x0009cfe2[1] GCTDRA=0x0009cfea[1] (CSR0_MISS disabled)
95:59:29.016 Guest Log: msgtype: 5
95:59:29.016 Guest Log: srvid: 192.168.1.39
95:59:29.016 Guest Log: class: PXEClient
95:59:29.016 Guest Log: msgtype: 5
95:59:29.016 Guest Log: srvid: 192.168.1.39
95:59:29.020 Guest Log: class: PXEClient
95:59:29.020 Guest Log: msgtype: 5
95:59:29.020 Guest Log: srvid: 192.168.1.10
95:59:29.020 Guest Log: subnet: 255.255.255.0
95:59:29.020 Guest Log: router: 192.168.1.27
95:59:29.020 Guest Log: Client_IP: 192.168.1.192
95:59:29.020 Guest Log: Gateway_IP: 192.168.1.27
95:59:29.020 Guest Log: msgtype: 5
95:59:29.020 Guest Log: srvid: 192.168.1.39
95:59:29.020 Guest Log: class: PXEClient
95:59:29.020 Guest Log: msgtype: 5
95:59:29.020 Guest Log: srvid: 192.168.1.39
95:59:29.105 PCNet#0: Init: ss32=0 GCRDRA=0x0009cfe2[1] GCTDRA=0x0009cfea[1] (CSR0_MISS disabled)
95:59:35.004 Guest Log: class: PXEClientBIOS: Boot from LAN failed
95:59:35.021 Guest Log: BIOS: Booting from Hard Disk...
95:59:35.400 Guest Log: BIOS: int13_harddisk: function 15, unmapped device for ELDL=81
95:59:39.124 PIT: mode=2 count=0x2ead (11949) - 99.85 Hz (ch=0)
95:59:39.184 Display::handleDisplayResize(): uScreenId = 0, pvVRAM=b1a19000 w=640 h=480 bpp=0 cbLine=0x140
95:59:41.034 PIIX3 ATA: LUN#0: IDLE IMMEDIATE, CmdIf=0xef (-1 usec ago)
95:59:41.034 PIIX3 ATA: LUN#0: aborting current command
95:59:47.999 Guest Additions information report: additionsVersion = 0x00010004  osType = 0x00033000
95:59:48.001 Guest requests mouse pointer integration
95:59:48.004 Guest reported fixed hypervisor window at 0xf6400000 (size = 0x800000, rc = VINF_SUCCESS)
95:59:48.148 PCNet#0: Init: ss32=1 GCRDRA=0x02e0d420[64] GCTDRA=0x02e0d020[64]
95:59:48.152 Guest adapter information contains unsupported type 5. The block has been skipped.
95:59:48.187 SharedFolders host service: connected, u32ClientID = 4
95:59:48.397 PCNet#0: Init: ss32=1 GCRDRA=0x02e0d420[64] GCTDRA=0x02e0d020[64]
95:59:49.511 Display::handleDisplayResize(): uScreenId = 0, pvVRAM=b1a19000 w=1920 h=1200 bpp=32 cbLine=0x1E00
95:59:49.511 VBVA: Enabled.
95:59:52.481 PCNet#0: Init: ss32=1 GCRDRA=0x02e0d420[64] GCTDRA=0x02e0d020[64]
96:00:11.279 Guest Log: VBoxService: Started.
96:00:18.688 Guest Log: vboxVMInfoThread: GuestProp ClientID = 5
96:00:28.548 Guest Log: VBOXNP: DLL loaded.
96:00:30.138 Guest Log: VBOXNP: DLL unloaded.
96:02:22.221 Guest Log: VBOXNP: DLL loaded.
96:02:22.973 Guest Log: VBOXNP: SendToMiniRdr: Returning error from DeviceIoctl! Status = 67 
96:02:23.061 Guest Log: VBOXNP: SendToMiniRdr: Returning error from DeviceIoctl! Status = 67 
96:02:23.061 Guest Log: VBOXNP: NPGetConnection: Returned error 0x43
96:02:23.408 Guest Log: VBOXNP: DLL loaded.
96:02:24.399 Guest Log: VBOXNP: DLL loaded.
96:02:24.409 Guest Log: VBOXNP: SendToMiniRdr: Returning error from DeviceIoctl! Status = 67 
96:02:24.409 Guest Log: VBOXNP: NPGetConnection: Returned error 0x43
96:02:24.421 Guest Log: VBOXNP: SendToMiniRdr: Returning error from DeviceIoctl! Status = 67 
96:02:24.421 Guest Log: VBOXNP: NPGetConnection: Returned error 0x43
96:02:24.465 Guest Log: VBOXNP: DLL unloaded.
96:02:28.798 Guest Log: VBoxTray: Started.
96:02:28.821 Guest Additions capability report: (0x5) seamless: yes, hostWindowMapping: no, graphics: yes
96:02:32.082 PCNet#0: Init: ss32=1 GCRDRA=0x02e0d420[64] GCTDRA=0x02e0d020[64]
96:02:32.839 Guest Log: VBOXNP: DLL loaded.

Ross

Attachments

Mini110308-01.dmp Download (88.0 KB) - added by myxiplx 5 years ago.
Windows crash dump log

Change History

Changed 5 years ago by myxiplx

Windows crash dump log

comment:1 Changed 5 years ago by sunlover

  • Status changed from new to closed
  • Resolution set to invalid

Thanks for detailed information. It is a crash in MRXDAV.SYS driver. You have to disable the WebClient service or install a hotfix from Microsoft:  http://support.microsoft.com/kb/832143

See  http://forums.virtualbox.org/viewtopic.php?t=2155&start=0&postdays=0&postorder=asc&highlight=mrxdav especially the last message for details.

I'll close this ticket because the problem is not a VirtualBox bug.

comment:2 Changed 5 years ago by myxiplx

Cool, thanks for the quick reply. I'll disable that service straight away.

We have a standard windows install that rarely changes so I never thought to look for problems in windows. I completely forgot that I'd recently installed SP3 on this machine, sorry about that.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use