VirtualBox

Ticket #2525 (closed defect: obsolete)

Opened 10 years ago

Last modified 3 years ago

Keyboard and mouse freeze, Vista host, Ubuntu guest

Reported by: Natovr Owned by:
Priority: major Component: other
Version: VirtualBox 2.0.4 Keywords:
Cc: Guest type: Linux
Host type: Windows

Description (last modified by frank) (diff)

When I start up Ubuntu under Vista host, my keyboard and mouse freezes. The freeze happens as soon as I can see the Ubuntu GUI. I can't get host control back because the keyboard is frozen. I can't shut down the virtual machine because the mouse is frozen. Sceen activity continues, but no interface with the host or guest. I have to do a force shut-down to exit this state...

Also, this seems to be a random error... the graphics card driver crashes and the computer restarts by itself. I updated the driver yesterday (27 Oct 2008)

Attachments

VBox.log Download (38.3 KB) - added by Natovr 10 years ago.
First attempt at Ubuntu startup
VBox.2.log Download (29.6 KB) - added by Natovr 10 years ago.
Debian startup (this one, the graphics card driver crashed)
VBox.log.1 Download (29.6 KB) - added by Natovr 10 years ago.
Second Debian startup... this one, the KB and mouse crashed. Note: this is a netinst CD ISO file

Change History

Changed 10 years ago by Natovr

First attempt at Ubuntu startup

Changed 10 years ago by Natovr

Debian startup (this one, the graphics card driver crashed)

Changed 10 years ago by Natovr

Second Debian startup... this one, the KB and mouse crashed. Note: this is a netinst CD ISO file

comment:1 follow-up: ↓ 2 Changed 10 years ago by mabrahamsson

Hi,

Are you using a laptop with both wireless and wired network connections? I get the same errors though only when using the wired connection.

comment:2 in reply to: ↑ 1 Changed 10 years ago by Natovr

Replying to mabrahamsson:

Hi,

Are you using a laptop with both wireless and wired network connections? I get the same errors though only when using the wired connection.

No, I'm just using wireless, but there is a slot for wired Ethernet. I haven't used it in a while.

comment:3 Changed 9 years ago by aminhosseiny

i have the same problem man!!! nobody can help us? so if there is no solution i'll try vmware...who knows more workstation?

comment:4 Changed 9 years ago by sandervl73

  • Summary changed from Keyboard and mouse freeze, Vista host, Ubuntu guest to Keyboard and mouse freeze, Vista host, Ubuntu guest -> fixed in SVN/2.1.4

Fixed in 2.1.4. Wait a bit.

comment:5 Changed 9 years ago by sandervl73

  • Status changed from new to closed
  • Resolution set to duplicate

Duplicate of #1606.

comment:6 Changed 9 years ago by jswdb

  • Status changed from closed to reopened
  • Resolution duplicate deleted

Problem still exists: Host = Ubuntu-Linux 9.04 64-bit, Guest = Windows Vista 32-bit.

Running in a window the workaround (as described elsewhere) is to minimize and restore the guest.

However when running full-screen and the keyboard gets locked there is no way to gain back access nor to the Vista guest, nor to the underlying Linux host. Need to hit the reset-button. Not so nice.

comment:7 Changed 9 years ago by MrX1980

Please try it with v3.0.0

comment:8 Changed 9 years ago by jswdb

Thanks for your suggestion MrX1980. No change of behaviour, though. Some more observations:

  • running ubuntu Desktop 9.04 patches applied
  • running VB 3.0.0
  • running Windows Vista (SP1) in a window
  • waiting +- 15 min
  • clicking inside the VB-window, I can move around any Vista window, drag drop, etc.
  • obviously the mouse is grabbed by VB - this is also visible through the icon in the bottom-right corned of the VB-window.
  • However the keyboard icon remains grey. There is no way to grab the keyboard by typing (i.e. right-ctrl, alt, c, etc.)
  • the only way to give control back to the keyboard is clicking any host-application, then clicking the Windows-Vista guest again. Now all is well.
  • The down-side of this workaround is that it does NOT work whenever the Windows-Vista guest is full-screen (right-ctrl-F).

comment:9 Changed 9 years ago by frank

  • Summary changed from Keyboard and mouse freeze, Vista host, Ubuntu guest -> fixed in SVN/2.1.4 to Keyboard and mouse freeze, Vista host, Ubuntu guest

comment:10 Changed 3 years ago by frank

  • Status changed from reopened to closed
  • Resolution set to obsolete
  • Description modified (diff)
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use