VirtualBox

Ticket #2523 (closed defect: duplicate)

Opened 5 years ago

Last modified 5 years ago

Aladdin Hardlock / HASP Drivers and Dongles do not work in Windows 2000+

Reported by: ashman Owned by:
Priority: blocker Component: USB
Version: VirtualBox 2.0.4 Keywords: hardlock hasp driver aladdin
Cc: Guest type: Windows
Host type: Windows

Description

The installation of Aladdin Hardlock / HASP drivers and thus usage of these dongles does not work in Windows 2000 with Service Pack 4. This might also apply to Windows XP (I know it was a problem in 1.5.x) and Windows Vista with different Service Pack versions.

If you install the Aladdin "HASP SRM Run-time Command-line Installation" drivers a Blue Screen of Death is triggered and in another case the VM crashed. Also the guest OS might not boot again after the driver installation. I think this can be tested without an attached dongle by just installing the drivers.

I try this on WindowsXP Service Pack 3 with later updates applied. The VirtualBox settings are pretty much standard except that USB Controller and USB 2.0 support is activated, RAM is set to 512MB and network support is deactivated. The VM Additions are installed. Processor is a Athlon X2.

HASP SRM Run-time Command-line Installation:

Driver download page:

 http://www.aladdin.com/support/hasp-srm/vendor.aspx

Direct driver download:

 ftp://ftp.aladdin.com/pub/hasp/srm/Runtime_%28Drivers%29/HASP_SRM_Runtime_cmd_line.zip

Attachments

Win2k-2008-10-27-19-29-18.log Download (164.3 KB) - added by ashman 5 years ago.

Change History

Changed 5 years ago by ashman

comment:1 Changed 5 years ago by sandervl73

  • Status changed from new to closed
  • Resolution set to duplicate

Duplicate of #2141.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use