VirtualBox

Ticket #2485 (closed defect: wontfix)

Opened 5 years ago

Last modified 3 years ago

remember iso image on iso mount disabled

Reported by: macias Owned by:
Priority: minor Component: other
Version: VirtualBox 2.0.4 Keywords:
Cc: Guest type: other
Host type: Linux

Description (last modified by frank) (diff)

The iso image is not remembered which makes switching it on/off more tiresome than it could be.

Steps:

  • start VB
  • select guest -> properties
  • iso image mount ON
  • select image
  • Ok
  • quit VB
  • start VB
  • iso image mount OFF
  • ok
  • quit VB
  • start VB
  • iso image mount ON

at this point the selected previously iso image should be mounted, but it is not

Ok, the bottom line is switching on/off the mount iso image in the guest properties should only do this -- mount off or not. It should not change the selected image.

Change History

comment:1 Changed 5 years ago by frank

  • Description modified (diff)

I don't think that this is a problem. Note that you can change the mounted .ISO image during runtime.

comment:2 Changed 5 years ago by macias

Let me describe it again.

You mount image A. You unmount it. You mount image again. Oh, image B was mounted.

Do you really think it is sane behaviour? mount, umount is for mounting images, not for swapping them (at the same time). If you user wants to change image, then user, well, should change the image.

It is 100% analogous to "real" mount. I insert disc in drive, I mount it, I unmount it -- this does not cause automatic insertion of another disc. And I would expect the VB would behave the same way.

It is even faster way to reproduce -- simply start VB (main app), select system, properties, CD/DVD, mount ON, select image, umount OFF, mount ON again -- your selected image is gone.

comment:3 Changed 5 years ago by frank

I completely understood your request. The issue is that after unmounting an image, the user is able to remount either another image the host CDROM/DVD-ROM drive. There are three states: Nothing is connected to the CDROM device, an image is connected or the physical host drive. The state not connected does not contain any information about the previous state. I don't say that it is not possible to change that but I don't think this is very important for now.

comment:4 Changed 5 years ago by macias

I am not saying it is very important, but in Linux I can insert a disc, and mount/umount it 1000 times without reinserting it. I am doing the same in VB with this difference I have to each time select the image for mounting again and again. And it is really tiresome.

comment:5 Changed 3 years ago by frank

  • Status changed from new to closed
  • Resolution set to wontfix

Note that mount/unmount of VBox always means that the (virtual) medium is removed from the (virtual) CD/DVD drive.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use