VirtualBox

Ticket #2484 (reopened defect)

Opened 5 years ago

Last modified 4 years ago

new version notification dialog: link is not active

Reported by: macias Owned by:
Priority: trivial Component: other
Version: VirtualBox 2.0.2 Keywords:
Cc: Guest type: other
Host type: Linux

Description

When the newer version is available VB shows notification dialog about this. It contains URL -- marked as blue, underlined. So it looks like valid link ready to be clicked, which should bring browser with web page.

However when you click on it, nothing happens.

Change History

comment:1 follow-up: ↓ 3 Changed 5 years ago by frank

Which windowing system are you using? The following commands will be executed (in that order) to check if a valid browser exists:

  • kfmclient exec URL
  • gnome-open URL
  • x-www-browser URL
  • firefox URL
  • konqueror URL

Does any of this commands work for you if you type it into an X terminal?

comment:2 Changed 5 years ago by Naruki

Additionally, right click options to Select All, Copy, and Copy Link Location appear to work as expected, but nothing gets added to the clipboard.

comment:3 in reply to: ↑ 1 Changed 5 years ago by Naruki

Replying to frank:

I am using a Windows XP host, and if that's what VB notification uses, it hasn't got a prayer of working.

comment:4 Changed 5 years ago by frank

Naruki, didn't understand your last comment. Does that mean that clicking on the download link does not work for you on a Windows host? Note that selecting + copying the link does not work because copy'n'paste from GUI dialogs does not work (2.0 regression caused by the Qt4 migration, will be fixed soon).

comment:5 Changed 5 years ago by Naruki

Sort of correct. Clicking the link does not work in Windows. (Sorry, I didn't realize macias had registered this as a Linux bug.) But that was not what my last comment was talking about.

It was talking about trying to launch a URL as you indicated, by trusting the browser executable to be in the system path.

Firefox happens to be my default browser, but it's set as such in the Windows registry, not in the path. Applications wishing to launch a link using my default browser (whatever it may be) cannot do so by using something like this:

firefox URL

So if that's how the notification dialog handles clicking on the links, it will not work in Windows. I just verified that even IE (iexplore.exe) is not in the path.

My first comment was to show that I tried other methods of getting the URL, but they also failed. Thanks for letting me know those are separate bugs.

comment:6 Changed 5 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

The method for calling the web browser was changed recently -- we are now using the Qt-provided method. Please reopen this ticket if you still have problems with the latest release 2.2.2.

comment:7 follow-up: ↓ 8 Changed 4 years ago by Naruki

  • Status changed from closed to reopened
  • Resolution fixed deleted

It's baaaaack.

I never really paid attention in the intervening upgrades, but today I am looking at the popup notice to upgrade to version 3.1.4 and clicking on the links does nothing.

Additionally, from the right-click menu I tried copying the link text, select all and copy, or just pressing Ctrl+C. In no case did my Windows clipboard get anything to paste.

Currently running 3.1.2 on Windows XP Host.

comment:8 in reply to: ↑ 7 Changed 4 years ago by Naruki

Hmm, at home now with 64-bit Vista, and the update link worked just fine.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use