VirtualBox

Ticket #2435 (closed defect: invalid)

Opened 6 years ago

Last modified 6 months ago

VRDPAUTH external on ubuntu hardy host -> Fixed in 2.1.2

Reported by: smonsarr Owned by:
Priority: major Component: RDP
Version: VirtualBox 2.0.6 Keywords:
Cc: Guest type: Windows
Host type: Linux

Description (last modified by frank) (diff)

VirtualBox 2.0.2.

I am unable to get the standard external vrdp authentication working on Ubuntu 8.04.

In the VB logs I get:

00:00:44.533 VRDP: Logon: kelisport06 (192.168.1.10) build 2600. User: [sam] Domain: [] Screen: 0
00:00:44.534 VRDPAUTH: User: [sam]. Domain: []. Authentication type: [External]
00:00:44.535 VRDPAUTH: ConsoleVRDPServer::Authenticate: loading external authentication library'VRDPAuth'
00:00:44.535 VRDPAUTH: Could not resolve import 'VRDPAuth2'. Error code: VERR_SYMBOL_NOT_FOUND
00:00:44.535 VRDPAUTH: Using entry point 'VRDPAuth'.
00:00:44.584 VRDPAUTH: external authentication module returned 'access denied'
00:00:44.584 VRDPAUTH: Access denied.

I exported:

export VRDP_AUTH_DEBUG_FILENAME=/tmp/vbox_auth.log

And tried again, /tmp/vbox_auth.log gave me:

u[sam], d[], p[8]
vrdpauth_pam_init: dlopen libpam.so failed
vrdpauth_pam_init failed 4

This looks like VRDPAuth.so is linking to a non existent lib, indeed on hardy /lib/libpam.so does NOT exist, only /lib/libpam.so.0, I then did :

$ sudo ln -s /lib/libpam.so.0 /lib/libpam.so

And tried again, this time /tmp/vbox_auth.log gave me:

u[sam], d[], p[8]
init ok
Using PAM service: login
start ok
conv: num 1 u[sam] p[8]
conv: 0 returning password [8]
auth ok
pam_acct_mgmt failed 9. Authentication service cannot retrieve authentication info
vrdpauth_pam_close completed

This is where I get stuck. it seems that VRDPAuth.so is NOT compatible with PAM on ubuntu 8.08 What is happening?

Change History

comment:1 Changed 5 years ago by helix84

I had this same problem on Debian Lenny x86_64 with VirtualBox 2.0.6 (nonfree - with RDP support).

This helped, thanks for the tip:

$ sudo ln -s /lib/libpam.so.0 /lib/libpam.so

my vdrp log then looked like this:

u[ctenar], d[], p[6]
init ok
Using PAM service: login
start ok
conv: num 1 u[ctenar] p[6]
conv: 0 returning password [6]
auth ok
access granted
vrdpauth_pam_close completed

comment:2 Changed 5 years ago by sunlover

  • Version changed from VirtualBox 2.0.2 to VirtualBox 2.0.6

The VRDPAuth library was changed to load libpam.so.0. The fix will be available in a future version of VBox.

smonsarr: The pam_acct_mgmt failure usually means that the pam library can not read /etc/shadow file. See  http://forums.virtualbox.org/viewtopic.php?t=5264&postdays=0&postorder=asc&highlight=shadow&start=15 for some solutions. Especially the post by jhowk Thu May 08, 2008 11:13 pm.

comment:3 Changed 5 years ago by sunlover

  • Status changed from new to closed
  • Resolution set to fixed
  • Summary changed from VRDPAUTH external on ubuntu hardy host to VRDPAUTH external on ubuntu hardy host -> Fixed in 2.1.2

Should be fixed in 2.1.2. Please reopen if the problem persists.

comment:4 Changed 5 years ago by danr

  • Status changed from closed to reopened
  • Resolution fixed deleted

Afraid this still exists.

Problem is fixed by export VRDP_AUTH_PAM_SERVICE=vrdpauth as per forum

But not if I want to use VBoxManage instead of VBoxHeadless

comment:5 Changed 5 years ago by sunlover

  • Status changed from reopened to closed
  • Resolution set to fixed

danr, you had a configuration problem on your host. This is not a bug.

comment:6 Changed 4 years ago by petervrichards

  • Status changed from closed to reopened
  • Resolution fixed deleted

sadly, I've done everything suggested inc pam.d scripts vrdpauth and exporting them, adding a shadow user group and am till getting the errors below when I try to access vbox3.0.10 running windowsXP from a remote windows Remote desktop.

what else do i have to do. I've spent 2 long nights trying to figure this out. peter richards

00:00:15.460 Guest Log: VBoxService.exe: Started. Verbose level = 0 00:00:20.905 VRDP: New connection: 00:00:20.940 VRDP: Flags 0x0000001b 00:00:20.940 VRDP: Channel: [rdpdr] [1004]. Not supported. 00:00:20.940 VRDP: Channel: [rdpsnd] [1005]. Accepted. 00:00:20.940 VRDP: Channel: [drdynvc] [1006]. Not supported. 00:00:20.940 VRDP: Channel: [cliprdr] [1007]. Accepted. 00:00:21.135 VRDP: Client seems to be MSFT. 00:00:21.135 VRDP: Logon: BACKOFFICE (192.168.1.145) build 6001. User: [] Domain: [] Screen: 0 00:00:21.135 VRDPAUTH: User: []. Domain: []. Authentication type: [External] 00:00:21.136 VRDPAUTH: ConsoleVRDPServer::Authenticate: loading external authentication library 'VRDPAuth' 00:00:21.148 VRDPAUTH: Could not resolve import 'VRDPAuth2'. Error code: VERR_SYMBOL_NOT_FOUND 00:00:21.148 VRDPAUTH: Using entry point 'VRDPAuth'. 00:00:23.615 VRDPAUTH: external authentication module returned 'access denied' 00:00:23.615 VRDPAUTH: Access denied. 00:00:23.615 VRDP: Connection closed: 00:00:23.615 VRDP: Logoff: BACKOFFICE (192.168.1.145) build 6001. User: [] Domain: [] Reason 0x0001. 00:00:48.596 VRDP: New connection: 00:00:48.623 VRDP: Flags 0x0000001b 00:00:48.624 VRDP: Channel: [rdpdr] [1004]. Not supported. 00:00:48.624 VRDP: Channel: [rdpsnd] [1005]. Accepted. 00:00:48.624 VRDP: Channel: [drdynvc] [1006]. Not supported. 00:00:48.624 VRDP: Channel: [cliprdr] [1007]. Accepted. 00:00:48.817 VRDP: Client seems to be MSFT. 00:00:48.817 VRDP: Logon: BACKOFFICE (192.168.1.145) build 6001. User: [apacheuser] Domain: [] Screen: 0 00:00:48.818 VRDPAUTH: User: [apacheuser]. Domain: []. Authentication type: [External] 00:00:51.307 VRDPAUTH: external authentication module returned 'access denied' 00:00:51.307 VRDPAUTH: Access denied. 00:00:51.307 VRDP: Connection closed: 00:00:51.307 VRDP: Logoff: BACKOFFICE (192.168.1.145) build 6001. User: [apacheuser] Domain: [] Reason 0x0001. 00:01:08.712 VRDP: New connection: 00:01:08.728 VRDP: Flags 0x0000001b 00:01:08.728 VRDP: Channel: [rdpdr] [1004]. Not supported. 00:01:08.728 VRDP: Channel: [rdpsnd] [1005]. Accepted. 00:01:08.728 VRDP: Channel: [drdynvc] [1006]. Not supported. 00:01:08.728 VRDP: Channel: [cliprdr] [1007]. Accepted. 00:01:08.922 VRDP: Client seems to be MSFT. 00:01:08.922 VRDP: Logon: BACKOFFICE (192.168.1.145) build 6001. User: [root] Domain: [] Screen: 0 00:01:08.923 VRDPAUTH: User: [root]. Domain: []. Authentication type: [External] 00:01:10.987 VRDPAUTH: external authentication module returned 'access denied' 00:01:10.987 VRDPAUTH: Access denied. 00:01:10.987 VRDP: Connection closed: 00:01:10.987 VRDP: Logoff: BACKOFFICE (192.168.1.145) build 6001. User: [root] Domain: [] Reason 0x0001.

comment:7 Changed 4 years ago by petervrichards

continued woe .... any solutions???

peter richards

linked libpam.so.0 to libpam.so

vrdpauth log

u[xxxxxx], d[], p[0] init ok Using PAM service: vrdpauth start ok conv: num 1 u[xxxxxxxx] p[0] conv: 0 returning password [0] pam_authenticate failed 7. Authentication failure vrdpauth_pam_close completed

comment:8 Changed 6 months ago by frank

  • Status changed from reopened to closed
  • Resolution set to invalid
  • Description modified (diff)

Obsolete.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use