VirtualBox

Ticket #2286 (closed defect: fixed)

Opened 6 years ago

Last modified 2 years ago

NAT network on Adapter 1 not working

Reported by: jwithana Owned by:
Priority: major Component: network/NAT
Version: VirtualBox 2.0.2 Keywords:
Cc: Guest type: Windows
Host type: Linux

Description

Cannot access the internet from Guest after upgrading from VB 2.0.0 to 2.0.2

Host: Ubuntu 8.04 Guest: WinXP Pro SP3

Attachments

WinXP-2008-10-25-11-21-38.log Download (43.3 KB) - added by jwithana 5 years ago.
Log file for NAT network not working on XP guest + Ubuntu Hardy host

Change History

comment:1 Changed 6 years ago by jwithana

the odd thing is shared folders works and in winxp the network shows as connected. therefore is the NAT broken on the host side?

comment:2 Changed 6 years ago by jwithana

or should i downgrade to 1.6.6? how can i do this?

comment:3 follow-up: ↓ 4 Changed 6 years ago by jwithana

i downgraded to 2.0.2 but this did not help

comment:4 in reply to: ↑ 3 Changed 6 years ago by jwithana

Replying to jwithana:

i downgraded to 2.0.2 but this did not help

i mean to 2.0.0 (not 2.0.2)

comment:5 Changed 6 years ago by jwithana

since shared folders are running i am guessing that the issue is NOT on the XP SP3 guest network config.

is there any way to "restart" the NAT server/network on the Ubuntu 7.04 host side?

thanks

comment:6 Changed 6 years ago by frop

It's the same here.

Upgrading from 2.0.0 to 2.0.2 broke networking (both NAT and Host Interface). Same setup, Host: "XP sp3" Guest: "Ubuntu (latest 8.04.1)".

The "VirtualBox Host Interface 1" never get @connected@ (aka, A network cable is unplugged). Tried also to modify Media Status from "Application Controlled" to "Always Connected", but nothing changed.

Works perfectly with 2.0.0 and older.

Also, I get a weird problem with USB host (i don't use USB devices, but...). As soon as I try to open a configuration window, this error come out:

Title: "Failed to access the USB subsystem"

Could not load the Host USB Proxy Service (VERR_FILE_NOT_FOUND). The service might be not installed on the host computer.

Result Code: E_FAIL (0x00004005)

comment:7 Changed 6 years ago by frank

frop, please open dedicated defects for different problems.

According to networking: Please make sure that the Ubuntu guest did not change the network card assignment. That is, please have a look at my last comment to #841.

comment:8 Changed 6 years ago by frop

sorry for the report on USB subsystem, but thought it could be related. (if it's worth a ticket, let me know and i'll submitt one)

checked ticket 841 as you suggested and that rule was there on my guest. So i tweaked /etc/udev/rules.d/75-persistent-net-generator.rules adding the exception for vbox mac addresses. Also i deleted the content of /etc/udev/rules.d/70-persistent-net.rules (it was containing rules for all vbox interfaces, aka pcnet32).

Rebooted...

At start, reconfigured the ethernet manually (to get a static ip address in the network, like i was used with vbox 2.0.0). Rebooted the guest again and wow, networking working.

Thank you, this made my day.

NOTE: Host Interface networking was working without the udev tweak in vbox 2.0.0

here's the output from the Host XP sp3:

C:\Profiles\Administrator>netsh bridge show adapter

----------------------------------------------------------------------
 ID AdapterFriendlyName         ForceCompatibilityMode
----------------------------------------------------------------------
  1 VirtualBox Host Interface 1 enabled
  2 Local Area Connection       enabled
----------------------------------------------------------------------

C:\Profiles\Administrator>ipconfig /all

Windows IP Configuration

        Host Name . . . . . . . . . . . . : lupin
        Primary Dns Suffix  . . . . . . . :
        Node Type . . . . . . . . . . . . : Unknown
        IP Routing Enabled. . . . . . . . : No
        WINS Proxy Enabled. . . . . . . . : No

Ethernet adapter Network Bridge:

        Connection-specific DNS Suffix  . :
        Description . . . . . . . . . . . : MAC Bridge Miniport
        Physical Address. . . . . . . . . : 07-FF-1C-41-6F-1A
        Dhcp Enabled. . . . . . . . . . . : No
        IP Address. . . . . . . . . . . . : 192.168.0.230
        Subnet Mask . . . . . . . . . . . : 255.255.255.0
        Default Gateway . . . . . . . . . : 192.168.0.155
        DNS Servers . . . . . . . . . . . : 192.168.0.155

and here the configuration from guest:

mule@vbox:~ $ ifconfig -a
eth0      Link encap:Ethernet  HWaddr 08:00:27:d1:9c:09  
          inet addr:192.168.0.22  Bcast:192.168.0.255  Mask:255.255.255.0
          inet6 addr: fe80::a00:27ff:fed1:9c09/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:2 errors:0 dropped:0 overruns:0 frame:0
          TX packets:51 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:303 (303.0 B)  TX bytes:6907 (6.7 KB)
          Interrupt:11 Base address:0xc020 

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:520 errors:0 dropped:0 overruns:0 frame:0
          TX packets:520 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:26000 (25.3 KB)  TX bytes:26000 (25.3 KB)

mule@vbox:~ $ route
Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
192.168.0.0     *               255.255.255.0   U     0      0        0 eth0
link-local      *               255.255.0.0     U     1000   0        0 eth0
default         192.168.0.155   0.0.0.0         UG    100    0        0 eth0

comment:9 Changed 6 years ago by frop

just noticed...althought Host Interface networking is working under the guest OS, the "Virtual Box Interface 1" on Host OS display "A network cable is unplugged"...weird.

Seems just a visual glitch, resolvable forcing "Always Connected" in the Advanced option tab, as suggested in other place (don't remember where...)

comment:10 follow-up: ↓ 11 Changed 6 years ago by frank

Note that these network rules are triggered by changes in the MAC address of the virtual network adapter. So this is a problem not related to 2.0.2 as we didn't change anything related with this version.

comment:11 in reply to: ↑ 10 Changed 6 years ago by SwordAngel

Replying to frank:

Note that these network rules are triggered by changes in the MAC address of the virtual network adapter. So this is a problem not related to 2.0.2 as we didn't change anything related with this version.

I don't understand your explanation.

I have a fresh installation of VirtualBox and I have never changed the MAC address of the virtual network adapter, yet the "VirtualBox Host Interface 1" is already shown as "disconnected" in my Windows XP SP3 host.

comment:12 Changed 6 years ago by frank

If you never changed the MAC address of the virtual network adapter then either the MAC might be changed accidently (perhaps due to a seldom-triggered bug -- not very likely) or your problem might not be related. Anyway, removing these automatically generated udev rules in the guest might help or not, at least its worth a try.

comment:13 Changed 6 years ago by frop

I have a fresh installation of VirtualBox and I have never changed the MAC address of the >virtual network adapter, yet the "VirtualBox Host Interface 1" is already shown as >"disconnected" in my Windows XP SP3 host.

as stated in my post, under Win XP SP3 host the "VirtualBox Host Interface 1" result as "unplugged", but the networking works fine under the Ubuntu guest OS.

You can "tweak" it by selecting "Always Connected" under the Advanced tab of the network interface. Althought this is a bug (i think so at least), it doesn't create problems to the Host Interface networking functionality.

comment:14 Changed 6 years ago by jwithana

pardon the question from the clueless newbie but:

it appears the the Virtual Adapter of my Guest Win XP VM has changed its MAC. So please can you tell me or point me to a link that tells me:

  1. where i can find the correct MAC i can change it back to in the virtualbox settings? is it in one of the files in the Ubuntu 8.04 host /etc/udev/rules.d/? the files i see are:

05-options.rules 70-persistent-cd.rules 05-udev-early.rules 70-persistent-net.rules 20-names.rules 75-cd-aliases-generator.rules 30-cdrom_id.rules 75-persistent-net-generator.rules 40-basic-permissions.rules 80-programs.rules 40-permissions.rules 85-alsa.rules 45-fuse.rules 85-brltty.rules 45-libmtp7.rules 85-hdparm.rules 50-libpisock9.rules 85-hplj10xx.rules 50-xserver-xorg-input-wacom.rules 85-hwclock.rules 55-hpmud.rules 85-ifupdown.rules 60-persistent-input.rules 85-pcmcia.rules 60-persistent-storage.rules 90-modprobe.rules 60-persistent-storage-tape.rules 95-hal.rules 60-symlinks.rules 95-udev-late.rules 60-vboxdrv.rules README 61-persistent-storage-edd.rules

  1. or is there some fix i need to make on the host side? i would prefer not to change host but rather supply the correct MAC to the Virtual Adapter of my Guest Win XP VM

Thanks in advance!

comment:15 Changed 6 years ago by jwithana

or

  1. does it require the fix on the guest Win XP? again it seems #1 above is easiest

comment:16 Changed 6 years ago by jwithana

i was re-reading this and would like to point out that the issue i was having was with a LINUX HOST and Windows GUEST. Anyway, even though the MAC# on the Virtual guest changed -- reinstalling VB 2.0.0 seemed to fix the problem after a reboot of the HOST. dunno whats going on!!

comment:17 Changed 6 years ago by frank

  • Priority changed from critical to major
  • Status changed from new to closed
  • Resolution set to fixed

Don't mix host and guest here. My statements about udev rules were related to Linux guests. I still don't know how it should happen that the MAC address of the virtual network adapter should change. Even if you disable + re-enable the network adapter in the VM settings or change the adapter type, the MAC address should remain.

I will close this bug for now. Please reopen if you still realize problems.

comment:18 in reply to: ↑ description Changed 6 years ago by jwithana

  • Status changed from closed to reopened
  • Resolution fixed deleted

my original post was for Linux host and WinXP guest (see below) -- someone hijacked it for the reverse

the problem still persists -- can you PLEASE tell me any tests you would like me to run on the UBUNTU HOST or WINDOWS GUEST

Replying to jwithana:

Cannot access the internet from Guest after upgrading from VB 2.0.0 to 2.0.2

Host: Ubuntu 8.04 Guest: WinXP Pro SP3

Changed 5 years ago by jwithana

Log file for NAT network not working on XP guest + Ubuntu Hardy host

comment:19 Changed 5 years ago by frank

  • Component changed from network to network/NAT

comment:20 follow-up: ↓ 21 Changed 5 years ago by frank

  • Status changed from reopened to closed
  • Resolution set to fixed

Please reopen if this problem still persists with VirtualBox 2.2.2. Note that starting with version 2.2.0, VirtualBox is able to pass multiple DNS servers to the guest. This should fix the original problem.

comment:21 in reply to: ↑ 20 ; follow-up: ↓ 22 Changed 3 years ago by dgovoni

  • Status changed from closed to reopened
  • Resolution fixed deleted

Using ubuntu 10.10 server guest on ubuntu 10.10 desktop. This has been a problem for many years still.

I have NAT on adapter 1 and it does not route. In fact, nothing on adapter 1 routes. It only works with 1 adapter only.

comment:22 in reply to: ↑ 21 Changed 3 years ago by dgovoni

Replying to dgovoni:

Using ubuntu 10.10 server guest on ubuntu 10.10 desktop. This has been a problem for many years still.

I have NAT on adapter 1 and it does not route. In fact, nothing on adapter 1 routes. It only works with 1 adapter only.

Correction. NAT on adapter 2 does not route. When there are two adapters, this problem occurs. With only 1 adapter, networking works.

comment:23 Changed 3 years ago by frank

What do you mean by "not route"? Does the 2nd adapter have an IP? Can you post the output of "ifconfig"?

comment:24 Changed 2 years ago by frank

  • Status changed from reopened to closed
  • Resolution set to fixed

No response, closing.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use