VirtualBox

Ticket #841 (closed defect: wontfix)

Opened 6 years ago

Last modified 4 years ago

Guest networking issue with VirtuaBox OSE svn rev 5577

Reported by: graum Owned by:
Priority: major Component: other
Version: VirtualBox 1.5.2 Keywords:
Cc: Guest type: other
Host type: other

Description

Hello!

My Debian Etch boots perfectly with NAT mode network setup, but the ethernet interface not working

~# ifconfig eth0

eth0: error fetching interface information: Device not found

I tried both Am79C970A and Am79C973 too.

Interface detection in dmesg output is probably OK:

thx Godot

Change History

comment:1 Changed 6 years ago by graum

Ohh....

My host system is 32bit Ubuntu Gutsy

comment:2 Changed 6 years ago by michael

Are you sure that the Debian VM is not expecting a different MAC address to the one set on the virtual interface?

comment:3 Changed 6 years ago by graum

I solved? a problem (or founded a bug?)

I configured the adapter0 but the debian guest detected as eth4 in /proc/dev/net

but in dmesg:

eth0: registered as PCNet/PCI II 79C970A

Here is the VM config:

Name: debianetch Guest OS: Linux 2.6 UUID: 47f4db3e-8c43-410e-e394-e7079189c25c Config file: /home/szep/.VirtualBox/Machines/debianetch/debianetch.xml Memory size: 128MB VRAM size: 8MB Boot menu mode: message and menu ACPI: on IOAPIC: off Time offset: 0 ms Hardw. virt.ext: off State: running (since 2007-10-31T17:32:34.526000000) Monitor count: 1 Floppy: empty Primary master: /home/szep/.VirtualBox/VDI/debianetch.vdi (UUID: 37a831c3-411a-4522-9e80-21290c81d8b8) DVD: empty NIC 1: MAC: 0800271B6964, Attachment: NAT, Cable connected: on, Trace: off (file: <NULL>), Type: Am79C970A, Reported speed: 100 Mbps NIC 2: disabled NIC 3: disabled NIC 4: disabled UART 1: disabled UART 2: disabled Audio: disabled (Driver: Unknown) Clipboard Mode: Bidirectional Video mode: 720x400x0 Shared folders: <none>

comment:4 Changed 6 years ago by frank

It might be an udev issue of the guest. Debian-like systems store the network interface according to the MAC address. Check if there does a file

/etc/udev/rules.d/z25_persistent-net.rules

exist. And check its content if so. This file is auto-generated by udev.

comment:5 Changed 6 years ago by graum

SOLVED!

I deleted the z25_persistent-net.rules and reboot the guest. And the interface order restored.

Thank you for your help....

comment:6 Changed 6 years ago by frank

  • Status changed from new to closed
  • Resolution set to wontfix

Ok. Note that z25_persistent-net.rules was generated by

/etc/udev/persistent-net-generator.rules

You might want to add an exception rule for the VirtualBox MAC addresses there like this:

# ignore VirtualBox virtual interfaces
ATTR{address}=="08:00:27:*", GOTO="persistent_net_generator_end"

at the beginning of this script. On Debian/sid there is already a rule for ignoring VMware MAC addresses.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use