VirtualBox

Ticket #2242 (closed defect: fixed)

Opened 6 years ago

Last modified 6 years ago

VboxSVC memory leak (Vista host only) -> fixed in SVN/2.0.4

Reported by: snowblind Owned by:
Priority: critical Component: other
Version: VirtualBox 2.0.2 Keywords:
Cc: Guest type: Windows
Host type: Windows

Description

Vboxsvc.exe starts normally and eventually eats all memory. This is without opening the virtual machine. Tried both a clean install and an overlapping one to no avail.

Host is vista 64-bit ultimate.

Change History

comment:1 Changed 6 years ago by sandervl73

There's a hotfix for this problem. See  http://support.microsoft.com/kb/949700

comment:2 Changed 6 years ago by sandervl73

The mentioned hotfix has not going through windows update yet afiacs. The mentioned dlls in my Vista 64 SP1 are older.

comment:3 Changed 6 years ago by sandervl73

I can confirm that the hotfix works for me. Request it at the top of the page.

comment:4 Changed 6 years ago by sandervl73

  • Priority changed from major to critical
  • Summary changed from Vboxsvc memory leak to VboxSVC memory leak (Vista host only)

comment:5 Changed 6 years ago by version2

I can confirm that the hotfix worked for me as well. Vista 32-bit SP2.

comment:6 Changed 6 years ago by snowblind

I can confirm that this hotfix works for me. Vista 64-bit Ultimate SP1. VBoxSVC stays at around 8mb.

comment:7 Changed 6 years ago by sandervl73

  • Summary changed from VboxSVC memory leak (Vista host only) to VboxSVC memory leak (Vista host only) -> fixed in SVN/2.0.4

comment:8 Changed 6 years ago by sandervl73

We've rewritten parts of the code so we don't use this Windows interface anymore. See defect #2212 for a patch.

comment:9 Changed 6 years ago by firebelly

Just another confirm to the hotfix solving this issue to let you know you've hit the nail on the head.

comment:10 Changed 6 years ago by mdmadph

I'm actually getting this exact same problem in Win XP. I start up Virtualbox, start working with a VM, and eventually all RAM is used up and my other programs (just Firefox for development) are moving sluggish because they've all been moved to virtual RAM.

I look at my available physical memory and it's hovering near 30MB, even though the Virtualbox VM is set to use only 512 MB, and before starting the VM I had over 1.5GB free.

Think I might start a new ticket about this...

comment:11 Changed 6 years ago by estrahon

I just installed VirtualBox and came here because I was experiencing the same thing. It eventually started eating around a gig of my memory. I just wanted to confirm that the hotfix worked. Thanks.

comment:12 Changed 6 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use