VirtualBox

Ticket #2240 (closed defect: duplicate)

Opened 6 years ago

Last modified 5 years ago

VM not paused when creating a snapshot from GUI

Reported by: markba Owned by:
Priority: major Component: GUI
Version: VirtualBox 2.1.0 Keywords: snapshot gui
Cc: Guest type: other
Host type: other

Description

When trying to make a snapshot from GUI of a running session, after the dialog for entering the snaphot name is passed, the following error pops up:

A session for the machine 'Ubuntu JeOS' is currently open (or being closed).

Result Code: 
E_ACCESSDENIED (0x80070005)
Component: 
Machine
Interface: 
IMachine {1e509de4-d96c-4f44-8b94-860194f710ac}
Callee: 
IVirtualBox {557a07bc-e6ae-4520-a361-4a8493199137}

When doing the same in the session menu or via CLI, all succeeds well, so it's clear it's possible to do a snapshot of a running session.

This can be of interest: when the name dialog is popped up (while creating the snapshot from the session menu), the session is *paused*. This (the pausing) is not happening when creating a snapshot from the generic menu, probably resulting in the error above.

So the possible solution could be that the GUI must pause the session while doing the snapshot.

Change History

comment:1 Changed 6 years ago by frank

  • Component changed from other to GUI
  • Summary changed from Creating a snapshot from GUI of running session is blocked to VM not paused when creating a snapshot from GUI

comment:2 Changed 6 years ago by frank

Please could you attach a VBox.log file for a VM session where you tried to take a snapshot from the GUI?

comment:3 Changed 5 years ago by sandervl73

  • Version changed from VirtualBox 2.0.2 to VirtualBox 2.1.0

comment:4 Changed 5 years ago by sandervl73

  • Status changed from new to closed
  • Resolution set to duplicate

Duplicate of #2853.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use