VirtualBox

Ticket #2853 (closed defect: fixed)

Opened 5 years ago

Last modified 5 years ago

Cannot create a snapshot of a running Virtual Machine (VBOX_E_INVALID_OBJECT_STATE (0x80BB0007) )

Reported by: someone Owned by:
Priority: major Component: other
Version: VirtualBox 2.1.0 Keywords: snapshot
Cc: Guest type: other
Host type: Linux

Description

Hi, When I upgrade to version 2.1 from version 2.0.6. I cannot do snapshots of a running Virtual machine.

This is running on a Kubuntu 7.10 host. Windows and Debian/Kubuntu guest OS.

If the machine is powered off. I can do a snapshot fine.

My VDI and Machine directories are changed from the default locations.

I get the following error

A session for the machine 'DebianServer' is currently open (or being closed).


Result Code: VBOX_E_INVALID_OBJECT_STATE (0x80BB0007)

Component: Machine Interface: IMachine {ea6fb7ea-1993-4642-b113-f29eb39e0df0}

Callee: IVirtualBox {339abca2-f47a-4302-87f5-7bc324e6bbde}

Attachments

SnapshotError.jpg Download (71.8 KB) - added by someone 5 years ago.

Change History

comment:1 Changed 5 years ago by Lelik

Unable to reproduce this problem. I can take a snapshot fine. Can you attach here a log file when you get this error?

comment:2 Changed 5 years ago by someone

Hi, The Snapshot feature runs fine when you invoke it from the Machine menu of the running VM. The problem is actually when you invoke it from the Sun xVM Virtualbox window.

See screenshot attached.

Sorry for not doing a bit more research on this. I think it the same issue as ticket 2240

Thanks!

Changed 5 years ago by someone

comment:3 Changed 5 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

Please reopen this ticket if the problem persists with the latest release 2.2.2.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use