VirtualBox

Opened 14 months ago

Closed 6 months ago

Last modified 6 months ago

#21516 closed defect (fixed)

Cisco CSR 1000v and 8000v does not recognize interfaces. => fixed in SVN/next 7.0.x

Reported by: diivious Owned by:
Component: network Version: VirtualBox-7.0.6
Keywords: Cc:
Guest type: Linux Host type: all

Description

With Version 7.0.6 the Cisco CSR Cisco CSR 1000v and 8000v does not recognize interfaces. The same deployment works fine on Version 6.1.42.

ISO: csr1000v-universalk9.17.03.06 OS: Linux Other Storage 10G, MEM: 8K, Vid: 16MB Interface: VERTIO-NET

Deployment goes with no issues, and the Guest boots just fine. However, when you connect to the console and log in, there are no interfaces listed.

This does not appear to be host related as the issue manifest itself weather you are using Mac, Win10 or Win11.

Please let me know if you need logs, etc as the issue is easily reproducible.

Attachments (2)

VBox.log (201.2 KB ) - added by PeterPaluch 12 months ago.
VBox.2.log (75.3 KB ) - added by diivious 9 months ago.
Log file for 7.10 csr1000v

Download all attachments as: .zip

Change History (8)

by PeterPaluch, 12 months ago

Attachment: VBox.log added

comment:1 by PeterPaluch, 12 months ago

Hi team,

Confirming that the issue still persists under VirtualBox 7.0.8 as well. I noted that the possibly related defect #21201 has been reported as fixed in VirtualBox 7.0.8 but no improvement has been observed for the CSR1Kv image - it still does not recognize any virtio-net adapters.

Thank you for looking into this! I've attached a VBox.log file for VBox 7.0.8 running CSR1Kv 17.3.7.

comment:2 by diivious, 9 months ago

Any update on this case? Use of many of Cisco products is borked as long as this is broken...

comment:3 by diivious, 9 months ago

Just tested Version 7.0.10 r158379 (Qt5.15.2) and the issue is still present.

Last edited 9 months ago by diivious (previous) (diff)

by diivious, 9 months ago

Attachment: VBox.2.log added

Log file for 7.10 csr1000v

comment:4 by aeichner, 8 months ago

Summary: Cisco CSR 1000v and 8000v does not recognize interfaces.Cisco CSR 1000v and 8000v does not recognize interfaces. => fixed in SVN/next 7.0.x

Thanks for the report, this will be fixed in the next 7.0.x maintenance release.

comment:5 by galitsyn, 6 months ago

Resolution: fixed
Status: newclosed

Hi guys,

We just released a new version of VirtualBox today. This issue should be fixed there. Closing it. Please leave a comment if it is still actual for you. As usual, builds are available on Downloads page. Thank you for reporting.

comment:6 by diivious, 6 months ago

Interfaces show up now. I will do more testing later in the week.

one thing to note - after installed .12 and was getting the error is "suplibOsInit what: 1 VERR_INRESOLVED_ERROR (-35). Unresolved (unknown) host platform error.

I resolved this by doing "bcdedit /set hypervisorlaunchtype off". This was NOT required for.8, which worked just find on the same system and no changes (other than windows pro insider updates) and the install of .12

Note: See TracTickets for help on using tickets.

© 2023 Oracle
ContactPrivacy policyTerms of Use