VirtualBox

Ticket #21201 (closed defect: fixed)

Opened 5 weeks ago

Last modified 12 days ago

FreeBSD 12.3 and pfSense 2.6.0 networking no longer works with upgrade to VB 7.0.2 => fixed in SVN/next 7.0.x maintenance

Reported by: rickga Owned by:
Component: network Version: VirtualBox-7.0.2
Keywords: freebsd,pfsense,networking,nat Cc:
Guest type: BSD Host type: Linux

Description

Hi,

After a recent upgrade from VirtualBox 6.1.40 to 7.0.2 on Arch Linux, all of my pfSense virtual machines hang at "Configuring WAN interface" during the boot process. Reverting VirtualBox back to 6.1.40 fixes it.

The pfSense VM (CE 2.6.0) is configured with EFI enabled and the WAN interface is a NAT virtual network adapter with "virtio-net". I've tried changing the adapter to either of the Intel PRO/1000 Server options and it does eventually boot after a 5 minute hang at the same point, but it is unable to get an IP and therefore doesn't work either.

I've also tried to create a brand new pfSense VM using the same settings as our currently running ones and while it installs properly, after the reboot it is stuck on "Default interfaces not found -- Running interface assignment option.". This also works properly in 6.1.40. I've also tried setting the network interface to bridge mode and no change.

Edit: All other VM work properly, including other FreeBSD 13.1 virtual machines but same behavior with FreeBSD 12.3.

Any suggestions?

Attachments

fb12.3-VBox.log Download (203.2 KB) - added by rickga 3 weeks ago.
pfsense2.6.0-VBox.log Download (161.4 KB) - added by rickga 3 weeks ago.
fb13.1-VBox.log Download (202.2 KB) - added by rickga 3 weeks ago.

Change History

comment:1 follow-up: ↓ 2 Changed 4 weeks ago by aeichner

Please upload VBox.log files of the affected VMs.

Changed 3 weeks ago by rickga

Changed 3 weeks ago by rickga

Changed 3 weeks ago by rickga

comment:2 in reply to: ↑ 1 Changed 3 weeks ago by rickga

Replying to aeichner:

Please upload VBox.log files of the affected VMs.

I have attached logs for FreeBSD 12.3 and pfSense 2.6.0 (network not working) and FreeBSD 13.1 (network working).

comment:3 Changed 2 weeks ago by aeichner

  • Summary changed from FreeBSD 12.3 and pfSense 2.6.0 networking no longer works with upgrade to VB 7.0.2 to FreeBSD 12.3 and pfSense 2.6.0 networking no longer works with upgrade to VB 7.0.2 => fixed in SVN/next 7.0.x maintenance

Thanks for the report, this will be fixed in the next 7.0.x maintenance release. The root cause is actually a bug in the virtio-net driver included in FreeBSD up to version 12.3. It violates the virtio specification and our new virtio implementation in 7.0 is much more strict when asserting sane driver behavior.

comment:4 Changed 12 days ago by galitsyn

  • Status changed from new to closed
  • Resolution set to fixed

VirtualBox 7.0.4 was just released and available for download at https://www.virtualbox.org/wiki/Downloads. This issue should be fixed in this version.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use