Opened 20 months ago

Last modified 19 months ago

#21138 new defect

7.0.0 doesn't work for a Windows 10 guest with multiple monitors

Reported by: Ian Puleston Owned by:
Component: guest control Version: VirtualBox 7.0.0
Keywords: multiple monitors displays Cc:
Guest type: Windows Host type: Windows


After upgrading from 6.1.38 to 7.0.0 on a Windows 10 host, it seems to be working fine with a single-monitor Windows 10 guest VM, but not with a Windows 10 guest VM that has 3 monitors. It gets confused as to which monitor the mouse is clicking in, making it pretty much unusable. For example, I have the Windows task bar on the center monitor only, and when I try to click with the mouse pointer located over the Windows start button there, nothing happens. If I move the mouse pointer to the bottom left corner of the left monitor and click there, then the start menu opens on the middle monitor.

Also, when the mouse is in the main window the pointer looks good and stable (although it doesn't work for clicking in that window), but when I move it to one of the other windows then it gets jumpy and fuzzy.

I tried to disable 2 of the monitors from within Windows, but that was almost impossible with the mouse clicking on the wrong one.

Rolled back to 6.1.38 and all is hunky dory again.

I then disabled 2 of the 3 monitors while running in 6.1.38 before re-installing 7.0.0, and then the VM worked fine with just the one monitor. But when I then tried to re-enable a 2nd one, the issue came back.

Attachments (2)

vbox-6.1.38-sess.log (471.2 KB ) - added by Ian Puleston 20 months ago.
Session log file from 6.1.38.
vbox-7.0.0-sess.log (287.7 KB ) - added by Ian Puleston 20 months ago.
Session log file from 7.0.0.

Download all attachments as: .zip

Change History (4)

by Ian Puleston, 20 months ago

Attachment: vbox-6.1.38-sess.log added

Session log file from 6.1.38.

by Ian Puleston, 20 months ago

Attachment: vbox-7.0.0-sess.log added

Session log file from 7.0.0.

comment:1 by Ian Puleston, 20 months ago

I've attached logs from sessions with the same 3-monitor guest VM running under 6.1.38 and 7.0.0. Something that stands out is that under 6.1.38 a bunch of these were logged, where the logs from 7.0.0 show nothing similar (that I could see):

03:09:41.195802 GUI: Machine-window #0 activated
03:09:41.195964 GUI: Machine-window #1 deactivated
03:09:41.195974 GUI: Releasing mouse on focus out
03:09:41.196039 GUI: Releasing keyboard on focus out
03:09:41.196049 GUI: Machine-view #1 unfocused, reason=3
03:09:41.196082 GUI: Capturing keyboard on focus in
03:09:41.196092 GUI: Machine-view #0 focused, reason=3

Could this mean that 7.0.0 is not recognizing it as 3 monitors, or is it just a change in what is logged between the two versions?

Note that in the 7.0.0 logs it reports that the extension pack and guest additions are 6.1.38. I hadn't bothered to upgrade those on this occasion, but in my first try I saw this issue after upgrading both to 7.0.0, so the problem is not related to that.

Last edited 20 months ago by Ian Puleston (previous) (diff)

comment:2 by Ian Puleston, 19 months ago

Note that I opened this against the wrong component which should maybe have been GUI/Multiview?

This is also reported as This one should probably be closed as a duplicate of that one.

Note: See TracTickets for help on using tickets.

© 2023 Oracle
ContactPrivacy policyTerms of Use