VirtualBox

Ticket #21137 (closed defect: fixed)

Opened 7 weeks ago

Last modified 21 hours ago

Extend displays broken in Virtualbox 7.0.0

Reported by: VP1 Owned by:
Component: GUI/multiview Version: VirtualBox 7.0.0
Keywords: Cc:
Guest type: Windows Host type: Windows

Description

Using VirtualBox 7.0.0 with Windows 10 21H2 host and Windows 10 21H2 guest, with the VM settings set to 2 displays. When using "Extend these displays" in the guest, the mouse pointer is off, clicks register away from the pointer. Both displays used are 2560x1440, and the issue happens in both full screen mode and windowed mode.

Change History

comment:1 Changed 7 weeks ago by VP1

Update: this only occurs if the pointing device is set to USB Tablet (which worked previously with VirtualBox 6.x). If the pointing device is set to PS/2 Mouse, it works correctly with multiple displays.

comment:2 Changed 3 weeks ago by Ian-P

I reported the same in https://www.virtualbox.org/ticket/21138 (although I selected the wrong component there). I had reverted to 6.1.38, and just tried to upgrade to 6.1.40, only to find that it has the same issue too. So apparently there is some change between .38 and .40 that also got included in 7.0.0, and that is causing this problem. It is still there in 7.0.2.

And your idea of changing the pointing device from USB Table to PS/2 Mouse worked for me too, so thank you for that (for anyone else, note that is in the VM Motherboard settings - it took me a while to find it).

Last edited 3 weeks ago by Ian-P (previous) (diff)

comment:3 Changed 3 weeks ago by jdmx

So I got bit by this today and wanted to added some additional info to this ticket.

I updated from 6.1.38 to 6.1.40 and then to 7.0.2 and each of the updates had this same issue.

The env is Win 10 with 3 monitors for the display. The default value for the pointing device for all my VM is USB Tablet.

When I switched the pointing device to PS/2 Mouse located at System -> Motherboard as the 5th option on the tab, the problem went away.

In both 6.1.40 and 7.0.2 with the pointing device set to USB Tablet, the mouse movement would register across all monitors ( the cursor would show on all monitors ). But all other mouse events would only register on Monitor 1 and the entire width of all the monitors display would be condensed on Monitor 1.

So if you right click on Monitor 2, the pop up would show on Monitor 1 in proportion to where if the whole width was on one monitor. Same with hover and click. If a Explorer window is open on the right side of Monitor 1, you can move the cursor to Monitor 2 and have the hover event highlight items in the Explorer windows.

Again this problem does not exist in 6.1.38.

This might be remedied by having a pop up notification on the Display window when a user switches to a Monitor count > 1 that it would check the Pointing Device value and warn of conflicts

comment:4 Changed 12 days ago by galitsyn

  • Status changed from new to closed
  • Resolution set to fixed

VirtualBox 7.0.4 was just released and available for download at https://www.virtualbox.org/wiki/Downloads. This issue should be fixed in this version.

comment:5 Changed 21 hours ago by Ian-P

I can confirm that it works for me. Upgraded to 7.0.4, set the pointing device back to USB Tablet, and the mouse now works fine on all 3 monitors in the guest. Thanks.

comment:6 Changed 21 hours ago by galitsyn

Thank you for confirmation.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use