VirtualBox

Opened 3 years ago

Closed 20 months ago

#20479 closed defect (fixed)

vboxwebsrv missing

Reported by: Eupeodes Owned by:
Component: webservices Version: VirtualBox 6.1.26
Keywords: Cc:
Guest type: other Host type: Linux

Description

When updating from virtualbox 6.1.24 to 6.1.26 vboxwebsrv is removed.

Host machine: debian 10

  • Already tried a new install (download installer from virtualbox.org and install using dpkg -i) of 6.1.26, this also doesn't help.
  • Uninstalled 6.1.26, downloaded and installed 6.1.24 again, vboxwebsrv is now back. When upgrading to 6.1.26 vboxwebsrv is gone again.

So it seems that the installer for 6.1.26 removes the vboxwebsrv executable.

Change History (5)

comment:1 by Klaus Espenlaub, 3 years ago

This appears to be an unintentional result from the big cleanup of the configure script. Which had so many strange hacks for our own builds that it was impossible to tell what really happens. Sorry about this regression. Need to check what we can do.

comment:2 by Madozu2, 3 years ago

I can confirm that the file "/usr/lib/virtualbox/vboxwebsrv" is missing from the Linux installer "virtualbox-6.1_6.1.26-145957~Ubuntu~eoan_amd64.deb". As is seems also from installers for other Linuxes.

Workaround that works for me:

  • Download the 6.1.24 version installer for your Linux distro
  • Grab the "/usr/lib/virtualbox/vboxwebsrv" file from installer file
  • Place it into "/usr/lib/virtualbox"
  • Start vboxweb-service

comment:3 by Klaus Espenlaub, 3 years ago

The next release (6.1.28, whenever it will happen) will have vboxwebsrv again.

The workaround in the previous comment sounds OK to me.

If you run into trouble with it the alternative would be using the 6.1.26 .run package. I know it's less convenient than using the distribution specific package,especially with updating... with 6.1.28 you'll need to uninstall the .run package and install the distribution specific one again.

comment:4 by Eupeodes, 3 years ago

I can confirm that the workaround works as expected. Thanks for the quick solution!

comment:5 by aeichner, 20 months ago

Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.

© 2023 Oracle
ContactPrivacy policyTerms of Use