Opened 3 years ago

#20478 new defect

Virtualbox locks up badly with fstrim on CentOS 8

Reported by: rincebrain Owned by:
Component: virtual disk Version: VirtualBox 6.1.24
Keywords: Cc:
Guest type: Linux Host type: Windows


I tried using fstrim, with a VM presenting a virtio-scsi "disk", and it worked for a while (defined as "the VDI file backing the FS shrinking on disk"), then eventually most IO hung indefinitely.

Most excitingly, SysRq-B resulted in the VM being stuck with its "display" showing a mix of black and occasional green boxes and not rebooting, then if I attempted to do anything to the VM (e.g. "Reset", "Poweroff"), the window became unresponsive, and I had to force-close it, and VB reported "Aborted" for the VM status.

When I tried reproducing it just now for this ticket, it instead just blocked indefinitely in the OS - no errors reported, but fstrim wouldn't respond to C or kill -9, and trying to close the VM window hung and then reported Aborted.

Attachments (1)

CentOS 8 recreate-2021-07-28-12-53-07.log (98.7 KB ) - added by rincebrain 3 years ago.

Download all attachments as: .zip

Change History (1)

by rincebrain, 3 years ago


Note: See TracTickets for help on using tickets.

© 2023 Oracle
ContactPrivacy policyTerms of Use