VirtualBox

Ticket #1995 (closed defect: duplicate)

Opened 6 years ago

Last modified 4 years ago

CPU at 100% (migrated XP guest from VMWare)

Reported by: rober1s Owned by:
Priority: major Component: host support
Version: VirtualBox 1.6.4 Keywords: CPU 100% Linux Host Windows Guest
Cc: Guest type: Windows
Host type: Linux

Description

The CPU is pegged with my XP Windows guest. The Host is an AMD 64 dual core running Kubuntu 8.04:

root@igor:/home/roberts/linux# uname -a Linux igor 2.6.24-19-generic #1 SMP Fri Jul 11 21:01:46 UTC 2008 x86_64 GNU/Linux

I have tried turning off clipboard and USB -- neither helped.

The virtual disk image is one that was converted to a single disk image from a multiple VMWare disk image set.

Attachments

VBox.log Download (42.6 KB) - added by poroussel 5 years ago.
VBox.2.log Download (33.6 KB) - added by zibalas 5 years ago.

Change History

comment:1 Changed 6 years ago by sandervl73

  • Summary changed from CPU at 100% to CPU at 100% (migrated XP guest from VMWare)

Attach your VBox.log here please.

Changed 5 years ago by poroussel

comment:2 Changed 5 years ago by poroussel

I have the same problem with virtualbox 2.0.4 on Ubuntu 8.10 (linux 2.6.27-7). I just attached my VBox.log.

comment:3 Changed 5 years ago by zibalas

Same here, Ubuntu 8.10

Changed 5 years ago by zibalas

comment:4 Changed 5 years ago by zibalas

solution is posted here:  http://forums.virtualbox.org/viewtopic.php?p=45450

Download the "HAL Updater"

Change your ACPI PC to "ACPI Uniprocessor PC".

The HAL Updater can be found here (www.hardware.info):
http://www.hardware.info/en-US/news/ym2cmZqYwp2a/Problems_updating_to_a_dualcore_CPU_Not_anymore/

The problem seems to be that windows finds a quad/dual core, installs the multicore HAL, but virtualbox only allows it to "see" one core, causing an issue.

After reboot I am not seeing the problem anymore.


comment:5 Changed 5 years ago by poroussel

Sorry to post again here but the 'Hal Updater' solution doesn't work for me.

First : after switching to Uniprocessor PC, Windows reboot and set Multiprocessor again. Second : I have the same problem on a single core machine (Athlon64 3000 I think)

Both machines run linux 2.6.27

  • Intel T2130, VirtualBox 2.0.6, 32 bits, linux 2.6.27
  • AMD Athlon64, VirtualBox 2.2.0, 32 bits, linux 2.6.27.16

Any ideas ? I'm going to try with another kernel version.

comment:6 Changed 5 years ago by csbac

I'm not sure whether you can do this with the tool, but there is a difference between "ACPI Uniprocessor" and "Advanced Configuration and Power Interface (ACPI) PC". The former one probably reverts to MP when IO-APIC and/or >1 cores are found - or believed to be found - while the latter one is completely unable to do so ...

Maby this helps,
Sebastian

comment:7 Changed 4 years ago by sandervl73

  • Status changed from new to closed
  • Resolution set to duplicate

Duplicate of #4392

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use