VirtualBox

Ticket #19470 (closed defect: fixed)

Opened 2 months ago

Last modified 5 weeks ago

VBoxClient does not implement checkhostversion in 6.1.x => fixed in svn/6.1.x x>6

Reported by: divB Owned by: paulson
Component: other Version: VirtualBox 6.1.4
Keywords: guest-additions, ubuntu Cc:
Guest type: Linux Host type: all

Description

I installed Ubuntu on a guest on Win host and the guest additions seem to be broken: Once installed, I cannot log into my Ubuntu system; I get one of these famous login loops where I immideately get back to the login prompt after login.

I started debugging and found that some x init scripts in /etc/X11 are created which call VBoxClient with various arguments. One of them is:

VBoxClient --checkhostversion

When I execute this same command on the command line I get:

# VBoxClient --checkhostversion
VBoxClient: error: No service specified. Quitting because nothing to do!

Surprisingly I did not find any similar reports but I can clearly reproduce this using VBoxGuestAdditions_6.1.0.iso, VBoxGuestAdditions_6.0.0.iso, VBoxGuestAdditions_6.1.4.iso. Versions before that seem to work.

Change History

comment:1 Changed 7 weeks ago by paulson

  • Owner set to paulson
  • Status changed from new to accepted

Thanks for the report. The handling of the '--checkhostversion' argument by VBoxClient was accidentally removed in some code refactoring a little while back. A fix is in progress.

comment:2 Changed 5 weeks ago by paulson

  • Status changed from accepted to closed
  • Resolution set to fixed

This regression was introduced in VirtualBox 6.1.0. The 'VBoxClient --checkhostversion' functionality has been restored and will be available in the next 6.1.x maintenance release of VirtualBox as well in any 6.1.x Guest Additions Testbuilds with a revision >= r133660.

comment:3 Changed 5 weeks ago by paulson

  • Summary changed from VBoxClient does not implement checkhostversion in 6.1.x to VBoxClient does not implement checkhostversion in 6.1.x => fixed in svn/6.1.x x>6
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use