VirtualBox

Ticket #19397 (closed defect: fixed)

Opened 7 months ago

Last modified 6 months ago

VirtualBox 6.1.4 GUI SEGV/crash when deleting a VM => fixed in svn/6.1.x x>6

Reported by: crunchyjohn Owned by:
Component: other Version: VirtualBox 6.1.4
Keywords: crash segmentation fault unregister vboxmanage unregistervm Cc:
Guest type: Linux Host type: all

Description (last modified by paulson) (diff)

This issue is not present in VirtualBox 6.1.2. I do not know about 6.1.3.

I use a mac for VirtualBox (Mojave, v10.14.6)

Procedure to reproduce:

  1. Install Virtual Box 6.1.4
  2. Install Vagrant 2.2.7 (latest)
  3. mkdir test
  4. cd test
  5. vagrant init centos/7
  6. Vagrant up
  7. Vagrant ssh
  8. ls -l (just proof that you did something in the VM)
  9. exit
  10. VBoxManage list runningvms
  11. Get the ID from the left column, e.g. test_default_1584037646504_61912
  12. VBoxManage controlvm test_default_1584037646504_61912 poweroff
  13. VBoxManage unregistervm test_default_1584037646504_61912 --delete
  14. VirtualBox crashes.

I have a log that it tries to send to Apple, which I'll attach if I can.

Attachments

crash.log Download (60.5 KB) - added by crunchyjohn 7 months ago.
Crash log

Change History

Changed 7 months ago by crunchyjohn

Crash log

comment:1 Changed 7 months ago by crunchyjohn

Sorry-- host was MacOS, Guest was CentOS/7

comment:2 Changed 7 months ago by fbatschu

  • Host type changed from other to Mac OS X
  • Guest type changed from OSX Server to Linux

comment:3 Changed 7 months ago by crunchyjohn

Any update?

A crash seems like a pretty severe problem, so I'm hoping others are able to easily reproduce it.

Is there anything else I can do to help?

comment:4 Changed 6 months ago by nycnewman

Sounds similar to problem where VirtualBox crashes when last VM deleted through UI.

comment:5 Changed 6 months ago by paulson

  • Host type changed from Mac OS X to all
  • Description modified (diff)
  • Summary changed from Virtual Box 6.1.4 segementation fault / crash on "VBoxManage unregistervm" to VirtualBox 6.1.4 GUI SEGV/crash when deleting a VM

Thanks for the report. This is a regression introduced in 6.1.4 which affects all hosts. As @nycnewman reported in #19490 this is a problem in the VirtualBox GUI and as reported here is also reproducible if running 'VBoxManage unregistervm VMname --delete' of a VM while the GUI is running.

The easiest way to reproduce this on the command line is the following which works for me when there are no other VMs created:

$ VirtualBox &
$ VBoxManage createvm --name fubar --register
$ VBoxManage unregistervm fubar --delete
[1] + Memory fault(coredump) VirtualBox

comment:6 Changed 6 months ago by paulson

  • Status changed from new to closed
  • Resolution set to fixed
  • Description modified (diff)
  • Summary changed from VirtualBox 6.1.4 GUI SEGV/crash when deleting a VM to VirtualBox 6.1.4 GUI SEGV/crash when deleting a VM => fixed in svn/6.1.x x>6

This has been addressed in revision r137409 of the development branch of VirtualBox and will be available in any development snapshot Testbuilds which includes that revision. The fix has also been backported to the 6.1 branch of VirtualBox as of revision r137698 and will be available in any 6.1.x Testbuilds which include that revision. The fix will also be part of the next maintenance release of VirtualBox.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use