VirtualBox

Ticket #1931 (closed defect: obsolete)

Opened 6 years ago

Last modified 5 months ago

Cannot boot Coherent from bootable floppy image

Reported by: Andrzej Popielewicz Owned by:
Priority: minor Component: other
Version: VirtualBox 1.6.2 Keywords:
Cc: Guest type: other
Host type: other

Description (last modified by frank) (diff)

I am using Solaris 10 x86, (uname -a -> SunOS unknown 5.10 Generic_Patch_118844-30 i86pc i386 i86pc) and using latest VirtualBox 1.6.2. I am trying to boot Coherent 4.2.10 from bootable floppy image. Kernel is loaded but crashes due to error in mounting/opening root filesystem(floppy). The identical message was produced in qemu previous to 1.6.1. Since qemu 1.6.1 Coherent bootable floppy boots OK and one can install Coherent to hard disk image.I suspect that some io addresses are not mapped correctly by VirtualBox.The error message is produced by Coherent kernel executing inb/outb instructions. It means comparison what was made in qemu 1.6.1 could be useful. The bootable floppy image for Coherent can be created from 4 installer files in TUHS archive. This bug report was suugested by Sun employee in the OpenSolaris forum.

Attachments

coherent-2008-08-09-22-35-23.log Download (25.5 KB) - added by Andrzej Popielewicz 6 years ago.

Change History

Changed 6 years ago by Andrzej Popielewicz

comment:1 follow-up: ↓ 2 Changed 6 years ago by Technologov

Excuse me, but latest Qemu is 0.9.1. (not 1.6.1)

-Technologov

comment:2 in reply to: ↑ 1 Changed 6 years ago by Andrzej Popielewicz

Replying to Technologov:

Excuse me, but latest Qemu is 0.9.1. (not 1.6.1)

-Technologov

Yes , sorry. It means Coherent works OK in Qemu 0.9.1 , but NOT for prior versions of qemu. If neccesarry I can supply logs and other files from qemu session in Linux.

comment:3 Changed 6 years ago by Andrzej Popielewicz

Ticket 1932 is a duplicate of ticket 1931. It means it can be removed.

comment:4 follow-ups: ↓ 6 ↓ 8 Changed 6 years ago by frank

And the latest version of VirtualBox is 1.6.4 not 1.6.2.

comment:5 follow-up: ↓ 7 Changed 6 years ago by frank

Please could you start this session with

VBoxSDL -norawr0 -startvm coherent

and check if that works?

comment:6 in reply to: ↑ 4 Changed 6 years ago by Andrzej Popielewicz

Replying to frank:

And the latest version of VirtualBox is 1.6.4 not 1.6.2.

OK, I will try to install 1.6.4 if it is available for Solaris.

comment:7 in reply to: ↑ 5 Changed 6 years ago by Andrzej Popielewicz

Replying to frank:

Please could you start this session with

VBoxSDL -norawr0 -startvm coherent

and check if that works?

I have added /opt/csw/lib to LD_LIBRARY_PATH and VirtualBox could not start.But after adding /opt/sfw/lib to LD_LIBRARY_PATH I could execute above proposed command but the error message persists.

comment:8 in reply to: ↑ 4 ; follow-up: ↓ 9 Changed 6 years ago by Andrzej Popielewicz

Replying to frank:

And the latest version of VirtualBox is 1.6.4 not 1.6.2.

I have removed 1.6.2 and installed 1.6.4. The same message with coherent as before(used under CDE, see below). But surprise : after reboot of Solaris I could not start JavaDesktop because of some Gnome error, the only way to go on was to make CRTL/ALT/Backspace and login via CDE. But CDE of course is not interesting because firefox does not start (perhaps after adding libs to library path one could make it going) etc ,etc. I had to remove 1.6.4 and reinstall old 1.6.2 .Perhaps it is situation for bug report but please another time.

comment:9 in reply to: ↑ 8 Changed 6 years ago by Andrzej Popielewicz

Replying to Andrzej Popielewicz:

Replying to frank:

And the latest version of VirtualBox is 1.6.4 not 1.6.2.

I have removed 1.6.2 and installed 1.6.4. The same message with coherent as before(used under CDE, see below). But surprise : after reboot of Solaris I could not start JavaDesktop because of some Gnome error, the only way to go on was to make CRTL/ALT/Backspace and login via CDE. But CDE of course is not interesting because firefox does not start (perhaps after adding libs to library path one could make it going) etc ,etc. I had to remove 1.6.4 and reinstall old 1.6.2 .Perhaps it is situation for bug report but please another time.

OK, the conclusion that gnome problem depends on virtualbox was of course wrong. It was coincidence in time , namely gnome problem was observed after install of 1.6.4. I have updated gnome (patch detected by Sun UpdateManager) and now gnome starts well. This is why I have reinstalled virtualbox 1.6.4 . But the coherent error occurs as before.

comment:10 Changed 4 years ago by Barron123

See here,  Google, for further info.

comment:11 Changed 4 years ago by Barron123

Also, there was an issue with resource ZendStudioReview online.

comment:12 Changed 5 months ago by frank

  • Status changed from new to closed
  • Resolution set to obsolete
  • Description modified (diff)

comment:13 Changed 5 months ago by andrzejpopielewicz

Correct action. I have forgotten about this ticket. In the meantime Coherent image boots well if used with VirtualBox 4.2.4.x so the problem is resolved since two years.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use