VirtualBox

Ticket #192 (closed defect: wontfix)

Opened 7 years ago

Last modified 4 years ago

OpenBSD reports full disk on install (requires VT-x or AMD-V; unsupported with software virtualization)

Reported by: scy Owned by:
Priority: major Component: other
Version: VirtualBox 2.0.6 Keywords:
Cc: Guest type: BSD
Host type: other

Description

OpenBSD (3.9) aborts the installation process reporting a full disk.

uid 0 on /: file system full

/: write failed, file system is full

I've tried static and dynamic images, and there is also much free space on the file system of the host os.

Tested with VirtualBox 1.3.6 and 1.3.8

Attachments

virtualbox-dmesg-boot.png Download (31.5 KB) - added by ellobo 7 years ago.
2007-11-16-094928.png Download (295.3 KB) - added by pitillo 6 years ago.
Capture.
VBox.log Download (24.2 KB) - added by pitillo 6 years ago.
Vbox.log
VBox.2.log Download (40.2 KB) - added by adelfino 5 years ago.
This is what I get when trying to run OpenBSD 4.4 with VirtualBox 2.1.0 (VT-x/AMD-V disabled)
VBox.3.log Download (40.1 KB) - added by adelfino 5 years ago.
This is what I get when trying to run OpenBSD 4.4 with VirtualBox 2.1.0 (VT-x/AMD-V enabled)
obsd-2009-09-28-22-16-19.log Download (33.6 KB) - added by aspringer 5 years ago.

Change History

comment:1 Changed 7 years ago by sharms

I can confirm this bug using OpenBSD 4.0 network / pxe install.

comment:2 follow-up: ↓ 3 Changed 7 years ago by michael

Just to be sure - the virtual hard disk is not on a FAT partition on the host, is it?

comment:3 in reply to: ↑ 2 Changed 7 years ago by scy

Replying to michael:

Just to be sure - the virtual hard disk is not on a FAT partition on the host, is it?

No, for me its XFS.

comment:4 Changed 7 years ago by sharms

EXT3 here

comment:5 Changed 7 years ago by Sascha

Also on Ubuntu 7.04 as host, ext3fs, OpenBSD4.1 as guest.
Dynamic images as well as fixed size images.

It crashes/reboots randomly during install of FreeBSD6.2 in a VirtualBox.

comment:6 Changed 7 years ago by chb

Same here container either fixed or dynamic - Host FS is Reiser 3.6 OpenBSD 4.1 as guest

comment:7 Changed 7 years ago by Sascha

This error is still present in a VirtualBox 1.4.0

My system is Ubuntu 7.04
Guest should be OpenBSD4.1

Besides that it stops while installing FreeBSD6.2 sets with disk full error.

Can we do something to narrow this ?
Maybe dmesg ?

comment:8 Changed 7 years ago by ellobo

I'm attaching a screenshot in PNG format of the boot messages, the portion that shows info found by OpenBSD4.1 on a guest system configured with a 7.81GB fixed size VDI. My host OS is Ubuntu 7.04 and the FS is ext3

Changed 7 years ago by ellobo

comment:9 Changed 7 years ago by chb

Almost half a year and no solution yet - :-/

comment:10 Changed 7 years ago by ellobo

Yay this bug is fixed in SVN :-). The Linux build instructions work like a charm. Thanks!

comment:11 Changed 7 years ago by rancor

I can't even install OpenBSD 4.1 on VB 1.4.0 because of this error message during install just before I shall create disk labels:

wd0c: device timeout writing fsbn 0 (wd0 bn 0;cn 0 tn 0 sn 0), retrying wd0(pciide0:0:0):timeout

type: ata c_bcount: 512 c_skip: 0

This message is repeated several times until this message occurs fdisk: error writing MBR: Input/output error fdisk: eof done.

I have tried both dynamic and static disk size.

Host OS: Windows XP Professional SP2 Swedish

comment:12 Changed 7 years ago by sandervl73

  • Status changed from new to closed
  • Resolution set to fixed

Fixed in 1.5.0. Closing.

Changed 6 years ago by pitillo

Capture.

Changed 6 years ago by pitillo

Vbox.log

comment:13 Changed 6 years ago by pitillo

  • Status changed from closed to reopened
  • Resolution fixed deleted

Hello,

i attached 2 files to show you the problem with VirtualBox 1.5.2 OSE in a CRUX 2.3 host using reiserfs while trying to install OpenBSD 4.2. The guest is getting me the error shown at capture file 2007-11-16-094928.png

I hope this can be usefull.

Thank you for your work. Regards.

comment:14 follow-up: ↓ 15 Changed 6 years ago by frank

How big is your guest hard disk?

comment:15 in reply to: ↑ 14 Changed 6 years ago by pitillo

Replying to frank:

How big is your guest hard disk?

I tried with the default value 2048Mb and another try with one around 6Gb.

comment:16 Changed 6 years ago by Technologov

It is damn strange, because here OpenBSD 4.1 and 4.2 both detected 8GB hard disk.

Host: Windows XP SP2, 4GB RAM, Core 2 Quad. VirtualBox 1.5.2.

Guest: OpenBSD 4.2, 128 MB of RAM, 8 GB HDD.

Nevertheless, guest segfaulted when attempted to be installed. I will open separate bug.

-Technologov. 16.11.2007.

comment:17 Changed 6 years ago by Technologov

Update: this segfaults bug already exists as bug #639.

comment:18 Changed 6 years ago by frank

  • Guest type changed from other to BSD

comment:19 follow-up: ↓ 20 Changed 6 years ago by adelfino

VirtualBox 1.6 has this bug.

comment:20 in reply to: ↑ 19 ; follow-up: ↓ 21 Changed 6 years ago by adelfino

Replying to adelfino:

VirtualBox 1.6 has this bug.

On Windows XP.

comment:21 in reply to: ↑ 20 Changed 6 years ago by radious

Replying to adelfino:

Replying to adelfino:

VirtualBox 1.6 has this bug.

On Windows XP.

On Linux too, VB ver 1.6.4 host partition is reiserfs.

comment:22 follow-up: ↓ 24 Changed 6 years ago by frank

  • Version changed from VirtualBox 1.3.6 to VirtualBox 1.6.4

And all of you are talking about BSD guests, correct?

comment:23 Changed 6 years ago by radious

Yes, latest OpenBSD in my case.

comment:24 in reply to: ↑ 22 Changed 6 years ago by radious

Replying to frank:

And all of you are talking about BSD guests, correct?

I'm talking about latest OpenBSD install cd and guest set as OpenBSD in VB Machine creator.

PS. Sorry for double posting, I haven't thought about clicking 'Reply'

comment:25 Changed 6 years ago by lawrence

Same behavior on VirtualBox 1.6.4 on Mac OS X 10.5.4.

I was trying to install OpenBSD (August 21, 2008 snapshot) and got that "uid 0 on /: file system full" message while in the bsd.rd installation environment.

comment:26 Changed 5 years ago by jhaensli

This bug is still an issue for VirtualBox: 2.0.6r39765
Host: Ubuntu 8.04.1 (2.6.24-18)
Guest: OpenBSD 4.4

It would be nice to hear if there are any workarounds. (Is OpenBSD running in a VBox of someone?) Otherwise, it would be incorrect to say that VirtualBox is capable of running OpenBSD as guest.
Is someone investigating this issue further?

Many Thanks

comment:27 Changed 5 years ago by bughunter2

Why isn't this being investigated? I understand that there a lot of items having priorities but this is a critical bug and it affects both OpenBSD and NetBSD.

Please Sun, fix it.

comment:28 Changed 5 years ago by rrioux

Confirmed here as well. Very annoying - Sun? Anyone?

Host:

Gentoo x86 / Pentium 4

VirtualBox 2.0.6

Guest:

OpenBSD 4.4 i386

6GB VDI

Message (received after modifying HD during install):

uid 0 on /: file system full

/: write failed, file system is full

Segmentation fault

comment:29 follow-up: ↓ 30 Changed 5 years ago by frank

Sure, everyone thinks that his bug is the most important one and of course, all bugs are critical.

comment:30 in reply to: ↑ 29 Changed 5 years ago by rrioux

Replying to frank:

Sure, everyone thinks that his bug is the most important one and of course, all bugs are critical.

Well, if they are going to advertise a particular guest OS as "supported," and it isn't, I'd imagine that is critical.

comment:31 Changed 5 years ago by azara

Hi,

just tried to install OpenBSD 4.4 on VirtualBox 2.0.6 (XP host). First I was glad to find OpenBSD on the list of OSes, then I ran into this bug... and now I can't believe that the problem has been reported 18 months ago already :-(

Installation works neither with "OpenBSD" nor with "Other/Unknown" as OS selection. Is there really no workaround for this problem (except reverting to VMWare)?

If not, as mentioned by rrioux, then OpenBSD should at least disappear from the list of supported guest OSes... which would be a pity.

Regards,

/alex

comment:32 Changed 5 years ago by sandervl73

  • Version changed from VirtualBox 1.6.4 to VirtualBox 2.0.6

Try it with VT-x or AMD-V instead. And complaining without useful feedback (VBox.log) isn't going to help either.

comment:33 Changed 5 years ago by azara

Thanks for your help. After 18 months I suppose this bug is not a technical problem in the first place, but a matter of priorities. And in this case it could help to point out that same people do want to use the advertised feature "OpenBSD support".

BR/alex

comment:34 Changed 5 years ago by jhaensli

Works now for me!

I have updated to VirtualBox 2.1.0r41146

Host: Ubuntu 8.04.1 (2.6.24-18)

Guest: OpenBSD 4.4

Despite I had a Segmentation fault at the end of the OpenBSD installation I rebooted.
OpenBSD 4.4 is now running in VirtualBox on a dedicated VM Server, thus headless. I assume it will work in UI mode as well!

Give it a try!

Cheers
Jan

comment:35 Changed 5 years ago by hoover

I can confirm the error still exists on VirtualBox 2.1 running on Ubuntu 8.04 LTS/i386. I'm trying to install openbsd4.4 from the install44.iso image and I'm getting the same error after writing the disklabel during the install process.

Partition layout is simple (4G total virtual, dynamic disk) with 512m swap in a and the rest of the disk assigned to b fstype 4.2BSD.

Underlying host filesystem is reiserfs.

Installation starts despite of the error, then sometime during the comp44.tgz extraction, the error reappears although there should be plenty of space in / (around 4g, choosing the default openbsd install set).

All the best & merry christmas,

hoover

Changed 5 years ago by adelfino

This is what I get when trying to run OpenBSD 4.4 with VirtualBox 2.1.0 (VT-x/AMD-V disabled)

Changed 5 years ago by adelfino

This is what I get when trying to run OpenBSD 4.4 with VirtualBox 2.1.0 (VT-x/AMD-V enabled)

comment:36 Changed 5 years ago by adelfino

Both times I tried, the error appeared.

comment:37 in reply to: ↑ description Changed 5 years ago by gretel

works for me.

Host: VirtualBox 2.1.4, OS X 10.5.6 Guest: OpenBSD 4.5 GENERIC#1749 i386

VT-x/AMD-V has to be enabled, otherwise the installation fails as described. enabling PAE is working in addition.

comment:38 Changed 5 years ago by alexhq

Having "disk full" wehn installing and also random "segmentation fault" when installing and on already installed systems. VBox 2.2, OpenBSD 4.4, 4.3

comment:39 Changed 5 years ago by mrmagoo

I experienced the 'file system full' issue during install, along with the random 'seg faults'. I was using VirtualBox 2.2.0 on 32 bit Vista.

I was able to work around the file system full during install by creating multiple disk labels instead of using one big disk label for root (i.e. separate labels for /var, /usr, etc.)

I did not find a work around for the seg faults. I switched to VMWare Workstation and was able to complete the same project on OpenBSD with no errors, so this seems limited to Virtual Box.

If there is any information that will assist the developers in fixing this bug, I am willing to troubleshoot.

comment:40 Changed 5 years ago by vladak

I have just tried that with OpenBSD 4.5 and Virtual box 2.2.2 running on Solaris Nevada build 113 (amd64, 64-bit) and I was able to install (albeit it complained about the 'disk full' at the beginning once) but when trying to compile the kernel it failed with segmentation fault.

comment:41 in reply to: ↑ description Changed 5 years ago by ohir

Confirmed for Virtualbox 2.2.4. hostOS: Windows XP SP3 / guestOS: OpenBSD 4.5 I managed to run OpenBSD 4.2 that was created under VMware server though. No luck with native vdi install under VBox. Sun should decide - either delist OpenBSD as supported guest or finally assign this issue to someone.

comment:42 Changed 5 years ago by gpatrick

Installed OpenBSD 4.5 and VirtualBox 3.0.2 in a non-global zone on OpenSolaris 2009.06 host. Received disk full and seg faults at installation although it installed. It's running but also received seg faults on startup and shutdown.

comment:43 Changed 5 years ago by gpatrick

OpenBSD 4.5 on VirtualBox 3.0.4 on an OpenSolaris 0906 host has installed and is running successfully. No disk full or segmentation faults occurred during installation or upon booting.

Using an Acer Aspire 5515 laptop. Used VirtualBox defaults (e.g., Enable VT-x/AMD-v).

comment:44 Changed 5 years ago by bughunter2

As said earlier by someone: "VT-x/AMD-V has to be enabled, otherwise the installation fails as described. enabling PAE is working in addition."

So, mentioning that you got it to work while having VT-x/AMD-V enabled is not really stunning news.

comment:45 Changed 5 years ago by gpatrick

It is stunning news because I had those enable before and it never worked. Also if you read back in the thread, others have tried to enable that before and they still had failures.

And if you also read back that I earlier had it running on 3.0.2 but had segmentation faults, which I don't have now using 3.0.4.

Apparently you pick and choose which threads you read, because after the date of that thread: 2009-04-10 09:27:17 changed by alexhq ¶ Having "disk full" wehn installing and also random "segmentation fault" when installing and on already installed systems. VBox 2.2, OpenBSD 4.4, 4.3

2009-05-04 16:34:38 changed by vladak ¶ I have just tried that with OpenBSD 4.5 and Virtual box 2.2.2 running on Solaris Nevada build 113 (amd64, 64-bit) and I was able to install (albeit it complained about the 'disk full' at the beginning once) but when trying to compile the kernel it failed with segmentation fault.

comment:46 Changed 5 years ago by gpatrick

In the other OpenBSD ticket: 2009-06-30 20:10:20 changed by fdgonthier ¶ The same OpenBSD VM fails spectacularily with VirtualBox 3.0, with VT-x/AMD-V enabled or not.

Dolt.

comment:47 Changed 5 years ago by bughunter2

Hey, my bad Patrick, ol' buddy. Everyone makes mistakes, let's not get into a cock fight by calling each other names.

comment:48 Changed 5 years ago by frank

I've removed the last comment which was almost unreadable. Guys, please: There is an ATTACH button!

comment:49 Changed 5 years ago by aspringer

guest openbsd 4.5 host linux/debian 5.0/ext3 VIRTUAL BOX latest ver.. seg fault many. install fail file system full

Need any details ask. Years old bug and the post is unreadable!

comment:50 Changed 5 years ago by clockfort

I have this bug and cannot install OpenBSD in a VM these two machines. Guest OS: OpenBSD 4.5 Host 1: Linux/ext4/intel atom Host 2: Linux/ext3/intel P4

Cannot install due to "full disk" segfault error on both systems.

comment:51 Changed 5 years ago by aspringer

Host OSX Darwin Kernel Version 9.6.0: Mon Nov 24 17:37:00 PST 2008 VB VirtualBox-3.0.6-52128-OSX.dmg Guest OpenBSD 4.5 Disk full / seg fault / install fails! You guys rock! 3 years and counting!

comment:52 Changed 5 years ago by sandervl73

  • Status changed from reopened to closed
  • Resolution set to wontfix
  • Summary changed from OpenBSD reports full disk on install to OpenBSD reports full disk on install (requires VT-x or AMD-V; unsupported with software virtualization)

aspringer: you're welcome to provide a patch to fix the problem.

OpenBSD needs VT-x or AMD-V and you must make sure it's enabled properly. If you don't have a CPU that supports either, then you're out of luck. I will close this ticket now as nobody has attached a log with hardware virtualization turned on.

As this ticket contains too much noise, I suggest to create a new one.

Changed 5 years ago by aspringer

comment:54 Changed 5 years ago by frank

According to the Intel processor finder your CPU indeed supports VT-x but the log file you attached states that this extension is disabled, most likely in the BIOS. Once locked by the BIOS it cannot be unlocked again by any software when the machine is booted. You could verify your BIOS settings or try to upgrade the BIOS. Actually this is a problem of your hardware and not a problem of VirtualBox. You can send your thanks to your hardware vendor.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use