VirtualBox

Ticket #19157 (closed defect: duplicate)

Opened 2 years ago

Last modified 2 years ago

vbox 6.1 on linux host with win10 guest - buggy mousecursors at 150% scale

Reported by: dentar Owned by:
Component: other Version: VirtualBox 6.1.0
Keywords: Cc:
Guest type: other Host type: other

Description

I'm running vbox 6.1 on fedora30 with win10 x64 as guest. At a first glance, this is fine, until you start using the ms office365 suite.

Independent of 3D settings (currently, i have 3D disabled because of still existing problems with screen updates in e.g. powerpoint) i experience mouse cursor problems when windows is in scaling mode.

My current experiments with office365/powerpoint shows problems when the mouse cursor is changing depending on context. Normal arrow pointer is fine, and when hovering over objects at the enclosing object frame-sides the mouse cursor changes properly to left/right or up/down arrows. But, if you have a cursor looking like a crosshair similat to a '+' sign (to move objects) then the cursor is scrambled to a rectangle with random pixels in it. Moving the mouse away restores the cursor to the pointing arrow again.

This is independent of the 3D setting, but dependent on the win10 scaling:

win10 in 100% scaling: cursors are ok

win10 in 125% scaling: cursors are ok

win10 in 150% scaling: cursors are scrambled (see above, depending on context)

Change History

comment:1 Changed 2 years ago by socratis

  • Status changed from new to closed
  • Resolution set to duplicate

Duplicate of #14366.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use