VirtualBox

Ticket #14366 (reopened defect)

Opened 4 years ago

Last modified 3 days ago

Cursor misscaled in HiDPI mode when using mouse integration

Reported by: nitrous Owned by:
Component: GUI Version: VirtualBox 5.0.0
Keywords: HiDPI, retina, mouse integration, cursor Cc:
Guest type: Linux Host type: Mac OS X

Description

I am using an OS X 10.10.4 host on a Macbook Pro retina with an archlinux guest, exposing unscaled hidpi output to the guest. When mouse integration is enabled, the cursor is comically oversized -- multiplied by a factor of 2 from the hidpi bug because of my retina display, and another 1.5x from the guest's dpi, giving a 3x size cursor.  This forum post suggests it affects other guests too, though I'm not sure about other hosts.

I think the problem is probably that the mouse integration code which implements the hardware cursor is hidpi-unaware and so writes the cursor pixels naively instead of to the underlying device pixels. As a result, the cursor is obviously pixellated and out-of-place with the rest of the guest. Presumably the solution is to simply test whether unscaled mode is on and to then remap the cursor to device pixels.

Change History

comment:1 Changed 4 years ago by dax

Just to confirm: same problem affects Windows 8.1 Guest and HiDPI activated. Temporary workaround: disabling Mouse Integration.

comment:2 Changed 4 years ago by Radhe

I have a Windows 10 guest on Mac OS 10.10.5 (Yosemite) host using VirtualBox 5.0.4. Same problem.

Workaround is not a good one for me, personally. Rather deactivate Unscaled HiDPI mode.

comment:3 Changed 4 years ago by s4y

Same here, this is annoying.

comment:4 Changed 4 years ago by tk111

Same story on OS X as host, and Linux & Windows (guest), cursor is huge when hidpi & scaling is On.

comment:5 Changed 4 years ago by 32bits

Same here. OS X host, Windows 10 guest. Disabling mouse integration is the only work around.

comment:6 Changed 4 years ago by hardingt

Also having the same issue, this issue is now 9 months old, more and more HiDPI devices are being released, this is going to show up more and more often. OSX Host, Windows 10 client

Last edited 4 years ago by hardingt (previous) (diff)

comment:7 Changed 4 years ago by Grillbrick

Also having the same issue. Mac OS 10.11.4 (Host) and Windows 10 (Guest).

comment:8 Changed 3 years ago by frank

Should be fixed in 5.1. Please try the most recent available Beta (currently 5.1 Beta 3).

comment:9 Changed 3 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

comment:10 Changed 3 years ago by adaugherity

  • Status changed from closed to reopened
  • Resolution fixed deleted

This does not appear to be fixed in 5.1.2 -- I still have the giant mouse cursors in a Windows 10 guest.

(I currently have much bigger problems with Unscaled HiDPI, like #15707, but noting for the record that the mouse cursor bug is still present.)

comment:11 Changed 3 years ago by Jorrit

A similar issue is the following:

I have 4K display but I want to run my Win10 and Ubuntu machines on lodpi so I set scaling to 200%. Everything works fine, much better than VMware, except for the cursor: it is displayed at half the expected size.

comment:12 Changed 3 years ago by hardingt

Still not fixed, 10.11.5 Host, Windows 10 Enterprise Guest, 5.0.26 r108824. Giant mouse cursor in HiDPI mode. If you turn off mouse integration it is back to the size it should be, but choppy as hell, which is probably why mouse integration exists.

Last edited 3 years ago by hardingt (previous) (diff)

comment:13 follow-up: ↓ 29 Changed 11 months ago by rokopt

I upgraded to VirtualBox 6.0 (from the latest 5.x) today, and immediately this issue appeared on all my VMs (which include both Linux and Windows 10 guests). My host is running Windows 10 at 4K resolution. The mouse pointer is so large as to make it difficult to tell what I'm clicking on. As others have observed, turning off mouse pointer integration restores it to the proper size, but makes moving it choppy and requires clicks or keypresses to capture and release the pointer.

comment:14 Changed 10 months ago by ThetaPhi

The issue now also appeared in my Virtualbox 6.0.2 installation on Windows. I also have a Higher DPI display which is normally scaled by Windows to 150%. The VM is running Windows 10 with native solution and the client VM therefore also zooms by 150%. It looks like the mouse cursor seems to be scaled 2 times, by the Host and the Guest (150%*150% = 225%).

comment:15 Changed 10 months ago by papayo29

Same here. VirtualBox 6.0.4 on Windows 10 host connected to a 4K monitor. At 4K resolution the mouse cursor is misscaled and is very large on both Windows and Linux guests. Using the Windows host default zoom setting at 150% gives an insanely large cursor. Reducing the Windows host zoom setting to 100% has some effect ont VMs' cursor size, but cursor is still larger than should be. When the host monitor resolution is lowered (i.e to 2560x1440) the VMs' mouse cursor is displayed at a normal size

Last edited 10 months ago by papayo29 (previous) (diff)

comment:16 Changed 9 months ago by Thorarin

It gets really silly when you have a 4k laptop and both Windows host and guest are set to 250% scaling.

VirtualBox 6.0.4, Windows 10 host, Windows 10 guest.

comment:17 Changed 9 months ago by annaparker

Same here, just switched from well working VBOX5 to VBOX 6 and experiencing the same problem. The guest OS Windows, same problem from XP to 8.1.

EDIT: Downgrade successful.

Last edited 9 months ago by annaparker (previous) (diff)

comment:18 Changed 9 months ago by 57696C6C69616D

Yeah, I have this as well on Vbox 6. The large cursor in Windows 10/10 ltsb. Also the cursor doesn't quite line up with what I am clicking on, so I have to guess a little. Turning off Windows scaling does fix the issue.

comment:19 Changed 9 months ago by i39dn6

This is happening for me as well with 6.0.4, Windows 10 host and Windows 10 guest. Host and guest are set to 150% scaling on a ThinkPad T470p. It is very distracting and at times almost unusable to have such a comically large mouse pointer, and turning off mouse integration results in a poor experience (jumpy/delayed cursor, having to hit host key to get out of VM).

comment:20 Changed 9 months ago by Georg

Same problem here windows 10 host, windows 10 guest, 2 display both 4k resolution on Dell laptop. Had to downgrade to Vbox 5 because this defect is a blocker for using any version 6.

Please take car of this issue soon.

In case you need more information feel free contact me.

comment:21 follow-up: ↓ 23 Changed 8 months ago by adaugherity

Perhaps this would get more attention if someone with access modified the host type for this ticket to All. It was originally reported against Mac hosts but many recent comments refer to Windows hosts.

comment:22 Changed 8 months ago by iljau

Experiencing issue with version 6.0.4 on Windows 10 host (display scaling is set to 150%) and Ubuntu guest.

Version 5.2.26 didn't have the issue - mouse cursor was normal size.

comment:23 in reply to: ↑ 21 ; follow-up: ↓ 24 Changed 8 months ago by Georg

Replying to adaugherity:

Perhaps this would get more attention if someone with access modified the host type for this ticket to All. It was originally reported against Mac hosts but many recent comments refer to Windows hosts.

You are right. As no one seems to take care, created a new ticket. Maybe this gets more attention.

https://www.virtualbox.org/ticket/18521

comment:24 in reply to: ↑ 23 Changed 8 months ago by socratis

Replying to Georg:

Maybe this gets more attention.

No, actually it won't. What you did manage to accomplish however, is to create a duplicate and take away those precious 3' from a developer that needs to close the other ticket.

This is not a way to draw attention. And attention isn't needed actually, they know. Keep in mind that psychological pressure, the sort that you tried to apply, actually makes the developers less keen to look at an issue.

You're not talking about an earth shuttering bug with loss of data on the host. You're talking about a cosmetic bug with a known workaround.

comment:25 Changed 7 months ago by MClark

I'm experiencing this in version 6.0.6. Win7 host, Ubuntu guest.

The mouse pointer not only appears large in the guest, the guest does not register clicks.

This problem manifests when Windows text (on the host) is set to "Larger - 150%". The workaround is to either disable mouse integration, or to change text in Windows to "Medium - 125%" or "Smaller - 100%".

comment:27 Changed 5 months ago by ViSan

Hi, I'm using Windows 10 host, this is only happening on VirtualBox 6 after installing the virtualbox extension pack. I use Crystal Reports so this is getting in the way for the design.

Last edited 5 months ago by ViSan (previous) (diff)

comment:28 Changed 5 months ago by dvp

I'm also seeing this on a Windows 10 host, with Windows 10 clients.

comment:29 in reply to: ↑ 13 ; follow-up: ↓ 30 Changed 4 months ago by rokopt

I tried again on 6.0.10 and the problem still exists.

Replying to rokopt:

I upgraded to VirtualBox 6.0 (from the latest 5.x) today, and immediately this issue appeared on all my VMs (which include both Linux and Windows 10 guests). My host is running Windows 10 at 4K resolution. The mouse pointer is so large as to make it difficult to tell what I'm clicking on. As others have observed, turning off mouse pointer integration restores it to the proper size, but makes moving it choppy and requires clicks or keypresses to capture and release the pointer.

comment:30 in reply to: ↑ 29 Changed 4 months ago by DanglerackChowderpants

My position is exactly the same as rokopt.

Another possible workaround is to change your guest's mouse pointer to the smallest one available. For me, this reduces the effect of the misaligned clicking.

Last edited 4 months ago by DanglerackChowderpants (previous) (diff)

comment:31 Changed 3 months ago by deckard

My position is also exactly the same as rokopt.

comment:32 Changed 2 months ago by EricV

Just tried VirtualBox 6.0.12 and the Cursor misscaled in HiDPI problem still exists. I successfully downgraded to VirtualBox 5.2.32 again where the problem does not exist. Will this problem be solved in VirtualBox 6.X or do I need to be looking for another virtualization product?

comment:33 Changed 3 weeks ago by Scimmiaparlante

I have the same issue. Virtualbox 6.0.14 on Windows 10. Guest OS: Debian 8

comment:34 Changed 3 weeks ago by osteng

This issue basically affects all users running Windows 10 or Mac OS X with a HiDPI display and it's 4 years since it was first reported. This should really be fixed by now.

I run Virtualbox 6.0.14 on Windows 10 with Arch Linux as guest OS, and I have the same problem.

comment:35 Changed 2 weeks ago by jdhackn

I have the same issue with a Windows 10 host and the Manjaro OS as my guest. I was wondering if there has been any traction at all on getting this issue resolved? It has been an issue with a varying degree of impact for a long time now. VirtualBox has typically been my "go-to" VM product but this issue, in particular, has become a bit glaring for obvious reasons. Until this issue is resolved I'm going to have to move over to Hyper-V or VMWare I think so that I can work in peace.

comment:36 Changed 3 days ago by dnmast

I have a Win XP guest on a Win 10 host with a high DPI monitor and have not had this problem in VirtualBox 6.0.14, but instead have had a normal small cursor. After a Win 10 update and reboot this morning, it is showing the unusably large and misplaced cursor, which makes editing dialogs in Visual Studio very difficult. I've gone back to 5.2.34. I hope this gets fixed.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use