VirtualBox

Ticket #18521 (closed defect: duplicate)

Opened 2 years ago

Last modified 23 months ago

Cursor misscaled in HiDPI mode when using mouse integration -> duplicate of #14366

Reported by: Georg Owned by:
Component: GUI Version: VirtualBox 6.0.4
Keywords: Cc:
Guest type: Windows Host type: all

Description

When running Virtualbox on hiDPI display with 4k resolution mouse cursor is misscaled. Issue affects multiple host systems. MacOS and Windows at least.

See also the older ticket that has been reopened: https://www.virtualbox.org/ticket/14366

Created this ticket as for the old ticket it is not possible to change the affected version.

Attachments

Mouse.png Download (32.1 KB) - added by StS 2 years ago.

Change History

comment:1 Changed 2 years ago by socratis

Duplicate of #14366.

You don't need to create a ticket per version. It would mean duplicate upon duplicate upon duplicate. If an issue is not marked as fixed/resolved, that means it applies to the current version as well.

And the important thing is not what version it applies to, but at what version the problem started.

comment:2 Changed 2 years ago by michael

  • Status changed from new to closed
  • Resolution set to duplicate
  • Summary changed from Cursor misscaled in HiDPI mode when using mouse integration to Cursor misscaled in HiDPI mode when using mouse integration -> duplicate of #14366

comment:3 follow-up: ↓ 4 Changed 2 years ago by StS

  • Status changed from closed to reopened
  • Resolution duplicate deleted

I have the same issue, same host resulution, windows host and windows guest. Host scaling is set to 150%, guest scaling is set to 100%, guest additions are installed.

Under this conditions, the mouse cursor is scaled by 150%. As a result, marking is very difficult.

But this didn't occur with VirtualBox 5.x. So it should be a new issue, not a copy of #14366.

Additionally, guest size seems to be limited. I had to configure

VBoxManage setextradata global GUI/MaxGuestResolution any

for a guest with 2138x1590, otherwise it was set to a lower resolution on guest startup. This might be a different issue, but also related to the new "scaling support" of 6.x.

comment:4 in reply to: ↑ 3 Changed 2 years ago by socratis

Replying to StS:

I have the same issue, same host resulution, windows host and windows guest. Host scaling is set to 150%, guest scaling is set to 100%, guest additions are installed.

  1. That's not the same issue. If you follow #14366 you'll see that the problem is with the guest scaling to 150% or more, not the host scaling. Similar as they may be, they're not the same.
  1. The OP for this ticket specifically stated that they opened #18521 simply because they couldn't change the affected version for #14366. That's why it was justifiably closed as a Duplicate; you don't create a new ticket for every VirtualBox version.
  1. It's usually better and faster, if issues get first addressed in the  VirtualBox forums, a lot more eyes there. More than 95% of the issues are resolved in the forums, which keeps the developers focusing on the bug fixes and enhancements.
  1. Could you try the latest Testbuilds? They contain several fixes regarding the mouse and the scaling. You might be pleasantly surprised... ;)

Changed 2 years ago by StS

comment:5 Changed 2 years ago by StS

In my opinion, Georg thought it would be a duplicate, but it isn't.

In V6.0.5 the problem still occurs. If host scaling and guest scaling is different, the mouse pointer seems to get scaled according to host scaling. This might be useful in some cases, in my it's not.

On the left side, mouse integration is enabled. On the right side, it's disabled. This seems to be a solution but with a Win10 guest, the mouse cursor disappears one the window is active. Additionally, you'll always have to host key to leave the guest session (the mouse pointer is trapped).

I already had a look at VirtualBox forums, but I can't find a solution except of going back to V5.x. Then I might have to do this...

comment:6 Changed 23 months ago by MClark

I'm experiencing this in version 6.0.6. Win7 host, Ubuntu guest.

The mouse pointer not only appears large in the guest, the guest does not register clicks.

This problem manifests when Windows text (on the host) is set to "Larger - 150%". The workaround is to either disable mouse integration, or to change text in Windows to "Medium - 125%" or "Smaller - 100%".

comment:7 Changed 23 months ago by michael

  • Status changed from reopened to closed
  • Resolution set to duplicate

It looks like the underlying issue is still the same. So still closing this as a duplicate.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use