VirtualBox

Ticket #1883 (closed defect: obsolete)

Opened 11 years ago

Last modified 4 years ago

BrazilFW: Kernel Panic, Guru meditation

Reported by: supaJ Owned by:
Component: VMM Version: VirtualBox 3.0.10
Keywords: BrazilFW, kernel panic Cc:
Guest type: Linux Host type: Linux

Description (last modified by frank) (diff)

I can't get the IDE installation of BrazilFW-2.31.10-Final to boot off the virtual IDE in VirtualBox 1.6.2. I get the following stop message whilst the kernel is loading:

"Kernel panic: VFS: Unable to mount root fs on 01:00"

BrazilFW iso:  http://ufpr.dl.sourceforge.net/sourceforge/brazilfw/brazilfw-2.30.1-cdrom.zip

  • Brazilfw is a mini-distribution designed for setting up network utility services such as Internet connection sharing, firewalling, or wireless access points.

Attachments

BrazilFW-2009-11-15-00-45-41.log Download (99.3 KB) - added by Technologov 10 years ago.
BrazilFW in Hardware Virtualization Mode (by Technologov)
BrazilFW_Softvirt-2009-11-15-00-46-51.log Download (29.8 KB) - added by Technologov 10 years ago.
BrazilFW in Software Virtualization Mode (by Technologov)

Change History

comment:1 Changed 11 years ago by Technologov

Bug verified by me.

Host: Windows XP SP2, VBox 1.3.8 and VBox 1.6.2 (to see that there is no regression). Intel Core 2 CPU. Guest OS: BrazilFW Linux (kernel 2.4)

Settings: Tried many of them: ACPI, PAE/non-PAE, VT-x=on/off, IO APIC=on/off. Doesn't help.

-Technologov

comment:2 follow-up: ↓ 3 Changed 11 years ago by erstazi

Since routers are not x86 arch based... and Brazil is based off of the Coyote Linux distro, I highly doubt you can boot this in virtualbox. Another key note is, Coyote gives

Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block(1,0)

comment:3 in reply to: ↑ 2 Changed 11 years ago by supaJ

BrazilFW is x86 based.

The CDROM version boots fine in VirtualBOX. It is the IDE installation which does not boot. Hence, I would assume it is a problem with virtualBOX's virtual IDE.

comment:4 Changed 10 years ago by Technologov

Host: Windows Vista, 32-bit, Core 2 P8600, VBox 3.0.10.

Re-tested this ISO with latest VBox 3.0.10, and the situation is bad.

Not only guest kernel still panics (same as before) in software virtualization mode, but running the ISO results in instant Guru Meditation when running in VT-x mode.

-Technologov

Changed 10 years ago by Technologov

BrazilFW in Hardware Virtualization Mode (by Technologov)

Changed 10 years ago by Technologov

BrazilFW in Software Virtualization Mode (by Technologov)

comment:5 Changed 10 years ago by frank

  • Version changed from VirtualBox 1.6.2 to VirtualBox 3.0.10
  • Component changed from virtual disk to VMM
  • Summary changed from BrazilFW - Virtual IDE - Kernel Panic to BrazilFW: Kernel Panic, Guru meditation

comment:6 Changed 4 years ago by frank

  • Status changed from new to closed
  • Resolution set to obsolete
  • Description modified (diff)
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use