VirtualBox

Ticket #1874 (closed defect: fixed)

Opened 6 years ago

Last modified 4 years ago

Clonevdi still results in crashing VirtualBox

Reported by: requestor12 Owned by:
Priority: major Component: other
Version: VirtualBox 2.0.4 Keywords:
Cc: Guest type: Windows
Host type: Windows

Description

Hi,

I make use of VirtualBox version 1.6.2 and when I clone a harddisk (vdi file) I use the following command: D:\Virtual PC (Sun)\VirtualBox\VDI>"c:\Program Files\sun\xVM VirtualBox\VBoxManage.exe" clonevdi "Harddisk VM Sun.vdi" "Harddisk VM Sun original.vdi"

VirtualBox crashes every time at the end of the copy process (though 100% is reached) and generates the message " Sun xVM VirtualBox Interface has encountered a problem and needs to close. We are sorry for the inconvenience. If you were in the middle of something, the information you were working on might be lost.

How can I fix this?

Change History

comment:1 Changed 6 years ago by requestor12

Btw: I also tried to copy a VDI file where the filenames do not contain <spaces>, and I did a reinstallation of both Windows and VirtualBox.

comment:2 Changed 6 years ago by sandervl73

We can't reproduce this here. Are you running out of disk space perhaps?

comment:3 Changed 6 years ago by requestor12

No absolutely not (> 20 GB disk space left where the VDI file is approximately 2 GB).

Are there maybe any prerequisites w.r.t. 3rd party software that needs to be installed in order for VirtualBox to run properly, such as the latest version of .NET, or the latest version of DirectX etc.

comment:4 Changed 6 years ago by sandervl73

None. Which windows version are you using?

comment:5 Changed 6 years ago by requestor12

XP with SP3. Patch level of Windows is up-to-date (so all patches after SP3 are also installed)

comment:6 Changed 6 years ago by requestor12

This weekend, I run some additional tests: I did a reinstallation of VirtualBox on a different partition and afterwards I did a reinstallation of Windows XP within the Virtual Machine. Unfortunately, I had the same error message as stated above.

Can it be that I have some kind of physical memory error, which results in e.g. a CRC checksum error which is not being correctly handled by VirtualBox?

Btw, VirtualBox is able to process the copied harddisk...

comment:7 Changed 6 years ago by mrewain

Hi,

I have exactly the same error.
VirtualBox 1.6.2
Host system: WindowsXP Pro SP1 (50GB free space for 1.3GB vdi file)
Guest System: WindowsXP Pro SP0
Error Signature:
AppName : vboxsvc.exe AppVer : 1.0.0.1 ModName: unknown ModVer : 0.0.0.0 Offset : 00001214


But my copied file crashes always, which is my main concern, because I just want to backup some configurations.

I did some CloneVDI several months ago with earlier VirtualBox version(s) without any problems.

comment:8 Changed 6 years ago by chdh

I have the same effect with VirtualBox 1.6.2 and 1.6.4 on WinXP SP2. It copies up to 100% and then crashes. Some months ago it worked.

The Windows event log contains the following error message: Faulting application vboxsvc.exe, version 1.0.0.1, faulting module unknown, version 0.0.0.0, fault address 0x000005b4.

The copied VDI file has the same size as the original file.

comment:9 Changed 6 years ago by frank

  • Version changed from VirtualBox 1.6.2 to VirtualBox 1.6.4

Can you provide a minidump? See  http://www.virtualbox.org/wiki/User_FAQ

comment:10 Changed 6 years ago by chdh

We have produced two different minidump files and stored them at:

 http://source-code.biz/temp/virtualbox

The error occurs in different variations. Sometimes it does not occur at all (on the same computer and with the same VDI file which is copied). Sometimes the DEP (data execution prevention) is triggered.

The stack trace for the first dump file is:

774ff2a6 ole32CoInitialize+0x9c 774fee98 ole32CoInitializeEx+0x32b 00436916 ole32CoUninitialize+0x52 004356ad VBoxManage+0x36916 7c816fd7 VBoxManage+0x356ad

The error occurred within CoUnitialize, which is called when VboxManage terminates. There is probably some memory corruption.

comment:11 Changed 6 years ago by chdh

This error still occurs with Virtualbox 2.0.0.

comment:12 Changed 5 years ago by BitBasher

I have this problem too with VBox 1.6.6. I can reproduce this bug 100% of the time on 3 different systems, all running WinXP Pro SP2. This bug happens for me when I run vboxmanage and either do a clonevdi or compact. In both cases, the process is completed ok and the VDI file is successfully cloned or compacted.

This problem seems to be an issue with VBoxManage/VBoxSVC closing down - something in the teardown process is bombing causing this exception.

I have placed my dump file here:  http://bitbasher.net/vbox/vboxdump.rar

That WinRAR archive file contains the .DMP file and the text file that are produced by WinXP's exception handling program. If a special DEBUG version of 1.6.6 could be made available, I could run that in the same failure mode, which may provide more information about the cause of the problem.

comment:13 Changed 5 years ago by sandervl73

Try again with 2.0.4.

comment:14 Changed 5 years ago by requestor12

Unfortunately, this error still occurs in version 2.0.4.

comment:15 Changed 5 years ago by requestor12

and btw, I tried all the previous versions as well, all gave the same error message.

comment:16 Changed 5 years ago by techno.scavenger

Got the same issue too using VirtualBox 2.0.4 on Windows Vista SP1 32 bit Business.

comment:17 Changed 5 years ago by frank

  • Version changed from VirtualBox 1.6.4 to VirtualBox 2.0.4

comment:18 Changed 5 years ago by frank

  • Summary changed from Clonevdi still results in crashing VirtualBox (version 1.6.2) to Clonevdi still results in crashing VirtualBox

comment:19 Changed 5 years ago by dmik

Does the problem still happen with VirtualBox 2.1.0? If yes, we'll provide a debug build for detailed testing.

comment:20 Changed 5 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

No complaints anymore so hopefully fixed.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use