VirtualBox

Ticket #1873 (closed defect: fixed)

Opened 6 years ago

Last modified 6 years ago

Disk access errors when using secondary SATA disk under Windows XP SP2.

Reported by: bifferos Owned by:
Priority: critical Component: virtual disk
Version: VirtualBox 1.6.2 Keywords:
Cc: Guest type: Windows
Host type: Linux

Description

Host is Slackware Linux 12.0, running kernel 2.6.21.5 SMP.

Guest is Windows XP SP2. Primary (OS) disk is IDE, Second disk is SATA formatted NTFS with default options. Both disks are configured as expanding.

I have installed SATA drivers from Intel, as specified in this thread.  http://forums.virtualbox.org/viewtopic.php?t=7177

I found several "Delayed write failed" messages, so I switched off the delayed write feature of the SATA driver in XP. This improved things, but still I got disk errors which resulted in the second drive (Drive D:) disappearing.

I have plenty of space available on the host drive (>70GB), and the system has been working flawlessly otherwise. Second disk is 5.7GB in size (on the disk) and maximum size has been set to 11GB.

Please note that you really have to hammer the system to reproduce this. I set going a 3-hour compilation, and it failed after approximately two hours, so this might be an obscure one to track down, but it's definitely there, and for a production environment it's a show-stopper. The IDE controller doesn't seem to suffer the same problems, and I've been using that for similar builds for months now.

If the intel SATA drivers are the wrong ones to be using, then it would be very good if this could be made clear, perhaps with the docs suggesting an alternative?

Change History

comment:1 Changed 6 years ago by aeichner

Thanks for your report. Unfortunately I'm currently not able to reproduce this issue. Can you please provide more info about your hardware, in specific about your CPU and RAM. And what do you mean with "hammer"? Only in terms of CPU usage or only high I/O traffic or both?

comment:2 Changed 6 years ago by bifferos

The host machine is a Dell Optiplex GX260 - a P4 1.8GHz, 1GB RAM, the first hard disk is an IDE 80GB, second is an IDE 250GB (on the second controller).

The virtual (guest) machine consists of two virtual hard disks, both of which reside on the 250GB, (secondary) host hard disk, not sure if that was clear above.

As for the guest, my build consists of compiling many (hundreds of) Visual Studio 2005 projects, which will result in a lot of CPU and disk activity. I'm using Visual Studio service pack 1, to be precise.

If you have tested this configuration and not found any problems, it's probably best if I now attempt to reproduce the problem on a second host machine before you spend any more time on this.

comment:3 Changed 6 years ago by aeichner

So your machine has only one single core CPU. This information helps a lot. I tested it with a dual core where the second core is used when the first one is at 100%. In your case the I/O thread has no chance to run concurrently and may pause for a long time which makes the driver in the guest times out before the command finishes. Thanks.

comment:4 Changed 6 years ago by aeichner

This issue should be fixed in 1.6.4 which will be released soon. Thanks for your report.

comment:5 Changed 6 years ago by klaus

  • Status changed from new to closed
  • Resolution set to fixed

This issue is fixed in 1.6.4, despite the defect number isn't explicitly listed.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use