Opened 5 years ago

Last modified 5 years ago

#18616 new defect

Shared Folder error when using reposync

Reported by: jim.rather Owned by:
Component: shared folders Version: VirtualBox 6.0.6
Keywords: Cc:
Guest type: Linux Host type: Linux


I have a couple of VMs (specifically CentOS6 and CentOS7) that I use to sync repositories for a disconnected network. EPEL, Cloudera, MySQL, etc. I keep these VMs pretty lean and but mount Shared Folders to a USB so that I can transfer the files. I download the files in the repos directly to the Shared Folder. For example to update the EPEL6 repository. I cd into a directory on the Shared Folder and use the command, reposync -n -d -r epel6. Since 6.0.6 this causes errors. To test it I tried a created a new directory and here is a sample output from one of the first attempted download:

[jrather@localhost sat]$ reposync -n -d -r epel6 [epel6: 1 of 12532 ] Downloading Packages/2/2048-cli-0.9.1-1.el6.x86_64.rpm Could not retrieve package 2048-cli-0.9.1-1.el6.x86_64. Error was failure: Packages/2/2048-cli-0.9.1-1.el6.x86_64.rpm from epel6: [Errno 256] No more mirrors to try.

I get errors on every file. If I try the command within a directory on the VM (for example, /tmp or my user's home directory) everything is fine. It is only with the Shared Folder or trying to write to it. This error occurs with the CentOS7 guest too. I have tried it from both CentOS7 host and Ubuntu 18.04 host both with Guest Additions installed. I have also tried using a physical disk for the Shared Folder instead of USB drive with the same results. This used to work fine with 6.0.4 and previous versions.

I am not sure what else to submit but would be more than happy to if instructed.

Change History (2)

comment:1 by jim.rather, 5 years ago

I downgraded to 6.0.4 and my issue is no longer present. I hope that whatever changed between 6.0.4 and 6.0.6 is re-evaluated.

comment:2 by boxer01, 5 years ago

Sounds like my ticket #18566.

Note: See TracTickets for help on using tickets.

© 2023 Oracle
ContactPrivacy policyTerms of Use