VirtualBox

Ticket #18566 (closed defect: fixed)

Opened 23 months ago

Last modified 15 months ago

No sub-folder copy operation possible from and to the shared folders since the latest Windows 10 1809 updates.

Reported by: boxer01 Owned by:
Component: shared folders Version: VirtualBox 6.0.6
Keywords: Cc:
Guest type: Windows Host type: Windows

Description

I try to copy some folders with some sub-folders from my Windows 10 1809 (with the latest updates) guest to the host with the same OS. But instead of coping them operation simply quickly fast-forward to the 100% without copying, just created the folder itself or the first sub-folder in it. The same operation in the other direction also fails. I can easily copy some files, but not the recursive structure. Some folders with only few files can also be copied without any issues, but as soon as some sub-folders are in the filed, one see this issue.

Only Windows 10 systems (now 1809 and 1803) has this issue. I tested this on my Windows 8.1 host and Windows 7 guest combination, and it does what I needed. Another important note: the Windows 10 systems use Virtual Box 5.2.22 as a stable version (because of some troubles in the sound and shared folders subsystems in the recent versions), but even there I see this now. Also, I tested with newly released versions (5.2.28 and 6.0.6) and also can reproduce it. So this would probably be some changes from MS and not in the Box itself. The regression windows is probably from December 2018, because I think I copied a lot just after the initial release of the 6.0 then. Definitely this worked back in November 2018 (5.2.22 release) and for sure back in August 2018.

I put some logs here even if I can’t see anything related to the issue here. And I link to the other two tickets with shared folder problems, which probably depends on this one: #17626 (this one also has some equal description of this issue in the end) and #18151

Attachments

VBox_Win10_No_Copy.7z Download (73.3 KB) - added by boxer01 23 months ago.
Logs from the Windows 10 1809 system

Change History

Changed 23 months ago by boxer01

Logs from the Windows 10 1809 system

comment:1 follow-up: ↓ 3 Changed 21 months ago by bird

It's possible that this is the same issue as #17626 after all, though I'm having a hard time reproducing it here with 6.0.8 GAs and trunk host. Generally, I can do it once and then no more. Seems like an explorer bug, but could also be some weirdness in our shared folder driver for what I know. Any chance you could reproduce with 6.0.8 additions and vbox host?

comment:2 Changed 21 months ago by boxer01

I’ve tested with current versions of Virtual Box, such as 6.0.8 / 6.0.9 (130520, 130868, 130970) and 5.2.30 / 5.2.31 (130521, 130748, 130893). This issue is gone, at least on my Windows 10 1809 guest and host combination. Now I couldn’t reproduce it. And because of probably the same changes or the same issue source my other ticket #17626 about “hidden” files with dot is also solved, at least for me. It would be nice to have some responses from some other people.

comment:3 in reply to: ↑ 1 Changed 21 months ago by boxer01

Replying to bird:

As I wrote in the other ticket, this looks like to be corrected in 6.0.8 and 5.2.30. Previously it was 100 % reproducible. One just needed to copy some folders structure, not just simple files, in some direction. With two or three sub-folders the issue was clearly to see. I have had to use 7-zip archives to move folders between host and guest.

comment:4 Changed 15 months ago by bird

  • Status changed from new to closed
  • Resolution set to fixed
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use