VirtualBox

Ticket #18151 (closed defect: fixed)

Opened 5 months ago

Last modified 6 days ago

Shared Folders hangs after while -> fixed in 6.0.6

Reported by: boxer01 Owned by:
Component: shared folders Version: VirtualBox 5.2.22
Keywords: Cc:
Guest type: Windows Host type: Windows

Description

I have Windows 8 x64 host with Windows 7 x86 guest. Since 5.2.23 126798 and 6.0.0_BETA2 (original 126642 and 126867) I have a problem after some time. I use the MP3 converter from the guest and after some time (nearly 20 minutes) or maybe some files (30 or 40) this program can’t read or write to the shared folders. After this I also can’t open them in the windows explorer and I can’t close the program, not even in the task manager. Trying to restart or to shut down the guest OS rarely succeed, but often I have to reset the guest. Going back to the 5.2.23 126581 solve this.

I found some tickets with kind of same problem description (#15662, #16949, #17716). Some of them closed after corrections in the guest additions. My both operation systems are up to date, I use the latest 6.0.0_BETA2 additions, but this shouldn’t be a culprit because with the version 5.2.23 126581 and the same guest additions it works.

Attachments

VBox_6b2.7z Download (181.3 KB) - added by boxer01 5 months ago.
Logs from the 5.2.23 and 6 beta 2
VBox_log_5.2.24 r128163_Win78.7z Download (21.3 KB) - added by boxer01 3 months ago.
5.2.24 logs
VBox_log_5.2.25 r128223_Win78.7z Download (21.9 KB) - added by boxer01 3 months ago.
5.2.25 r128223 logs
VBox_log_6.0.3 r128259_Win78_1.7z Download (27.4 KB) - added by boxer01 3 months ago.
6.0.3 r128259 logs
VBox_log_6.0.3 r128259_Win78_2.7z Download (48.9 KB) - added by boxer01 3 months ago.
6.0.3 r128259 logs part 2
VBox_log_5.2.25-128361_win78.7z Download (39.0 KB) - added by boxer01 3 months ago.
5.2.25-128361 logs
VBox_20190311_errorA.log Download (141.2 KB) - added by neumannd 6 weeks ago.
log related to error description A in comment of user neumannd
VBox_20190311_errorB.log Download (140.0 KB) - added by neumannd 6 weeks ago.
log related to error description B in comment of user neumannd
VBox_20190311_errorC.log Download (140.2 KB) - added by neumannd 6 weeks ago.
log related to error description C in comment of user neumannd
VBox_20190311_errorD.log Download (140.6 KB) - added by neumannd 6 weeks ago.
log related to error description D in comment of user neumannd
VBox_errorE.log Download (140.4 KB) - added by neumannd 6 weeks ago.
log related to error description E in comment of user neumannd
VBox_errorF.log Download (140.4 KB) - added by neumannd 6 weeks ago.
log related to error description F in comment of user neumannd

Change History

Changed 5 months ago by boxer01

Logs from the 5.2.23 and 6 beta 2

comment:1 Changed 5 months ago by socratis

You already did some research and found #15662, #16949, #16762, #17067, #17716. The last three of them are still open. Can I ask why are you opening a new one? It usually doesn't go "the more the merrier" for bug reporting. It creates even more confusion.

comment:2 Changed 5 months ago by boxer01

They are is some misunderstandings from you here, so I have to make some points clear. First of all, for me it’s a new issue. I use this product over 9 years and never had a problem like this. The shared folders feature was sometimes slow or got other kind of troubles. But never it got simply stuck and made a normal reboot of the guest OS impossible.

Before filing the new ticket I made a small research to avoid filing a ticket for already existing problem. As anybody can see in description, I found some of them. Two of them are old and closed after fix, the last one is from this year and looks really similar to my issue, but not exact the same. I just thought that doing some rehearsals would help the developers and save some of their precious time. And I also posted the exact time and version frame, when this problem started. So this issue is new for me and not currently reported as an active bug. Right now I’m back to the current stable version, where the exact the same VM has no such problem. The other workaround is to copy files into the VM and convert them locally. But it would simply unnecessary enlarge the snapshot file; I also have a bad feeling that this would also lead to hang of the shared folders feature because it would trigger the same situation by the same amount of data or time for this operation.

The other two tickets you posted here is from my other ticket, that describes another issue with the shared folders (files and folders with period as a first symbol in the name breaks the IO operations and leads to the stop of all shared folder operations till the next guest restart, which could be done without any problems). I don’t know why you put it here. This is totally different issue in the same area. It also clearly described many times, but not looking really important for the project management so it still not fixed. But once again, that ticket has nothing to do with this one.

I hope now is everything clear about this issue and another one. If somebody has some questions about this issue itself, I would be glad to answer them.

BTW, just tested the new beta 3 (127054) and stuck in this after 3 minutes and 5 converted files.

comment:3 follow-up: ↓ 4 Changed 5 months ago by socratis

boxer01, you don't even give the exact steps to reproduce the problem. You talk about "MP3 converting" and "it gets stuck". If you want this addressed, you should be doing something like:

  1. step1
  2. do this
  3. follow that
  4. download this test
  5. do this
  6. FAIL

so that the developers have a decent chance of reproducing the problem.

comment:4 in reply to: ↑ 3 Changed 5 months ago by boxer01

Replying to socratis:

Clearly you have a point here. So here is a complete step by step description. I have Windows 7 x86 guest under Windows 8 x64 host here, both with all current updates. In the guest I have a Poikosoft’s EZ CD Audio Converter installed. The audio files (MP3) is on the host and I can access them through the shared folder, those folders are some of sub-folders in the shared folder. Of course, I have a full access, read and write, to those folders. My shared folder is a temporary one, if this is important.

So I drag and drop the files or folders into the converter’s window and after that I start the converting process. I don’t think that MP3 setting are important here. On thing: to create a better CPU load I set the amount of parallel converted files to three. Converter creates a new file and erase the original at the end of the process, effectually replacing it. After a while the converting process get stuck, the percentage of each currently converted file and whole process itself just stop to rise. After that you can stop the batch, but the currently converted files will be in stuck state forever. Therefore, you can’t close the program, even with task manager.

If one tries to open the shared folders with some file manager like Windows explorer, this also will take forever to no avail. So from some point the shared folders are simply absent. And from this moment you can’t even restart the guest OS, I managed this only once, the other times I have to reset the guest. I put the logs here, but I can’t see anything strange there.

I hope this is now a really detailed description. If there are any further questions, I would like to answer them. I don’t really think that MP3 converting is making something special here, one would probably have just the same problems with simple heavy file copy.

About the other ticket, with period in the file or folder name, I think that the description there is already detailed enough. If not, let me know and I’ll put even more details about that simple situation.

comment:5 Changed 5 months ago by boxer01

Just a little update: I thought that this could be probably related to this issue, but the changes in the current version (6.0.0_BETA3-127164) didn‘t help here. Currently I got the described situation in the first three converted files in the second minute. So the issue is still here and I‘ back to the latest working version again.

comment:6 Changed 3 months ago by boxer01

Some news about this issue: I’ve tested some versions and in the current 5.2.25-128361 and 6.0.3-128367 it’s still here, after couple of minutes and files the whole situation repeats. I put my logs here, probably somebody would find it helpful if this issue would be fixed. The other versions I tested in the last weeks are: 5.2.23-127298, 5.2.23-127309, 6.0.0_BETA3-127339, 6.0.0_RC1-127378, 6.0.0_RC1-127414, 6.0.1-128017, 6.0.1-128072, 6.0.1-127640, 5.2.23-127445, 5.2.25-128227, 5.2.25-128236, 6.0.3-128235, 6.0.3-128237.

Here I found some other tickets and forum topics about this issue. Those people are on different systems and versions. And they even do nothing more than copy or move some files over the Windows explorer. But after some time the VBOXSVR became irresponsible and no further file operations are possible after that.

 Linux  Linux  Win  Win #18322 #18228

Last edited 3 months ago by boxer01 (previous) (diff)

Changed 3 months ago by boxer01

5.2.24 logs

Changed 3 months ago by boxer01

5.2.25 r128223 logs

Changed 3 months ago by boxer01

6.0.3 r128259 logs

Changed 3 months ago by boxer01

6.0.3 r128259 logs part 2

Changed 3 months ago by boxer01

5.2.25-128361 logs

comment:7 Changed 6 weeks ago by neumannd

I can confirm the issue (xUbuntu 16.04 and xUbuntu 18.04 hosts (each x64); Windows 7 x86 guest). The attached logs are from the xUbuntu 18.04 hosts. The VirtualBox version is 6.0.4. The issue did not occur in version 5.x.x of VirtualBox (not sure, which I had before).

What I did to reproduce the error documented by the logfile ending with errorA

  • copy and rename a file on a shared folder
  • open the file in MS Powerpoint
  • Powerpoint hangs during its starting phase (close to time stamp 00:02:10.582578)
  • open a new file browser, try to access another folder (works) and try to access the shared folder (windows hangs) (close to time stamp 00:03:34.996016)
  • open a new file browser and try to access the shared folder (windows hangs) (close to time stamp 00:04:31.074309)
  • windows explorer breaks
  • shut down windows (around 00:05:00) no reaction
  • (force the VM to shut down (after 00:05:53))

What I did to reproduce the error documented by the logfile ending with errorB

  • copy and rename a file on a shared folder
  • file browser window hangs
  • (force the VM to shut down)

What I did to reproduce the error documented by the logfile ending with errorC

  • copy and rename a file on a shared folder
  • open the file in MS Powerpoint
  • Powerpoint hangs during its starting phase
  • file browser window hangs
  • (force the VM to shut down)

As the three itemizations show: the error does not always occur at the same time.

Information on the shared folder:

  • permanent shared folder ("machine folder")
  • read-only: no
  • auto-mount: yes
  • mount point: empty
  • make permanent: yes

The configuration of the virtual machine exists since version 5 of VirtualBox. Thus, I did not set it newly up in VirtualBox 6 (just is case it is some issue related to a configuration file).

Last edited 5 weeks ago by neumannd (previous) (diff)

Changed 6 weeks ago by neumannd

log related to error description A in comment of user neumannd

Changed 6 weeks ago by neumannd

log related to error description B in comment of user neumannd

Changed 6 weeks ago by neumannd

log related to error description C in comment of user neumannd

comment:8 Changed 6 weeks ago by neumannd

One addition to my comment above. If a file was involved into the generation of the issue it seems to be burned. But maybe it is just a coincidence.

What I mean: To generate error log B, I copied the same file as I copied for error log A. In case B the issue occurred on step earlier compared to case A. To generate error log C, I copied a new file, which had not been touched before. Now, I have a case D (attached below) in which I wanted to copy the file, which was touched in case A and B), from the shared folder to default folder in the VM (C:\users\...\Downloads). The same as in case B happened. Log is attached.

Changed 6 weeks ago by neumannd

log related to error description D in comment of user neumannd

comment:9 Changed 6 weeks ago by neumannd

I can confirm the error with Windows 10 (x64) as Host and Windows 7 (x86) as Guest. Same VM as for my Linux examples above (but different host). I reproduced the error twice (E and F). It seems to be related to copy and paste a file (old file or large file) in one and the same folder.

The error logs are attached. The production of the error is described below. On request I could possibly provide the Virtual Machine.

Error E:

  • Started VM
  • entered shared folder
  • copy&paste one file in same folder => hanging

Error F:

  • Started VM
  • entered shared folder
  • created a new folder
  • created a new text file within the new folder
  • edited the text file
  • copy&paste the text file (no issue)
  • copied two larger files from another location into the new folder (no issue)
  • copy&paste of one of the new larger files into the new folder (CTRL+C on the file and directly CTRL+V) => hanging
Last edited 5 weeks ago by neumannd (previous) (diff)

Changed 6 weeks ago by neumannd

log related to error description E in comment of user neumannd

Changed 6 weeks ago by neumannd

log related to error description F in comment of user neumannd

comment:10 Changed 2 weeks ago by animeshsaxena

Are you still facing the issue?

comment:11 follow-up: ↓ 12 Changed 2 weeks ago by socratis

I decided to test this after the comment from "animeshsaxena". I used to have a hanging Win Explorer in previous versions, when trying to copy several files from "\\VBoxSvr\Share".

I just tested version 6.0.97 r129919 on OSX 10.11.6 and it works great so far. I'll test the latest 6.0.5 and report back...

UPDATE: It works fine with 6.0.5 r129921 on OSX 10.11.6 as well...

Last edited 2 weeks ago by socratis (previous) (diff)

comment:12 in reply to: ↑ 11 ; follow-up: ↓ 13 Changed 7 days ago by boxer01

Replying to socratis:

I also tested heavily on my Windows 10 (1809 and 1803) guests and most important Windows 7 x86 guest by converting between 50 and 70 files in a batch. Usually this would cause this behavior, but everything worked fine. So I would tell that there is no hanging in the shared folders now after a while. Because I have another issue with them, now on my Windows 10 guests, I opened another ticket: #18566. This one could be closed. If the issue reappeared we could re-open this ticket, right?

comment:13 in reply to: ↑ 12 Changed 7 days ago by socratis

Replying to boxer01:

This one could be closed. If the issue reappeared we could re-open this ticket, right?

Absolutely, but for the moment I think we can safely say:

This issue can be closed as [Fixed] with VirtualBox 6.0.6.

I'll mark it as such in the "Known Issues" section...

comment:14 Changed 6 days ago by michael

  • Status changed from new to closed
  • Resolution set to fixed
  • Summary changed from Shared Folders hangs after while. to Shared Folders hangs after while -> fixed in 6.0.6
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use