VirtualBox

Ticket #1861 (closed defect: invalid)

Opened 6 years ago

Last modified 6 years ago

Swiss German Keyboard input with Windows XP Guest is totally messed up

Reported by: fish-guts Owned by:
Priority: major Component: GUI
Version: VirtualBox 1.6.2 Keywords:
Cc: Guest type: Windows
Host type: Linux

Description

Hello

I have installed Virtualbox 1.6.2 an a Ubuntu Hardy (8.04) host, with a Windows XP Guest.

I installed the GuestAdditions and i'm running the machine with rdesktop, because my SDL drivers are messed up and i cannot repair them.

Everything is working properly except the keyboard.

I use a Swiss German Keyboard, 105 Key Layout.

On the guest, the letters work fine, except it's qwerty format, and it should be qwertz.

Then, i cannot use the numpad, i cannot use special character like é ö à à, etc.

I cannot use the @ sign, i cannot use brackets, almost anything exept the letters is messed up.

I'd really appreciate any help here. Remember, i cannot use the SDL front end, because i can't fix and after 20 hours of troubleshooting nobody could help me.

Change History

comment:1 Changed 6 years ago by michael

  • Priority changed from critical to major

Please make sure first of all that you have set up the guest to use the Swiss German layout, as the guest does not know anything about the host layout. Then check to see what is working and what is not. Note that there are several keyboard issues, particularly relating to accent keys, which are fixed for the next version of VirtualBox.

comment:2 Changed 6 years ago by fish-guts

Well

I don't mind about the accent keys, since if i really need them, i can use an ALT combination. But it's a little annoying that i can't even get an '@' working, and since i'm running outlook on my windows guest, you can imagine what this means =)

My Guest is all set up for Swiss German layout.

comment:3 Changed 6 years ago by michael

Can you take a look in the release log ("~/.VirtualBox/Machines/<Guest Name>/Logs/VBox.log") and see if there is anything keyboard-related at the top of it? If so, post it here.

comment:4 Changed 6 years ago by fish-guts

There's nothing in the logs about keyboard. at least not in the first 20 lines.

comment:5 Changed 6 years ago by michael

Does switching your host layout to qwerty before starting up your guest make a difference? You can switch back after starting it up.

comment:6 Changed 6 years ago by fish-guts

No it does not.

I now changed it to US layout on the guest, so at least i can use ALT combinations. But in swiss german its still messed up.

comment:7 Changed 6 years ago by michael

If everything works when you change the guest to US layout then the problem is with your guest, not with VirtualBox. Does everything work in this case?

comment:8 Changed 6 years ago by fish-guts

No it doesn't. I just have some more keys that aren't messed up.

comment:9 Changed 6 years ago by michael

Could you try starting your virtual machine from the console, with the command

$ LOG_KB_SECONDARY=1 VirtualBox -startvm <your VM name>

and copy the console output into a file and attach it to this ticket? The output should look something like

Attempting to match against "U.S. English"
Mismatch for keycode ...
...

comment:10 Changed 6 years ago by michael

  • Status changed from new to closed
  • Resolution set to invalid

OK, forget that last bit. I missed the bit in the original description that you are running over RDP (I noticed in the last ticket you submitted), so that is a completely different affair. I'm afraid that keyboard issues in rdesktop are bugs of that programme, not of VirtualBox, so there is nothing we can do to help you without fixing their issues.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use