VirtualBox

Ticket #18515 (closed defect: fixed)

Opened 8 months ago

Last modified 7 months ago

vboxsf-6.0.4 not compiling on kernel-5.0.3 -> fixed after (not in) 6.0.4/5.2.26 and test builds

Reported by: zd59 Owned by:
Component: installer Version: VirtualBox 6.0.4
Keywords: vboxsf module compile error Cc:
Guest type: Linux Host type: Windows

Description

My configuration:
Slackware64-current updated 20.3.2019
Kernel-5.0.3
Vbox-6.0.4

After compile/install a new kernel-5.0.3 and reboot, the boot process complains at the end that vboxsf module can not run.
A vboxadd-setup.log file show:

/tmp/vbox.0/vfsmod.c:235:14: error: 'MS_REMOUNT' undeclared (first use in this function); did you mean 'DT_RELCOUNT'?

I found the solution for that - source patch:

--- /opt/VBoxGuestAdditions-6.0.4/src/vboxguest-6.0.4/vboxsf/vfsmod.c	2019-03-19 16:24:00.759229219 +0100
+++ /opt/VBoxGuestAdditions-6.0.4/src/vboxguest-6.0.4/vboxsf/vfsmod.c	2019-03-19 16:27:29.967294113 +0100
@@ -40,9 +40,13 @@
 #include "revision-generated.h"
 #include "product-generated.h"
 #include "VBoxGuestR0LibInternal.h"
-#if LINUX_VERSION_CODE < KERNEL_VERSION(3, 3, 0)
+
+#if LINUX_VERSION_CODE >= KERNEL_VERSION(5, 0, 0)
+# include <uapi/linux/mount.h> /* for MS_REMOUNT */
+#elif LINUX_VERSION_CODE < KERNEL_VERSION(3, 3, 0)
 # include <linux/mount.h>
 #endif
+
 #include <linux/seq_file.h>
 
 MODULE_DESCRIPTION(VBOX_PRODUCT " VFS Module for Host File System Access");

But after extracting the vbox additions package and patching, there is no .configure file to run as described in a solution, just run make all do not work.

Any exact compile procedure to solve this?
Expecting this will be included in a next vbox release (6.0.6).

Change History

comment:1 follow-up: ↓ 2 Changed 8 months ago by socratis

Did you try the latest Testbuilds? You should. If you want to use the latest version for your host/guests, you should also consider doing the same for VirtualBox.

comment:2 in reply to: ↑ 1 Changed 8 months ago by zd59

Replying to socratis:

Did you try the latest Testbuilds? You should. If you want to use the latest version for your host/guests, you should also consider doing the same for VirtualBox.

Would not complain, as I know about new kernels Vbox compilation, but take look about 6.0.4 Change logs last line (kernel =>5.0. modules failed to compile, last line not valid):

VirtualBox 6.0.4 (released January 28 2019)

This is a maintenance release. The following items were fixed and/or added:

Virtualization core: support Shanghai/Zhaoxin CPUs.
User interface: handle command line arguments to VirtualBox correctly (bugs #18206 and #18197)
User interface: improvements to machine manager window, virtual optical disk creator, storage selector window and log viewer window
User interface: various small fixes and improvements
Audio: implemented time scheduling for the AC'97 device emulation to keep audio and video in sync
Graphics: basic support for VMSVGA graphics device in virtual machines using EFI
Network: fix occasional NATNet crashes (bug #13899)
Network: worked around problems in certain PCnet drivers on old operating systems
Serial: fixed connecting to pseudo terminals on POSIX hosts (6.0.0 regression; bug #18319)
Linux hosts and guests: fix for building kernel modules against Linux 5.0. Thank you Kyle Laker

That last line simply is not truth.
Google will show you (people asking about a solution)

comment:3 follow-up: ↓ 4 Changed 8 months ago by socratis

That last line simply is not truth.

I beg to differ. It was definitely true at the time of the release. I know about the changelog as well as the changeset that was contributed to the mailing list by Kyle Laker on 2019-01-26 (I'm on the recipient list), that led to that last line in the changes in VirtualBox and the entry in the changelog 2 days later, when 6.0.4 was released on 2019-01-28.

5.0.0 != 5.0.3

Things change, things evolve constantly. As I said, try the Testbuilds, if I'm not mistaken the fix is already in...

comment:4 in reply to: ↑ 3 Changed 8 months ago by wawastein

Replying to socratis:

That last line simply is not truth.

I beg to differ. It was definitely true at the time of the release. I know about the changelog as well as the changeset that was contributed to the mailing list by Kyle Laker on 2019-01-26 (I'm on the recipient list), that led to that last line in the changes in VirtualBox and the entry in the changelog 2 days later, when 6.0.4 was released on 2019-01-28.

5.0.0 != 5.0.3

Things change, things evolve constantly. As I said, try the Testbuilds, if I'm not mistaken the fix is already in...

6.0.x revision 129569 found on testbuilds page still has the issue.

comment:5 Changed 8 months ago by socratis

Can you please try with the latest development ones? As of now we're talking about "VBoxGuestAdditions_6.0.97-129566.iso" or anything greater than that. Can't give you the direct link because it's going to be invalid really soon... ;)

comment:6 follow-up: ↓ 7 Changed 8 months ago by michael

  • Summary changed from vboxsf-6.0.4 not compiling on kernel-5.0.3 to vboxsf-6.0.4 not compiling on kernel-5.0.3 -> fixed after (not in) 6.0.4/5.2.26 and test builds

It should be fixed now in 6.0 and 5.2 Guest Additions test builds.

comment:7 in reply to: ↑ 6 Changed 8 months ago by zd59

Replying to michael:

It should be fixed now in 6.0 and 5.2 Guest Additions test builds.

Today, 27.3.2019 available on: https://www.virtualbox.org/wiki/Testbuilds

The new pair:
VirtualBox-6.0.5-129575-Win
Oracle_VM_VirtualBox_Extension_Pack-6.0.5-129569

Compilation of extensions:

/tmp/vbox.0/vfsmod.c:235:14: error: ‘MS_REMOUNT’ undeclared (first use in this function); did you mean ‘DT_RELCOUNT’?

So this error is still not solved (since 28.1.- tomorrow will be two months).

comment:8 Changed 8 months ago by michael

You are right, the Additions build was not updated enough (the change is r129577). Should be fixed now.

comment:9 Changed 8 months ago by socratis

michael: It should be fixed now in 6.0 and 5.2 Guest Additions test builds.

zd59: VirtualBox-6.0.5-129575-Win

Sometimes the complete builds do not contain the latest Guest Additions (GAs). Can you try the stand-alone GAs ISO that michael was pointing to?

EDIT: michael posted just as I was hitting the "Preview" button... :)

Last edited 8 months ago by socratis (previous) (diff)

comment:10 Changed 8 months ago by vboxsf

Same failure under Version 6.0.5 r129579 (Qt5.6.2), standalone GAs at https://www.virtualbox.org/download/testcase/VBoxGuestAdditions_6.0.5-129616.iso.

comment:11 follow-up: ↓ 13 Changed 8 months ago by socratis

@vboxsf
What's your host/guest/VirtualBox? Distro/version/revision/build, the whole thing if you don't mind.

BTW, you said 129579, but you linked to the 129616 one... ;)

PS. You couldn't have picked a more... common nickname. Searching for your nickname returns a bunch of "vboxsf" results, as in VBox Shared Folders... :D

comment:13 in reply to: ↑ 11 Changed 8 months ago by zd59

Replying to socratis:

@vboxsf
PS. You couldn't have picked a more... common nickname. Searching for your nickname returns a bunch of "vboxsf" results, as in VBox Shared Folders... :D

Agree 1000% - s....d nick, sorry but that's trough. Where you got that idea?

And finally YES to 129580 GA. Compilation & execution works. Shared folder from windows rw accessible. Compiled on Slackware64-current with fresh 5.0.5 kernel (compiled by me) Thanks a lot to the developer.

comment:14 Changed 8 months ago by michael

What is the error with revision 129616 of the 6.0.5 Guest Additions?

comment:15 Changed 8 months ago by michael

Never mind. Try Guest Additions 6.0.5 revision 129665 when it appears in an hour or so.

comment:16 Changed 7 months ago by michael

  • Status changed from new to closed
  • Resolution set to fixed
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use