VirtualBox

Ticket #18312 (closed defect: fixed)

Opened 10 months ago

Last modified 7 months ago

Unable to build Virtualbox 6.0 on Fedora 29 -> fixed after (not in) 6.0.4 and 5.2.26 and in test builds

Reported by: pueffl Owned by:
Component: installer Version: VirtualBox 6.0.0
Keywords: Cc:
Guest type: other Host type: Linux

Description

After installing VirtualBox 6.0 on Fedora 29 and creating a rudimentary VM, I get the following message:

The VirtualBox Linux kernel driver (vboxdrv) is either not loaded or there is a permission problem with /dev/vboxdrv. Please reinstall the kernel module by executing

'/sbin/vboxconfig'

as root.

where: suplibOsInit what: 3 VERR_VM_DRIVER_NOT_INSTALLED (-1908) - The support driver is not installed. On linux, open returned ENOENT.

sudo /sbin/vboxconfig vboxdrv.sh: Stopping VirtualBox services. vboxdrv.sh: Starting VirtualBox services. vboxdrv.sh: Building VirtualBox kernel modules. vboxdrv.sh: failed: modprobe vboxdrv failed. Please use 'dmesg' to find out why.

There were problems setting up VirtualBox. To re-start the set-up process, run

/sbin/vboxconfig

as root.

dmesg has ABSOLUTELY NO messages about this.

Kernel Version: 4.19.13-300.fc29.x86_64

Change History

comment:1 Changed 10 months ago by socratis

It's usually better and faster, if issues get first addressed in the  VirtualBox forums, a lot more eyes there. More than 95% of the issues are resolved over there, which keeps the developers focusing on the bug fixes and enhancements, and there is no need for another ticket to keep track of. For example, yours is most probably not a bug and someone from the developers has to deal with it and close it as "Invalid".

It looks like either you didn't download the appropriate package, or you downloaded the fork from the Fedora repository, or you're missing some building tools from your installation.

So, if you can, please open a new thread in the  VirtualBox on Linux Hosts section of the forums. Please be sure to mention that you came from the bug tracker and include the ticket number.

comment:2 follow-up: ↓ 3 Changed 10 months ago by pueffl

You are generally right and after some investigations I found out that the problem was secure boot. But the message you display is not really helpful. So isn't it possible to give at least a hint that secure boot could be the problem?

comment:3 in reply to: ↑ 2 Changed 10 months ago by socratis

Replying to pueffl:

So isn't it possible to give at least a hint that secure boot could be the problem?

That's not a bad idea actually, not bad at all!

I'm not personally very familiar with Linux and its intricacies, could you see if it's easy to detect Secure Boot, and potentially apply a fix/patch to the installation script so that it gives better feedback to the user?

comment:4 Changed 10 months ago by michael

It is actually not quite trivial to detect when module signing is needed, not least because different distributions have done slightly different things. I am thinking of extending the message with something like: "If your system has EFI Secure Boot enabled you may also need to sign the kernel modules (vboxdrv, vboxnetflt, vboxnetadp, vboxpci) before you can load them. Please see your Linux system's documentation for more information." Does that sound reasonable?

comment:5 Changed 9 months ago by michael

  • Summary changed from Unable to build Virtualbox 6.0 on Fedora 29 to Unable to build Virtualbox 6.0 on Fedora 29 -> fixed after (not in) 6.0.4 and 5.2.26 and in test builds

Since you did not answer I did what I suggested (r77196). The change will be in the test builds in about an hour, though I doubt anyone will install one just to try this.

comment:6 Changed 7 months ago by michael

  • Status changed from new to closed
  • Resolution set to fixed

Closing this, though it is possible that we will be working on it further in future. Ubuntu has its own solution for signing kernel modules which we might make use of. Debian looks like it will adopt it too. If other distributions also provide solutions we will certainly look at them. I am not aware of Fedora doing anything though at the moment.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use