VirtualBox

Ticket #18286 (closed defect: fixed)

Opened 4 months ago

Last modified 6 days ago

DOS-class VMs don't recognize PCnet-FAST III (6.0.0 regression) => fixed in svn

Reported by: socratis Owned by:
Component: network Version: VirtualBox 6.0.0
Keywords: PCnet-FAST III, DOS guests Cc:
Guest type: other Host type: all

Description

Based on a discussion in the forums ( Possible bug: unrecognized PCnet-FAST III network card (in a guest DOS) with VirtualBox 6.0), it seems that there's an issue with the emulation of the above mentioned card.

It has been confirmed by multiple users.

Disclaimer: I have not tried this personally, I'm planning on it...

Attachments

dos-networking.zip Download (45.2 KB) - added by andyp1973 4 months ago.
Logs from identical VM guest running under 5.2.22 and 6.0.1
vbox-freedos-pcnet-bug.zip Download (24.6 KB) - added by PThorn 4 months ago.
FreeDos 1.2 VM log with manual PCNET driver config and an attempt to run dhcp.exe

Change History

comment:1 Changed 4 months ago by andyp1973

I have tried this with dev build 6.0.1 r127640 and the problem persists.

-Andy.

Changed 4 months ago by andyp1973

Logs from identical VM guest running under 5.2.22 and 6.0.1

comment:2 Changed 4 months ago by andyp1973

Slight clarification...

The 5.2.22 log comes from a Linux host the 6.0.1 from a macOS host but the only difference in setup is the network device being bridged to.

-Andy.

comment:3 Changed 4 months ago by PThorn

I was able to get the driver to detect the card by adding parameters to the command line:

PCNTPK.COM INT=0x60 IRQ=0x0A IOADDR=0xD020

(took the values from the last screenshot  here). With this change the driver correctly prints the MAC address as set in the VM config. However, dhcp.exe fails with timeout errors. So I used wireshark to see if there is any traffic coming out of the VM. Turns out there is: the VM sends DHCP DISCOVER packets and my DHCP server responds with OFFERs. The VM does not seem to receive those DHCP responses though.

Other VMs (Ubuntu, etc.) with the same net config (bridge to en0, the adapter type is different of course) successfully obtain DHCP leases and have network connectivity under the same VirtualBox instance.

VirtualBox 6.0.0 release, macOS 10.14.2.

Changed 4 months ago by PThorn

FreeDos 1.2 VM log with manual PCNET driver config and an attempt to run dhcp.exe

comment:4 Changed 3 months ago by michaln

  • Summary changed from DOS-class VMs don't recognize PCnet-FAST III (6.0.0 regression) to DOS-class VMs don't recognize PCnet-FAST III (6.0.0 regression) => fixed in svn

Yes, this was a regression in 6.0.0, should be now fixed.

The problem was not so much with DOS VMs as with specific drivers which failed to detect the emulated hardware. The DOS packet drivers were affected, NetWare client and server drivers were affected. DOS NDIS drivers were not affected, and neither were Windows and OS/2 NDIS drivers or Linux drivers.

comment:5 Changed 3 months ago by socratis

Can you try the latest test build, r128070 or later?

comment:6 Changed 3 months ago by PThorn

Build 128072 (macOS) is confirmed working. Thanks for the fix!

comment:7 Changed 3 months ago by andyp1973

Likewise, I can confirm that this is working using 6.0.1-r128072 (also on a macOS host).

-Andy.

comment:8 Changed 3 months ago by haakondahl

Any projected date for the release?

comment:9 follow-up: ↓ 10 Changed 3 months ago by socratis

@haakondahl
There's never a projected release date for any version. If you're immediately affected, install the latest test build.

comment:10 in reply to: ↑ 9 Changed 3 months ago by haakondahl

Replying to socratis:

@haakondahl
There's never a projected release date for any version. If you're immediately affected, install the latest test build.

Thank you. I'm new to this. I'm leery about modifying UEFI settings -- have worked around using mkisofs and some disk-swapping. Which is part of the DOS experience, so... I shall wait patiently and be grateful.

comment:11 Changed 6 days ago by michael

  • Status changed from new to closed
  • Resolution set to fixed
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use