VirtualBox

Ticket #18239 (closed defect: fixed)

Opened 9 months ago

Last modified 3 months ago

No Mouse visibility on VM -> fixed in releases after 6.0.4

Reported by: jfha73 Owned by:
Component: other Version: VirtualBox 6.0.0
Keywords: Cc:
Guest type: Linux Host type: Mac OS X

Description

Hey guys,

I just installed VirtualBox 6 (first install) to a Mac OS X 10.13.6 and tried to create my first VM using CentOS but I never got to see the mouse pointer, I did notice that when the mouse passed on top of the list boxes they showed the mouse was on top of them, but I couldn't see the mouse pointer itself, what can I do?

Thanks.

Change History

comment:1 Changed 9 months ago by socratis

  1. It's usually better and faster, if issues get first addressed in the  VirtualBox forums, a lot more eyes there. More than 95% of the issues are resolved over there, which keeps the developers focusing on the bug fixes and enhancements, and there is no need for another ticket to keep track of. For example, yours is most probably not a bug and someone from the developers has to deal with it and close it as "Invalid". Please be sure to mention that you came from the bug tracker and include the ticket number.
  1. You were supposed to follow these steps when you filed the bug, and provide a VBox.log:

    Attach a (full) log file ("Machine" menu/"Show Log" in the main VirtualBox Manager window) straight away to save time for you and for us. The log file contains a lot of useful information about both the host and the guest systems as well as information about what happened during a particular machine run. Please do not cut and paste it.

comment:2 Changed 7 months ago by MarcT

I saw the same behavior in Linux (host) and VirtualBox 6.0. During CentOS7 install the guest mouse pointer was not visible.

In "VirtualBox > Settings > Display" for the guest, I changed the "Graphics Controller" to "VBoxSVGA" (was previously "VBoxVGA" I think) and rebooted the guest. Now the mouse pointer is visible during CentOS install.

FYI - I'm not that familiar with CentOS, but I did also note that sometimes clicking on certain buttons in the installer did not activate them. I either had to click on them AND press "<RETURN>" to activate, or press "<ESC>" on the keyboard to cancel.

Last edited 7 months ago by MarcT (previous) (diff)

comment:3 follow-up: ↓ 4 Changed 7 months ago by socratis

VBoxSVGA is the wrong option, as it's used for Win guests. Are you sure you didn't change it to VMSVGA, which is the proper one for Linux guests?

comment:4 in reply to: ↑ 3 Changed 7 months ago by MarcT

Replying to socratis:

VBoxSVGA is the wrong option, as it's used for Win guests. Are you sure you didn't change it to VMSVGA, which is the proper one for Linux guests?

Yes, I'm sure I changed it to VBoxSVGA, and it resolved the invisible mouse pointer in CentOS 7 install.

comment:5 follow-up: ↓ 6 Changed 7 months ago by socratis

As I said, the VBoxSVGA is for Win guests. Please try with the VMSVGA.

comment:6 in reply to: ↑ 5 Changed 7 months ago by MarcT

Replying to socratis:

As I said, the VBoxSVGA is for Win guests. Please try with the VMSVGA.

I tried a fresh install of Centos 7 minimal (1810), with VMSVGA. The mouse pointer is not visible in the installer.

Set it to VBoxSVGA, and the mouse pointer is visible in the CentOS installer.

comment:7 follow-up: ↓ 12 Changed 7 months ago by socratis

@MarcT
If your CentOS7 is actually 7.6, then this is a duplicate of #18124. Please read that ticket and the related discussion in the forums:  https://forums.virtualbox.org/viewtopic.php?f=3&t=90267

It's a RHEL/CentOS bug actually in the PS/2 mouse, in the kernel. We're waiting for a RHEL/CentOS fix, nothing VirtualBox can do about it...

comment:8 follow-up: ↓ 9 Changed 7 months ago by boktai1000

I just came from VirtualBox 5.2 to 6.0 and immediately ran into this bug. Everything was working perfectly prior to the upgrade, and suddenly when VirtualBox changes (all other variables remain the same) - suddenly the mouse has disappeared completely. Switching to VboxSVGA appears to fix this as others have mentioned, and gives the expected result.

I know it's being said that it's a "Kernel bug" - but if the software used to emulate an expected result (which is to have a mouse visible) works on other hardware, etc. - Wouldn't the issue be with VirtualBox in this case?

Either way it seems a little bit finger pointy to keep saying that VBoxSVGA is the wrong option and to use VMSVGA which is the intended option (and is the default). Well here's the news, VMSVGA is broken. I don't think end-users really care what the "proper" option is here, they just want things to work out-of-the-box.

The experience with VBox 5.2 is that it works just as expected. Now it doesn't with 6.0. Even if it's fixed in a later Kernel, these versions of installers will forever be broken by this logic.

comment:9 in reply to: ↑ 8 ; follow-up: ↓ 10 Changed 7 months ago by socratis

Replying to boktai1000:

I know it's being said that it's a "Kernel bug"

No, I didn't say it's a Kernel bug, I said:

If your CentOS7 is actually 7.6

Based on your  comments if the forums, what you're seeing is not the same bug as #18124.

The experience with VBox 5.2 is that it works just as expected. Now it doesn't with 6.0.

I definitely don't see it, so most probably it must be specific to your setup. We got to find if it is a problem and under which conditions/setup. As I've mentioned  in reply to your forum post, please open a new thread in the  Linux Guests section of the forums, a lot more users/use-cases there. And if it is a bug, then we can call it a "bug" ;)

it seems a little bit finger pointy to keep saying that VBoxSVGA is the wrong option and to use VMSVGA which is the intended option (and is the default)

Not really. If an option is the wrong option, it should be pointed out! I've actually asked the developers to flag these combinations (VMSVGA+Windows, or VBoxSVGA+Linux) and not allow the end-user to select that combination. If the users don't want to listen, it should be enforced by the API, instead of letting the users "shoot their feet".

Well here's the news, VMSVGA is broken

Yes, VMSVGA and VBoxSVGA were released with 6.0.0 as the next-gen foundation for the GPUs, not something that was working perfectly before even being released. I expect (wild guess) that by 6.1.0, the majority of the issues will have been resolved.

I don't think end-users really care what the "proper" option is here, they just want things to work out-of-the-box.

You can always either choose a different vGPU option, downgrade, or complain and a helpful volunteer will tell you to use the old VBoxVGA card. Problem "solved", there is a temporary workaround available...

Even if it's fixed in a later Kernel, these versions of installers will forever be broken by this logic.

It most probably will be fixed with a future VirtualBox version. No clue when of even if. And yours is not a kernel issue, as I've mentioned previously...

Last edited 7 months ago by socratis (previous) (diff)

comment:10 in reply to: ↑ 9 ; follow-up: ↓ 11 Changed 7 months ago by boktai1000

@socratis I've opened up a new thread on the forums here  https://forums.virtualbox.org/viewtopic.php?f=3&t=92060 as per your recommendation.

I would also like to mention that I did also try with VboxVGA and that works just the same as VboxSVGA for what it's worth - as far fixing the mouse problem goes.

How would you recommend we procedure from here? Is there any more information that we could gather and provide that may be useful? I see that the OP mentions using Mac OS X 10.13.6, I am personally using Windows 10 x64 Build 1809, which is in-fact a fresh installation. CPU is an i7-4790K with a Nvidia GTX 980 Ti GPU. I at least wanted to mention my specifications in case there is any correlation, but there does appear to be quite a variance already in OP and mine with the OS used.

Last edited 7 months ago by boktai1000 (previous) (diff)

comment:11 in reply to: ↑ 10 Changed 7 months ago by socratis

Replying to boktai1000:

@socratis I've opened up a new thread on the forums here  https://forums.virtualbox.org/viewtopic.php?f=3&t=92060 as per your recommendation.

Thank you very much, let's figure out what's going on in the forums, and if we reach a meaningful conclusion, we can then let the developers know here, in the bugtracker.

I would also like to mention that I did also try with VboxVGA and that works just the same as VboxSVGA for what it's worth - as far fixing the mouse problem goes.

I know, it's the new VMSVGA that was introduced that has most of the issues with the Linux guests.

How would you recommend we procedure from here? Is there any more information that we could gather and provide that may be useful? I see that the OP mentions using Mac OS X 10.13.6, I am personally using Windows 10 x64 Build 1809, which is in-fact a fresh installation.

I happen to have a couple (4 actually) OSX installations and 3 Windows ones. Unfortunately my 64-bit hosts' hard drive broke, and I'm in the process of recreating the setup, so it's going to be a couple of days until I'm back in full operational mode.

But, let's continue in the forums, momentarily... ;)

comment:12 in reply to: ↑ 7 Changed 7 months ago by MarcT

Replying to socratis:

@MarcT
If your CentOS7 is actually 7.6, then this is a duplicate of #18124. Please read that ticket and the related discussion in the forums:  https://forums.virtualbox.org/viewtopic.php?f=3&t=90267

It's a RHEL/CentOS bug actually in the PS/2 mouse, in the kernel. We're waiting for a RHEL/CentOS fix, nothing VirtualBox can do about it...

No - my issue is whether the mouse pointer is visible (or not) in the Guest window. With "VBoxSVGA" I can see the guest's mouse pointer. With "VMSVGA" I cannot; however the Guest thinks's it's there as scroll bars and buttons hilight when the now invisible pointer is moved over them.

comment:13 Changed 6 months ago by WillB68

I'm on a windows box, but installing CentOS 7. Ran into same no working/invisible mouse bug. This threat helped me fix my problem.

VBoxSVGA worked for me. VMSVGA didn't work for me. Same symptoms as default load.

Note: The VM can NOT be running when you adjust the graphics, because it will be greyed out and not allow you to change anything. Turn off the VM, first!

INSTRUCTIONS: Launch VirtualBox --> Oracle VM VirtualBox Manager --> Highlight your CentOS, RHEL or whatever flavor VM is giving you the invisible mouse bug problem --> Settings --> Display --> Graphics Controller --> VBoxSVGA --> turn on your VM to await Language and your mouse will not work as desired.

Capturing is a different elementary issue. Read the instructions on the screen. Click Return to capture the mouse inside of the VM environment and click Right Ctrl to escape. I had to go in and out many times to setup initial settings.

You're welcome ;)

Last edited 6 months ago by WillB68 (previous) (diff)

comment:14 Changed 6 months ago by michael

Known issue, fix being worked on but not there yet. Background: when mouse integration is not available our older graphics device would tell the guest system that it could not draw the cursor itself, and then the guest system drew it itself. The VMSVGA drivers in the kernel do not do that, but always say that the device can draw the cursor, even when our current code cannot.

comment:15 Changed 6 months ago by Ronophobia

I ran into the same issue while installing Centos 7 (invisible mouse pointer) (uname -a Linux hostname 3.10.0-957.el7.x86_64 ) I did manage to install using the keyboard shortcuts. So following this thread i switched over to VBoxSVGA and it worked. But the downside is that the highest resolution available on guest OS is 1024*768(4:3). In one way it does solve the problem but looking at a small screen on a large screen is a bit annoying. Did anybody solve this issue?

comment:16 Changed 5 months ago by michael

  • Summary changed from No Mouse visibility on VM to No Mouse visibility on VM -> fixed in releases after 6.0.4

comment:17 Changed 5 months ago by michael

  • Status changed from new to closed
  • Resolution set to fixed

comment:18 Changed 3 months ago by mikefo

  • Status changed from closed to reopened
  • Resolution fixed deleted

Problem still persists using VBox 6.0.8 r130520 and associated Guest Additions. Running Ubuntu 18.04LTS guest on native Win10 64-bit. Starting the VM (VirtualBox window maximized with Mouse Integration enabled) yields no mouse capture or keyboard with "Mouse Integration" enabled. If I press the Win10 "Restore" button (i.e. making the window smaller than "maximized", keyboard and mouse "come back to life" (Input-->Mouse Integration still shows "enabled"). I then can log into the Ubuntu 18.04LTS VM. Once I am logged in, I sometimes have to go to "Input-->Mouse Integration" and flip Mouse Integration (enabled-->disabled-->enabled). I can then "maximize" the Win10 Oracle VBox window and all is well.

comment:19 Changed 3 months ago by michael

  • Status changed from reopened to closed
  • Resolution set to fixed

That does not sound like the problem discussed in the ticket. Have you searched for similar problems on the forums or asked there? If you can't find a solution that way you might want to open a new ticket (with log file).

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use