VirtualBox

Opened 6 years ago

Closed 5 years ago

Last modified 5 years ago

#18205 closed defect (fixed)

VM does not refresh, but preview window runs realtime -> fixed in 6.0.2

Reported by: Frossi Owned by:
Component: VM control Version: VirtualBox 6.0.0
Keywords: freeze refresh Cc:
Guest type: other Host type: Windows

Description

Hey guys, i'm expecting a weird problem on my VM. I'm running WIN7 and i'm trying to run a fresh install of Win10. At the login window my problem starts. When I type the password, nothing (chars) shows up. If I hit "enter" nothing happens. If I switch the VM VirtualBox app focus, when I come back at the VirtualBox, it refreshes the screen. More weird than this, the Preview window runs everything realtime, but the VM screen does not refresh until focus is changed.

Similar (or the same problem) can be found here: https://www.virtualbox.org/ticket/15511 https://www.virtualbox.org/ticket/2985

Attachments (2)

VBox.log (136.9 KB ) - added by Mihai Hanor 6 years ago.
VBox.2.log (100.8 KB ) - added by Reggie Perrin 5 years ago.
Log file

Download all attachments as: .zip

Change History (18)

comment:1 by Frossi, 6 years ago

Hey Guys, solved my problem.

I had to enable 2D and 3D video acceleration to make it work.

comment:2 by Mihai Hanor, 6 years ago

This issue occurs when the selected VM display adapter is VBoxSVGA and VirtualBox Guest Additions video driver is running. After changing the VM video adapter to VBoxVGA or uninstalling the GA video driver, the issue doesn't manifest itself. I haven't tried enabling 2D/3D.

Version 0, edited 6 years ago by Mihai Hanor (next)

by Mihai Hanor, 6 years ago

Attachment: VBox.log added

comment:3 by lbgaus, 5 years ago

I am also experiencing this condition with the new 6.0.0 release. Your workaround resolved the issue for me. In my case, I was running Windows 10 guest in headless/detached mode.

Last edited 5 years ago by lbgaus (previous) (diff)

comment:4 by mtrix-hbo, 5 years ago

This also affects Windows Server 2016 Guests, probably because of the same code base as Windows 10.

My host system is Windows 10 x64 as well, so it might be independent of the host OS.

Both workarounds worked in my case, 2D/3D acceleration and changing to a different VGA adapter.

comment:5 by TehSphinX, 5 years ago

Had the issue on OSX with Windows 10 Guest.

Enabling 2D/3D support did not really fix the issue. The Screen did update but text sometimes became completely unreadable after opening the Start-Menu for example.

Switching the driver to VBoxVGA (instead of VBoxSVGA) helped.

Seems the SVGA driver has some issues.

by Reggie Perrin, 5 years ago

Attachment: VBox.2.log added

Log file

comment:6 by Reggie Perrin, 5 years ago

I'm having the same issue as above with a Server 2016 VM. Setting 2D/3D acceleration does (partially) work around it, with similar results as posted by TehSphinX

comment:7 by AkifTariq, 5 years ago

I am having the same issue with Manjaro 18 as host and Windows 10 as guest, after upgrading to VirtualBox 6.

comment:8 by Mihai Hanor, 5 years ago

This was fixed in 6.0.2.

comment:9 by Socratis, 5 years ago

Confirmed on an OSX 10.9.5 host with 6.0.3 r128258 as well...

Not the most supported setup, but it works!

comment:10 by jeffb, 5 years ago

I have the same symptoms with a Windows 10 host and Linux guest. Changing to VBoxSVGA from VBoxVGA (both 2D/3D acceleration disabled) resolved it for me.

comment:11 by Mihai Hanor, 5 years ago

Attach a VM log.

comment:12 by Michael Thayer, 5 years ago

Resolution: fixed
Status: newclosed
Summary: VM does not refresh, but preview window runs realtimeVM does not refresh, but preview window runs realtime -> fixed in 6.0.2

comment:13 by enterprise, 5 years ago

I have the same issue still present in VirtualBox version 6.0.10 r132072 (Qt5.6.3), using MacOS Mojave 10.14.15. Only graphics controller, which worked, was VMSVGA (without any 2D/3D acceleration).

comment:14 by Socratis, 5 years ago

@enterprise

Please, open a new thread in the VirtualBox on Mac OS X Hosts section of the forums.

comment:15 by pulse, 5 years ago

I have the same issue still present in VirtualBox 6.0.14 r133895 (Qt5.6.2), using Windows 10 (10.0.17134). The only graphics controller which worked was VMSVGA (without 2D/3D acceleration). This is the same as for @enterprise, but on Windows 10 - so it seems that this is not OS specific...

comment:16 by Socratis, 5 years ago

'pulse'

The advice still remains the same: open a new thread in the Using VirtualBox section of the forums.

Note: See TracTickets for help on using tickets.

© 2023 Oracle
ContactPrivacy policyTerms of Use