VirtualBox

Ticket #18205 (new defect)

Opened 2 months ago

Last modified 2 weeks ago

VM does not refresh, but preview window runs realtime

Reported by: Frossi Owned by:
Component: VM control Version: VirtualBox 6.0.0
Keywords: freeze refresh Cc:
Guest type: other Host type: Windows

Description

Hey guys, i'm expecting a weird problem on my VM. I'm running WIN7 and i'm trying to run a fresh install of Win10. At the login window my problem starts. When I type the password, nothing (chars) shows up. If I hit "enter" nothing happens. If I switch the VM VirtualBox app focus, when I come back at the VirtualBox, it refreshes the screen. More weird than this, the Preview window runs everything realtime, but the VM screen does not refresh until focus is changed.

Similar (or the same problem) can be found here: https://www.virtualbox.org/ticket/15511 https://www.virtualbox.org/ticket/2985

Attachments

VBox.log Download (136.9 KB) - added by mhanor 2 months ago.
VBox.2.log Download (100.8 KB) - added by Reggie Perrin 6 weeks ago.
Log file

Change History

comment:1 Changed 2 months ago by Frossi

Hey Guys, solved my problem.

I had to enable 2D and 3D video acceleration to make it work.

comment:2 Changed 2 months ago by mhanor

This issue occurs when the selected VM display adapter is VBoxSVGA and VirtualBox Guest Additions video driver is running. After changing the VM video adapter to VBoxVGA or uninstalling the GA video driver, the issue doesn't manifest itself. I haven't tried enabling 2D/3D. Making the VirtualBox Manager window active, triggers a refresh of the VM screen.

Last edited 2 months ago by mhanor (previous) (diff)

Changed 2 months ago by mhanor

comment:3 Changed 7 weeks ago by lbgaus

I am also experiencing this condition with the new 6.0.0 release. Your workaround resolved the issue for me. In my case, I was running Windows 10 guest in headless/detached mode.

Last edited 7 weeks ago by lbgaus (previous) (diff)

comment:4 Changed 7 weeks ago by mtrix-hbo

This also affects Windows Server 2016 Guests, probably because of the same code base as Windows 10.

My host system is Windows 10 x64 as well, so it might be independent of the host OS.

Both workarounds worked in my case, 2D/3D acceleration and changing to a different VGA adapter.

comment:5 Changed 6 weeks ago by TehSphinX

Had the issue on OSX with Windows 10 Guest.

Enabling 2D/3D support did not really fix the issue. The Screen did update but text sometimes became completely unreadable after opening the Start-Menu for example.

Switching the driver to VBoxVGA (instead of VBoxSVGA) helped.

Seems the SVGA driver has some issues.

Changed 6 weeks ago by Reggie Perrin

Log file

comment:6 Changed 6 weeks ago by Reggie Perrin

I'm having the same issue as above with a Server 2016 VM. Setting 2D/3D acceleration does (partially) work around it, with similar results as posted by TehSphinX

comment:7 Changed 5 weeks ago by AkifTariq

I am having the same issue with Manjaro 18 as host and Windows 10 as guest, after upgrading to VirtualBox 6.

comment:8 Changed 5 weeks ago by mhanor

This was fixed in 6.0.2.

comment:9 Changed 5 weeks ago by socratis

Confirmed on an OSX 10.9.5 host with 6.0.3 r128258 as well...

Not the most supported setup, but it works!

comment:10 Changed 2 weeks ago by jeffb

I have the same symptoms with a Windows 10 host and Linux guest. Changing to VBoxSVGA from VBoxVGA (both 2D/3D acceleration disabled) resolved it for me.

comment:11 Changed 2 weeks ago by mhanor

Attach a VM log.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use