VirtualBox

Ticket #18093 (closed defect: fixed)

Opened 13 months ago

Last modified 10 months ago

Error building the graphics driver module in a RHEL 7.6 guest -> fixed after (not in) 5.2.22

Reported by: JoergK Owned by:
Component: guest additions Version: VirtualBox 5.2.20
Keywords: Cc:
Guest type: Linux Host type: Linux

Description

Hello,

I'm using VBox 5.2.20 r125813 (Qt5.6.1) on Ubuntu 16.04 Host with RHEL 7.5 guest. After updating the RHEL guest to 7.6 I tried to reinstall the guest additions but building the graphics driver module failed.

So I tried with the test build 5.2.21 revision 126213 but building the graphics driver module failed, too.

To reproduce this issue just try to install the guest additions in a RHEL 7.6 guest system.

There is a topic to this issue at:  https://forums.virtualbox.org/viewtopic.php?f=3&t=90103

I'm going to attach related log files to this case once it is open. If I could do anything else to track this down, please let me know. I'm not experienced in tracking down and debugging possible bugs in virtualbox, yet.

Attachments

RHEL-Dev-2018-11-01-06-52-27.log.gz Download (35.6 KB) - added by JoergK 13 months ago.
Log file from VBox version 5.2.20
vboxadd-setup.log Download (20.3 KB) - added by JoergK 13 months ago.
vboxadd-setup-log from version 5.2.20
RHEL-Dev-2018-11-01-17-46-12.log Download (124.3 KB) - added by JoergK 13 months ago.
Log file from test build 5.2.21 126213
vboxadd-setup.2.log Download (20.3 KB) - added by JoergK 13 months ago.
vboxadd-setup-log from version 5.2.21 126213
vbox_video_build_rhel76_fix.patch Download (4.6 KB) - added by rconde01 12 months ago.
Patch to fix build
vboxadd-setup.3.log Download (13.9 KB) - added by nixuser 12 months ago.
vboxadd-setup.zip Download (2.2 KB) - added by maroz 10 months ago.
logs for 3.8.13-118.28.1.el7uek.x86_64

Change History

Changed 13 months ago by JoergK

Log file from VBox version 5.2.20

Changed 13 months ago by JoergK

vboxadd-setup-log from version 5.2.20

Changed 13 months ago by JoergK

Log file from test build 5.2.21 126213

Changed 13 months ago by JoergK

vboxadd-setup-log from version 5.2.21 126213

comment:1 Changed 12 months ago by nixuser

The failure leaves the system in a state whereby Xorg crashes on startup so you can't even use the 1024x768 (or whatever it is) default GUI until you clean it up by running the /opt/VBoxGuestAdditions-5.2.20/uninstall.sh script via a virtual console.

Last edited 12 months ago by nixuser (previous) (diff)

comment:2 Changed 12 months ago by HRZunibi

Can reproduce the problem under CentOS 7.5 as Host and RHEL 7.6 Guest with 5.2.21-126141 Guest additions. System is usable problem equal to JoergK, but not as worse as nixuser.

comment:3 Changed 12 months ago by wil-go

Same issue, but system can't even run 1024x768 after uninstalling. Stuck with small window for a week now.

comment:4 Changed 12 months ago by michael

I will take a look at this as soon as OL 7.6 or CentOS 7.6 is available. Alternatively, patches welcome.

comment:5 Changed 12 months ago by nixuser

It may be quicker to download an eval copy of RHEL and try it out. Not sure when 7.6 will push through to the others.

comment:6 Changed 12 months ago by michael

Actually I have already downloaded the OL 7.6 pre-release, but I need to find time to do this. If you are in a hurry, a patch may speed things up.

comment:7 Changed 12 months ago by rconde01

michael - I'm going to look at doing a patch, but I think it will fix Redhat 7.6, and break others...how is that normally handled?

comment:8 Changed 12 months ago by michael

See the RHEL_7x conditionals in the code. Usually there is already a conditional on a particular kernel version, and you just need to add "|| defined(RHEL_76)" (after defining that in vbox_drv.h of course).

Changed 12 months ago by rconde01

Patch to fix build

comment:9 Changed 12 months ago by rconde01

Ok - I added a first cut at a patch. FYI I'm new at working in the vbox codebase. I

  • Checked out the svn repo
  • Built VBox (after installing many dependencies) through
    • ./configure --disable-hardening --disable-docs
    • source ./env.sh
    • kmk all VBOX_ONLY_ADDITIONS=1
  • cd ./out/linux.amd64/release/bin/additions/src/vboxvideo
  • make and fix each issue until it builds

To create the patch I found the original location of the files in the repo and copied over the edited versions. I was a bit surprised when comparing because there were additional changes...not sure if there's a preprocessing step before copying to ./out/XXXX/vboxvideo. So I made the files look like the head except for my changes. Then I created an svn patch and that's what I attached. Let me know if you need any changes to those steps.

comment:10 Changed 12 months ago by michael

Thank you, I will take a look at it. Your sequence looks good to me. And you are right, there is a pre-processing stage. I will get rid of it when I get around to it. It seemed like a good idea at the time, to make what we supply look as similar as possible to what Hans put into the Linux kernel code.

comment:11 Changed 12 months ago by HRZunibi

Just for those who are interested: Problem still persists in 5.2.22.

comment:12 Changed 12 months ago by michael

@rconde01 Looks good. Could you please post a statement that you release your patch under the MIT licence, and tell me if (and how) you would like to be credited in the change log/subversion history?

comment:13 Changed 12 months ago by rconde01

I Robert Conde release my patch under the MIT license. You may credit me as "Robert Conde".

comment:14 Changed 12 months ago by michael

  • Summary changed from Error building the graphics driver module in a RHEL 7.6 guest to Error building the graphics driver module in a RHEL 7.6 guest -> fixed after (not in) 5.2.22

https://www.virtualbox.org/changeset/75402/vbox

Many thanks. Test build<1> revision 126544 of the Guest Additions (5.2 branch build) should be available in an hour or so and contain the change. I see no reason not to continue using this test build as long as there is no new release of VirtualBox.

  1. wiki:Testbuilds

Changed 12 months ago by nixuser

comment:15 Changed 12 months ago by nixuser

Test build VirtualBox-5.2.23-126544 not working for me, attached vboxadd-setup.log file.

comment:16 Changed 12 months ago by HRZunibi

Successfully installed Guest extensions 5.2.23-126544 without problems and it works (Host CentOS 7.5, Guest RHEL 7.6).

THX!

Last edited 12 months ago by HRZunibi (previous) (diff)

comment:17 Changed 12 months ago by nixuser

@HRZunibi which kernel are you running, is it 3.10.0-957 ??

If so I don't understand how you are getting it to compile. I've just cleaned out yum and run latest updates and it still fails here.

comment:18 Changed 12 months ago by nixuser

I was able to get the latest test build VirtualBox-5.2.23-126581 to work.

comment:19 Changed 12 months ago by JoergK

Hi, Version 5.2.23-126798 fixed the issue on my site. I'm running kernel 3.10.0-957 in the guest os.

comment:20 Changed 11 months ago by michael

  • Status changed from new to closed
  • Resolution set to fixed

comment:21 Changed 11 months ago by nixuser

Is this fixed in the 6.x stream? I see that 6.0 has just been released.

comment:22 Changed 11 months ago by michael

It should be. Did you have problems with it?

comment:23 Changed 10 months ago by maroz

I couldn't install 6.0.0 guest additions for Oracle Linux 7.6 with Unbreakable Enterprise Kernel 3.8.13-118.28.1.el7uek.x86_64, but installed fine with Linux 3.10.0-957.1.3.el7.x86_64 kernel.

Last edited 10 months ago by maroz (previous) (diff)

comment:24 Changed 10 months ago by maroz

It also installs fine with Oracle Linux 7.6 default kernel 4.14.35-1818.3.3.el7uek.x86_64.

comment:25 follow-up: ↓ 26 Changed 10 months ago by nixuser

@michael I cannot run 6.0 as I saw it was 64-bit only. I need [for now] to support 32-bit.

comment:26 in reply to: ↑ 25 Changed 10 months ago by socratis

Replying to nixuser:

I cannot run 6.0 as I saw it was 64-bit only. I need [for now] to support 32-bit.

Then your only option is to use the Test Builds, until 5.2.24 comes out, if and when it does...

comment:27 Changed 10 months ago by michael

@maroz Could you please provide the log files from the guest (/var/log/vbox*) after trying to install with 3.8.13-118.2? I have just built the OL7.3/3.8.13-118.24.2.el6uek.x86_64 combination without problems.

Changed 10 months ago by maroz

logs for 3.8.13-118.28.1.el7uek.x86_64

comment:28 Changed 10 months ago by michael

@maroz Thank you. This is a different problem - see ticket #18238 - and is fixed in the current test builds. Feel free to give one a try. They are expected to be as stable as release builds for most purposes - possibly more currently, as they have several bug fixes which 6.0.0 does not have - so there is no reason not to use a test build as long as there is no new release.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use