VirtualBox

Ticket #17804 (new defect)

Opened 4 years ago

Last modified 4 years ago

Win10 and 7 host OracleEnterpriseLinux 6.7 guest addition clipboard and window resize does not work

Reported by: Laszlo Owned by:
Component: guest additions Version: VirtualBox 5.2.12
Keywords: Cc:
Guest type: Linux Host type: Windows

Description

HostOS: Win10 Pro, Win7Pro GuestOS: Oracle Linux 6.7 uname -a: Linux demo.us.oracle.com 3.8.13-118.4.2.el6uek.x86_64 #2 SMP VBox: Version 5.2.12 r122591 (Qt5.6.2) Guest Addition: 5.2.12 successfully installed under OS user 'oracle' and root authentication was given during the install. Mouse integration works, I can move the mouse outside of VBox window without pressing Right-CTRL. Devices/Shared Clipboard is set to bi-directional Devices/Drag and drop disabled Devices/Shared Folder is set and auto-mount is working, files can be read and written.

What does not work is:

  1. Clipboard between host and guest do not work in any direction regardless what is the Devices/Shared Clipboard setting
  2. VBox window resizing worked before guest addition was installed, after that it stopped working only 800x600 screen size is available by default. Within Linux manual reset of the resolution works but the information gets lost and reset to 800x600 after reboot.
  3. when switching Linux OS user from 'oracle' to 'root' the screen resizing starts working and the clipboard bidirectional as well.
  4. When switching back to 'oracle' it is not working

The clipboard integration makes it as a major incident.

Change History

comment:1 Changed 4 years ago by socratis

Is this maybe a duplicate of #17790, which apparently was fixed with the release of a new Oracle VM released on 2018-06-07?

BTW, it's usually better and faster, if issues get first addressed in the  VirtualBox forums. More than 95% of the issues are resolved over there, which keeps the developers focusing on the bug fixes and enhancements, and there is no need for another ticket to keep track of. For example, yours is most probably not a bug and someone from the developers has to deal with it and close it as "Invalid".

Oh, and you were supposed to follow these steps when you filed the bug, and provide a VBox.log:

Attach a (full) log file ("Machine" menu/"Show Log" in the main VirtualBox Manager window) straight away to save time for you and for us. The log file contains a lot of useful information about both the host and the guest systems as well as information about what happened during a particular machine run. Please do not cut and paste it.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use