VirtualBox

Ticket #1778 (reopened defect)

Opened 6 years ago

Last modified 17 months ago

Windows XP Guest crash with Kaspersky 2009 (rdpmc) -> fixed in SVN

Reported by: oxmosys Owned by:
Priority: major Component: VMM
Version: VirtualBox 1.6.2 Keywords:
Cc: Guest type: Windows
Host type: other

Description

When using VirtualBox 1.6.2 with Windows XP SP2 guest with kaspersky 2009 installed, the computer crash a few seconds after boot. This is always reproducible.

Attachments

VBox.log Download (47.6 KB) - added by oxmosys 6 years ago.
VBox.2.log Download (32.3 KB) - added by oxmosys 6 years ago.
VB-WinXP-2009-04-20-19-12-12.log Download (37.8 KB) - added by ToddAndMargo 5 years ago.
XP-Pro-SP3, kis8.0.0.506en.exe with VT-x crash log
vbox_kis8.0.0.506de_exe.log Download (56.5 KB) - added by anfo.at 5 years ago.
XP SP3 on Vista X64, kis8.0.0.506de.exe
vbox_hiryu.log Download (50.0 KB) - added by anfo.at 5 years ago.
8.0.0.506 PL (on request by forum user "hiryu")
WinXPSP3-2009-07-13-15-30-49.log Download (50.9 KB) - added by harlan4096 5 years ago.
Problem with KIS 2010 463 CF1 beta & VB 3.0.2
WINXPSP3 + KIS2010-2009-10-04-22-02-08.log Download (50.4 KB) - added by harlan4096 5 years ago.
Windows XP hungs (KIS 2010 9.0.0.463)
Windows XP-2009-11-05-20-43-24.log Download (50.9 KB) - added by fjnunn 4 years ago.

Change History

comment:1 Changed 6 years ago by sandervl73

Without the VBox.log of the XP VM there's not much we can say.

Changed 6 years ago by oxmosys

comment:2 Changed 6 years ago by oxmosys

VBox.log attached, however this bug can always be reproduced.

comment:3 Changed 6 years ago by sandervl73

The crash will probably go away if you turn on VT-x in the VM settings dialog.

comment:4 Changed 6 years ago by oxmosys

VT-x totally enabled : No crash, but Windows XP won't boot, it stays waiting just after the welcome screen, when the desktop should normally appears. VT-x partially enabled : It boots to the desktop and works correctly during a few seconds, then crash with a BSOD VT-x disabled : It boots to the desktop and works correctly during a few seconds, then crash with a BSOD

comment:5 Changed 6 years ago by sandervl73

We have to check this ourselves then. Is there a demo of Kaspersky 2009 and if so, does the problem occur with that version as well?

Also, there's no partial VT-x; it's either enabled or it's not. Can you attach a log when you have VT-x enabled?

Changed 6 years ago by oxmosys

comment:6 Changed 6 years ago by oxmosys

I waited 30 minutes for Windows XP to boot, and then attached the VBox.log file, and closed Windows which was still not booted.

Kaspersky free trial version is here :  http://usa.kaspersky.com/trials/home-users/anti-virus-7/tp/

You were right, there is no partial VT-x (I thought this because of the grey case). I tested VT-x enabled (don't boot) and disabled (crashes).

comment:7 Changed 6 years ago by sandervl73

  • Guest type changed from other to Windows

comment:8 Changed 6 years ago by frank

  • Component changed from other to VMM

comment:9 Changed 6 years ago by oxmosys

Can be still reproduced with 1.6.4 release and up-to-date kaspersky

comment:10 Changed 6 years ago by oxmosys

This bug can still be reproduced in 1.6.6 release when VT-x is enabled. However, the bug is not reproducible anymore with VT-x disabled!

comment:11 Changed 6 years ago by oxmosys

Ah false, the situation improved : The guest system does not immediately crash anymore, but it still crashes with a BSOD on random situations.

comment:12 Changed 6 years ago by oxmosys

I can always reproduce a crash when I try to open any .zip file!

comment:13 Changed 6 years ago by oxmosys

BSOD does not happens when Kaspersky is disabled.

comment:14 Changed 6 years ago by oxmosys

This bug can be still reproduced with 2.0 release when VT-x is enabled. With VT-x disabled, it crashes on some circumstances (ex: when accessing a .zip file). Nothing changed since 1.6.6 release.

comment:15 Changed 6 years ago by bes

The problem that VirtualBox in VT-x disabled and AMD-V mode can't correctly skip and injects #UD then guest execute performance monitoring code - rdpmc instruction and read/write unknown for VirtualBox performance counters MSRs by rdmsr, wrmsr. Kaspersky 2009 use these instructions in kernel mode of heuristic analysis engine.

VirtualBox correctly work with Kaspersky on Intel VTx.

comment:16 Changed 6 years ago by oxmosys

MMh, I just tried 2.0.2 with VT-x enabled (I have a intel core 2 duo CPU) and it still crashes with a BSOD when clicking on .zip archives.

comment:17 Changed 6 years ago by bes

Opps, there is other bug on 2.0.2 with VT-x enabled. Yesterday I check only heuristic analysis engine with VT-x - work correct. Other bug - VBox hangs when guest write to write-protected page (on supervisor level) with WP disabled bit of CR0.

comment:18 in reply to: ↑ description Changed 6 years ago by nacho

I think your problem is no VT-x, your problem is Guest additions, try to start XP and unistall Gust additions from control panel

comment:19 Changed 6 years ago by oxmosys

No, the bug is identical without guest additions (I just tested). Crash without VT-x when accessing .zip files, doesn't boot with VT-x

comment:20 follow-up: ↓ 21 Changed 5 years ago by oxmosys

2.0.4, not fixed yet.

comment:21 in reply to: ↑ 20 Changed 5 years ago by ToddAndMargo

Replying to oxmosys:

2.0.4, not fixed yet.

Kaspersky just released a new KIS and KAS:

Kiss (firewall and all)

 ftp://ftp.kaspersky.com//products/english/homeuser/kis2009/kis8.0.0.506en.exe

Kas (no firewall)

 ftp://ftp.kaspersky.com//products/english/homeuser/kav2009/kav8.0.0.506en.exe

Have anyone had a chance to test it yet?

-T

comment:22 follow-up: ↓ 23 Changed 5 years ago by oxmosys

Still reproducible.

comment:23 in reply to: ↑ 22 Changed 5 years ago by ToddAndMargo

Replying to oxmosys:

Still reproducible.

any change under 2.1.0

comment:24 Changed 5 years ago by wordmonger

I'm afraid not since the RDPMC x86 instruction still causes an exception.

We (Kaspersky Lab) can disable certain features of KAV/KIS and not use RDPMC on Virtual Box to avoid the crashes, but to do it, we need a reliable way of detecting Virtual Box "from within". Any ideas?

comment:25 Changed 5 years ago by sandervl73

Unfortunately there's no CPUID bit for RDPMC, so we'll have to properly support this instruction ourselves. I've opened an internal defect for this.

comment:26 Changed 5 years ago by sandervl73

  • Summary changed from Windows XP Guest crash with Kaspersky 2009 to Windows XP Guest crash with Kaspersky 2009 (rdpmc)

comment:27 Changed 5 years ago by jdc15

I also get this crash however it could be related to the scanning engine. I only seem to get the crash after about 2 seconds after starting a system scan using Kaspersky. Im not at all an expert on Virtualbox but I thought it would be worth mentioning it. I have Win XP Pro SP3. My settings are near enough default.

STOP: 0x0000008E (0xC000001D, 0xF70213A3, 0xF4233AB0, 0x00000000)

The file which causes the crash as shown on the BSOD is 'KL1.sys'.

I have VirtualBox version 2.1.2 so by the look of it the crash still happens in the latest version. This is not an inportant bug for me since I was only messing around with VirtualBox. I installed the 30 day trial of Kaspersky Internet Security 2009 including all the latest updates for Windows and for Kaspersky. Guest Additions are installed.

comment:28 Changed 5 years ago by ToddAndMargo

Was this fixed in 2.1.4? There is no sigh of bug 1778 in the change log.

comment:29 follow-up: ↓ 30 Changed 5 years ago by frank

If there is no changelog entry then the probability that this was already fixed is low.

comment:30 in reply to: ↑ 29 Changed 5 years ago by ToddAndMargo

Replying to frank:

If there is no changelog entry then the probability that this was already fixed is low.

Any idea if it is in the queues for 2.1.6 (or whatever they are calling the next release)?

comment:31 Changed 5 years ago by sandervl73

  • Summary changed from Windows XP Guest crash with Kaspersky 2009 (rdpmc) to Windows XP Guest crash with Kaspersky 2009 (rdpmc) -> fixed in SVN/2.2

comment:32 Changed 5 years ago by sandervl73

Kaspersky Internet Security 2009 (trial version) seems to be happy here.

comment:33 Changed 5 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

comment:34 Changed 5 years ago by oxmosys

I confirm that the bug is fixed with VirtualBox 2.2.0

comment:35 Changed 5 years ago by sandervl73

Thanks for the feedback!

comment:36 Changed 5 years ago by ToddAndMargo

  • Status changed from closed to reopened
  • Resolution fixed deleted

Dudes! Guys! This is NOT fixed. Windows XP Pro SP3 and kis8.0.0.506en.exe will only boot up if you turn off VT-x support. And at that it runs like poop (slow, freezes up a lot).

Please fix VT-x support before closing this bug.

Running KAVremover9.exe (in safe mode) and reverting to kis7.0.1.325en.exe for now.

Many thanks, -T

comment:37 follow-up: ↓ 39 Changed 5 years ago by sandervl73

It works here, so some more information is required. VBox.log of such a session and exact Kaspersky version would be helpful.

comment:38 Changed 5 years ago by Lelik

Reproduced freezing here, thanks.

comment:39 in reply to: ↑ 37 Changed 5 years ago by ToddAndMargo

Replying to sandervl73:

It works here, so some more information is required. VBox.log of such a session and exact Kaspersky version would be helpful.

2) The exact version is kis8.0.0.506en.exe or Kaspersky Internet Security suite Version 8.0.0.506 "english". You can download it from:  http://www.kaspersky.com/kis_latest_versions  http://www.kaspersky.com/kis_latest_versions?downlink=206910253

1) Please give me exact directions on how to harvest this log (how to clear out the old stuff, where it is located, what format you want it in, etc.).

-T

Changed 5 years ago by ToddAndMargo

XP-Pro-SP3, kis8.0.0.506en.exe with VT-x crash log

Changed 5 years ago by anfo.at

XP SP3 on Vista X64, kis8.0.0.506de.exe

Changed 5 years ago by anfo.at

8.0.0.506 PL (on request by forum user "hiryu")

comment:40 Changed 5 years ago by ThomasGC

I have same problem.

VirtualBox 2.2.2 hosted on Ubuntu 9.04 jaunty (official public release) with a Windows XP Pro SP3 guest. Kaspersky (KIS) 8.0.0.506.

Since installing KIS the WinXP guest has become unusable. It just hangs immediately after booting up, with max CPU. Cannot even turn KIS off as it does not respond.

I'll probably trash my WinXP guest and start again with a clean install, only this time I'll take a VirtualBox snapshot before installing KIS. :-)

comment:41 Changed 5 years ago by ToddAndMargo

This bug is affecting my ability to give good tech support to my customers who have purchased Kiss8 from me. Since this is affecting my business, would the developers please consider upping the priority on this?

Many thanks, -T

comment:42 Changed 5 years ago by ThomasGC

For anyone moving from Windows to Linux there are almost always going to be Windows applications that they need to continue using, at least for a while. Wine is a solution for some apps but running a virtualized Windows guest [in VirtualBox] may be the only solution for some. I certainly have an app that just won't work in Wine and for which there is no Linux alternative.

If I could run my Windows guest offline that would be a solution. Unfortunately the app needs network access.

Given the above, those same people need the same system security that they had in Windows, in my case the ability to run Kaspersky Internet Security. I've seen similar problems reported for other antivirus software on a Windows guest, e.g. Symantec.

So, this is a serious problem.

I'd consider using a different antivirus if that were possible. Does anyone know of an Internet security app / antivirus that works OK in a Windows XP SP3 guest running in VB on Linux?

comment:43 Changed 5 years ago by ToddAndMargo

Hi Thomas,

Kaspersky version 7 runs fine.

 http://www.kaspersky.com/kis_previous_versions

-T

comment:44 Changed 5 years ago by ToddAndMargo

This bug is getting close to a year old (2008-06-26). It is a total pain in the neck! Is there any chance of this being fixed in 2.2.4? This is affecting my business.

comment:45 Changed 5 years ago by ni81036

ToddAndMargo, please use more correct language. It wouldn't help showing your emotions here, if you will us pay for our work - it may affect our priorities. Shouting won't.

comment:46 Changed 5 years ago by unggnu

This isn't fixed in 2.2.0, 2.2.2 and 2.2.4. I have exact the same issue like described above with Kaspersky 2009.

comment:47 Changed 5 years ago by unggnu

Still happens with 3.0.0 Beta 1.

comment:48 follow-up: ↓ 66 Changed 5 years ago by Serpardum

[quote]2008-12-26 11:18:03 changed by wordmonger ¶

I'm afraid not since the RDPMC x86 instruction still causes an exception.

We (Kaspersky Lab) can disable certain features of KAV/KIS and not use RDPMC on Virtual Box to avoid the crashes, but to do it, we need a reliable way of detecting Virtual Box "from within". Any ideas?quote

I know that if I look at the bios memory starting at b0000 (video memory) that VirtualBox is shown up there (video card). Perhaps you could use that info? You'll need to see exactly the offset where "VirtualBox" shows up and might have problems with priveledges. I am not sure how you would look at this as it's probably protected memory. Just a suggestion.

comment:49 Changed 5 years ago by ToddAndMargo

From:  http://forums.virtualbox.org/viewtopic.php?f=15&t=19292&p=83392#p83392 [quote="sandervl"]... I'll have more time for 3.0.2. Remind me in case I forgotquote

Hi Sandervl,

3.0 just got announced. Nag, Nag, Nag :-)

Also, Kaspersky announced version 9 (2010):  http://www.kaspersky.com/kis_latest_versions

-T

comment:50 Changed 5 years ago by sandervl73

Kaspersky Internet Security version 9 works fine here (XP SP2 guest; VT-x). Trying version 8.0.0.506 next.

comment:51 Changed 5 years ago by sandervl73

Reproduced high cpu load with version 8. Only happens without nested paging here (I have a Core i7 CPU). Investigating.

comment:52 Changed 5 years ago by sandervl73

  • Summary changed from Windows XP Guest crash with Kaspersky 2009 (rdpmc) -> fixed in SVN/2.2 to Windows XP Guest crash with Kaspersky 2009 (rdpmc) -> fixed in SVN

Ok, found and fixed the problem. Performance is normal now. Fix will be included in 3.0.2, which shouldn't be that far off.

comment:53 follow-up: ↓ 54 Changed 5 years ago by harlan4096

Hi guys!

Today I've installed VB 3.0.0 r49315 in my Vista Ultimate x64. I've created a VM with WinXP SP3, and tried KIS 2009 8.0.0.517/506 and KIS 9.0.0.463 CF1 (beta) and IN BOTH CASES, after a few minutos 2 or 3 of working VB got hunged.

My base system ins a Pentium IV 3,4 Ghz / 4 GB RAM DDR2 800 Mhz.

Any idea? Some months ago I tried an older VB (I think 2.1.2 versión)with a KIS and my virtual XP hunged too.

Any idea?.

Regards.

comment:54 in reply to: ↑ 53 ; follow-up: ↓ 55 Changed 5 years ago by ToddAndMargo

Replying to harlan4096:

Today I've installed VB 3.0.0 r49315

Yes: see comment #52. Wait for 3.0.2, where to patch will reside. Then test and report.

-T

comment:55 in reply to: ↑ 54 Changed 5 years ago by harlan4096

Replying to ToddAndMargo:

Replying to harlan4096:

Today I've installed VB 3.0.0 r49315

Yes: see comment #52. Wait for 3.0.2, where to patch will reside. Then test and report.

-T

Ok, thanks, I saw that comment, but I thought maybe It was maybe a different problem.

Regards.

comment:56 Changed 5 years ago by frank

  • Status changed from reopened to closed
  • Resolution set to fixed

comment:57 follow-up: ↓ 59 Changed 5 years ago by unggnu

  • Status changed from closed to reopened
  • Resolution fixed deleted

Windows XP starts further but still hangs shortly after start with Kaspersky 2009 and high cpu usage.

I am using 3.0.2. Can anyone confirm this?

comment:58 Changed 5 years ago by SergeyUser

It still doesn't work on 3.0.2 (Windows Vista host, Windows XP SP3 host, KIS 9.0.0.463, VT-x is not available). System first hangs for some time, and later it starts working but KIS is not accessible (i.e. unable to open KIS window). KIS functions are not available (grayed) in Windows Explorer as well.

comment:59 in reply to: ↑ 57 Changed 5 years ago by ToddAndMargo

Replying to unggnu:

Windows XP starts further but still hangs shortly after start with Kaspersky 2009 and high cpu usage. I am using 3.0.2. Can anyone confirm this?

Yes. VBox 3.0.2, Host: CentOS 5.3, Guest: XP-Pro-SP3. Kaspersky Work Space Security (kav6.0.3.837_winwksen.exe). The corporate edition this time. It now has drags and dead stop since the upgrade. Very annoying to have the mouse stop activating buttons and typing stop every three minutes or so.

Work around (not a good one): send a <ctrl><alt><delete> from the "Machine" pull down.

-T

comment:60 follow-ups: ↓ 61 ↓ 64 Changed 5 years ago by ToddAndMargo

Hi All,

I have a machine I need to update to 3.0.2. Does anyone know if Kaspersky version 7 still runs on 3.0.2?  http://www.kaspersky.com/kis_previous_versions. It does under 2.2.4.

-T

comment:61 in reply to: ↑ 60 Changed 5 years ago by harlan4096

VB 3.0.2 doesn't work either with KIS 9.0.0.463 CF1, my virtual XP hunged again ... bug still not fixed.

Regards.

comment:62 follow-up: ↓ 63 Changed 5 years ago by sandervl73

It is working fine with VT-x here. If you report a problem and don't supply a VBox.log then I can't help you unfortunately.

comment:63 in reply to: ↑ 62 Changed 5 years ago by harlan4096

Replying to sandervl73:

It is working fine with VT-x here. If you report a problem and don't supply a VBox.log then I can't help you unfortunately.

Attaching log file ...

Regards.

Changed 5 years ago by harlan4096

Problem with KIS 2010 463 CF1 beta & VB 3.0.2

comment:64 in reply to: ↑ 60 Changed 5 years ago by catkin

Replying to ToddAndMargo:

Hi All,

I have a machine I need to update to 3.0.2. Does anyone know if Kaspersky version 7 still runs on 3.0.2?  http://www.kaspersky.com/kis_previous_versions. It does under 2.2.4.

Yes. KIS 7.0.1.325 on WXP Pro SP2 on VBox 3.0.2 on ubuntu 8.04.2.

comment:65 follow-up: ↓ 67 Changed 5 years ago by catkin

Hello :-)

Workaround becoming unavailable?

The workaround for this problem -- of using KIS 7 -- is becoming unavailable.

My license is soon to run out so I bought a two year extension only to find it cannot be used on KIS 7. Error message: "This key is not for this application". support@… wrote "About the key problem, each area have itself solution, therefore you'd better contact the local agent/sales or local technical support for help". So I wrote to kaspersky.ie.cs@… asking for an activation code to extend the KIS 7 license but have had no reply > 96 hours later :-(

Best

Charles

comment:66 in reply to: ↑ 48 Changed 5 years ago by catkin

Hello :-)

Replying to Serpardum

I know that if I look at the bios memory starting at b0000 (video memory) that VirtualBox is shown up there (video card). Perhaps you could use that info? You'll need to see exactly the offset where "VirtualBox" shows up and might have problems with priveledges. I am not sure how you would look at this as it's probably protected memory. Just a suggestion.

Any progress with that idea, Kaspersky? This bug is more than a year old so either intractable or a low priority for VirtualBox -- so a workaround by Kaspersky would be very welcome.

Best

Charles

comment:67 in reply to: ↑ 65 ; follow-up: ↓ 68 Changed 5 years ago by ToddAndMargo

Replying to catkin:

Hello :-)

Workaround becoming unavailable?

The workaround for this problem -- of using KIS 7 -- is becoming unavailable. Charles

Hi Charles,

The keys I sell work with 7, 8, and the unreleased 9. It all depends on how your create the key. Unfortunately, I only sell locally. But, all is not lost, you can contact my supplier and they will gin up a key that will work for you:  http://www.useice.com/ 913.268.3250 They are very, very nice people, which is why I use them.

HTH, -T

comment:68 in reply to: ↑ 67 Changed 5 years ago by catkin

Replying to ToddAndMargo:

Hi Charles,

The keys I sell work with 7, 8, and the unreleased 9. It all depends on how your create the key. Unfortunately, I only sell locally. But, all is not lost, you can contact my supplier and they will gin up a key that will work for you:  http://www.useice.com/ 913.268.3250 They are very, very nice people, which is why I use them.

Thanks Todd :)

Thanks for confirming that it is possible to create a key for KIS 7 and suggesting ICE Systems. I'll contact them.

<rant> I'm getting nowhere fast with Kaspersky themselves on this. support@… said it is not a technical issue and referred me to  http://www.kaspersky.com/customer_care_cente where it says "for orders placed on or after June 18, 2009, Kaspersky Lab eStore is supported by our trusted e-commerce partner - Digital River." so I wrote to kaspersky.ie.cs@… who took 3 days to reply saying they couldn't find my order despite being given the order reference and activation key. Don, on  http://forum.kaspersky.com/index.php?showtopic=126784 suggested contacting Kaspersky via  http://www.kaspersky.com/in/contacts (I live in India) which gives sales_india@… for non-technical email but Kaspersky's mail server bounced that address. The story continues ... </rant>

Best

Charles

comment:69 Changed 5 years ago by catkin

Hello :-)

Update: the good news is that Kaspersky did issue an activation code for Kaspersky Internet Security 7.

The bad news is <rant>I still haven't had a response from Digital River, despite sending them a .pdf of the paid invoice</rant>. ICE systems were helpful but wanted me to buy another license. It was an email to info@… that produced the activation code along with an explanation that the reason the "customer care center was unable to help you is that you purchased the license through our Indian estore".

Best

Charles

comment:70 follow-up: ↓ 71 Changed 5 years ago by sandervl73

Could you please move the license discussion to the forum? I know you mean well, but it makes the ticket harder to read. Thanks.

comment:71 in reply to: ↑ 70 ; follow-up: ↓ 72 Changed 5 years ago by catkin

Replying to sandervl73:

Could you please move the license discussion to the forum? I know you mean well, but it makes the ticket harder to read. Thanks.

I'm sorry -- I did mean well. For users, bug workarounds can be as important, perhaps more important, than the bug itself, so I thought the license position useful here as well as on the Kaspersky forum. In retrospect I should have waited for the position to be determined before posting any relevant summary here. The position was determined in my last post which would have been my last on the subject.

comment:72 in reply to: ↑ 71 Changed 5 years ago by catkin

Replying to catkin:

Replying to sandervl73:

Could you please move the license discussion to the forum? I know you mean well, but it makes the ticket harder to read. Thanks.

I'm sorry -- I did mean well. For users, bug workarounds can be as important, perhaps more important, than the bug itself, so I thought the license position useful here as well as on the Kaspersky forum. In retrospect I should have waited for the position to be determined before posting any relevant summary here. The position was determined in my last post which would have been my last on the subject.

sandervl73, I'm sorry some more and think it's worth adding another reply to say so. I added inappropriate material to this bug report and responded defensively to your gentle message saying so. Sorry. Lesson learned. Bug reports are not BBS threads.

comment:73 Changed 5 years ago by harlan4096

I'm having crashes/hunging system in my virtualized WINXPSP3 + KIS 2010 9.0.0.463.

After some seconds of being started, the system hungs ... and I have to stop/force to stop the virtual machine sesion.

I provide logs of my VB.

Regards.

Changed 5 years ago by harlan4096

Windows XP hungs (KIS 2010 9.0.0.463)

comment:74 Changed 4 years ago by fjnunn

Same here. WinXP SP3. Kaspersky 2009. Logs attached below. Summary: windows gets progressively slower, especially when running apps. That seems to speed up the time until it halts.

Changed 4 years ago by fjnunn

comment:75 follow-up: ↓ 78 Changed 4 years ago by harlan4096

But KIS 2010 9.0.0.736 is working fine here in VB 3.0.10 and even in 3.0.8 worked fine.

Regards.

comment:76 Changed 4 years ago by mbondfusion

Summary:

WinXP Pro SP3 VM hangs with Kaspersky 2009 (specifically kav8.0.0.523en.exe) and GA installed
Related ticket: #4974

Host:

9.10 w/ 2.6.31-14 64-bit kernel w/ VirtualBox 3.0.10r54097 and VirtualBox 3.0.12r54655 (Both versions are having the same issue)

Guest:

WinXP Pro SP3 32-bit w/ Guest Additions, Kaspersky 2009, VT Enabled, 512MB RAM, 10GB disk

comment:77 Changed 4 years ago by ToddAndMargo

Guy! Great news. I think I may have figured this one out. Or rather, Viznix did and did not realize it. Check out:

 http://www.virtualbox.org/ticket/3792#comment:36

I could not get Virtual XP to reboot after running Go To Assist Express (GTAE) with out the restart jamming at a video shimmer. Viznix reported that he solved his reboot problem by upping his video memory to 16 MB and his RAM to 512 MB. Since my video was already at 32 MB, I bumped my RAM up from 352 Meg to 512 Meg. It fixed the reboot problem. Then I got to thinking, maybe bug 3792 was a duplicate of this bug. So, I fired up a VDI I had specially set up to test Kaspersky Internet Security Suite (KISS) 2009. And what do you know. KISS 2009 now run perfectly. Updates and License Server too.

So, everyone with this problem, try upping your RAM to at least 512 Meg. Then let us all know if it does the trick.

Virtual Box: this could very well be the same problem as bug 3792. We shall soon see.

-T

comment:78 in reply to: ↑ 75 Changed 4 years ago by ToddAndMargo

Replying to harlan4096:

But KIS 2010 9.0.0.736 is working fine here in VB 3.0.10 and even in 3.0.8 worked fine.

Regards.

Hi Harlan,

Set your RAM at or below 352 Meg an retry your test.

-T

comment:79 Changed 4 years ago by ToddAndMargo

Hi All,

I just got Kaspersky Internet Security 2010 (kis9.0.0.736en.exe) installed on my main XP guest. Yipee! RAM=512 Meg

-T

comment:80 Changed 4 years ago by frank

  • Priority changed from critical to major

comment:81 Changed 3 years ago by harlan4096

I have VB 4.0.10R72479 and I've installed KIS2011 .566 and after a while always my virtual W7 (but tried in XP too) hangs ... this issue was also in previous builds of VB ... any solution?. The same issue is present wti hte new KIS2012 ...

Regards.

comment:82 follow-up: ↓ 83 Changed 3 years ago by ToddAndMargo

I am using VB 3.2.12 and kis11.0.2.556en.exe. After reinstalling and doing the update, my machine freezes up at 99% on the update. The host shows 100% CPU.

comment:83 in reply to: ↑ 82 Changed 3 years ago by ToddAndMargo

Replying to ToddAndMargo:

I am using VB 3.2.12 and kis11.0.2.556en.exe. After reinstalling and doing the update, my machine freezes up at 99% on the update. The host shows 100% CPU.

Update:  http://products.kaspersky-labs.com/english/homeuser/kis2012/kis12.0.0.374en_gb.exe freezes my VM at 99% update too. Bummer ...

Oh, VM is XP-Pro-SP3, 32 bit. Host is CentOS 5.6, 32 bit

comment:84 Changed 21 months ago by Fred

Hi everyone,

I am currently using VB 4.1.16 with a Windows XP x86 guest OS, and a Windows 7 x64 host OS. With Kaspersky Antivirus 6.0 , the virtual machine crashes after the Kaspersky's launch, since the database update of yesterday! Is this problem known with theses versions of VB and Kaspersky? I have to disable Intel VT-x to avoid the crash.. which is quite annoying.

Thank you for your help.

Last edited 21 months ago by Fred (previous) (diff)

comment:85 Changed 17 months ago by daCaPo

I can confirm this bug for VB 4.2.4 on a Core 2 Duo iMac. However, on a Core Duo iMac, the bug does not occur, event with VT-x enabled. HTH

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use