VirtualBox

Ticket #17577 (new defect)

Opened 4 years ago

Last modified 4 years ago

Unusable window system on Ubuntu 1204 guest using 5.2.8 or GA 5.2.7

Reported by: tomasth Owned by:
Component: guest additions Version: VirtualBox 5.2.8
Keywords: 3D acceleration Cc:
Guest type: Linux Host type: Windows

Description

After installing 5.2.8 (and also after testing GA 5.2.7 against 5.2.6 to address 3D acceleration bug - Ticket #17463, Ticket #17569) my Ubuntu 1204 system became unusable. E.g. when I try to run terminal I cannot see the console window and cannot switch to it with Alt-Tab or any other means. The Alt-Tab icons look different as well. The problem went away on 5.2.6 after moving back to GA 5.2.6 but I really need a fix for the 3D issue so that is not where I want to be.

Attachments

Logs.zip Download (55.2 KB) - added by tomasth 4 years ago.
Recent logs

Change History

Changed 4 years ago by tomasth

Recent logs

comment:1 Changed 4 years ago by tomasth

Also crash the entire VM when running e.g. QtCreator 2.5.2 and generally unstable. Everything seems normal after revertig to GA 5.2.6. See attached logs

comment:2 follow-up: ↓ 3 Changed 4 years ago by michael

Does this happen with a fresh installation of Ubuntu 12.04?

comment:3 in reply to: ↑ 2 Changed 4 years ago by tomasth

Replying to michael:

Does this happen with a fresh installation of Ubuntu 12.04?

Just finished testing and - no - does not happen. Any guess as to what on my system has been affected by the change from 5.2.6 to 5.2.7/8 of GA?

comment:4 Changed 4 years ago by michael

I'm afraid that that is something you will have to find out if you are interested in someone looking at this. The more you find, the better the chances. The first thing which comes to mind to check is the versions of Ubuntu 12.04 installed, and which kernel and X.Org versions the old and the new installations have. Taking a look at the /var/log/*vbox* log files on the affected guest would be good too, as well as the system log and dmesg. I must also admit that I can't quite picture what you describe - a screen recording or something might be interesting.

A quick solution would of course be to migrate what you need from the old guest to the new one if the new one works well enough.

comment:5 Changed 4 years ago by tomasth

Chances are that when I bring the new machine up to where I need it to be the issue will re-surface. I thought maybe you (or someone else) could provide some insight as to what changed between GA 2.5.6 and 2.5.7 That could narrow my search.

comment:6 Changed 4 years ago by tomasth

Video of the faulty behavior (cannot open terminal)  https://www.dropbox.com/s/ibacpp2xmpkbufu/vbox258.wmv?dl=0

comment:7 Changed 4 years ago by tomasth

Same Ubuntu (fully updated) - therefore kernel and X.Org should be the same

comment:8 Changed 4 years ago by tomasth

Just realized I hadn't turned on 3D acceleration in the new VM. Same problem now.

comment:9 Changed 4 years ago by michael

Are you saying that 3D works with the 5.2.6 Additions installed? I thought that that was broken for all Linux guests.

comment:10 Changed 4 years ago by tomasth

No, I'm not 100% sure what happened. Didn't track my changes closely enough. Is it possible that VBox turned 3D off when I changed some settings and then my gui failed when I tried to turn it back on?

If not then 3D was off the whole time, which would explain why I never saw the issue.

comment:11 Changed 4 years ago by tomasth

Made a new 1204 machine from scratch, made sure that 3D acceleration is on and the problem is reproduced after installing GA on top of a fresh ubuntu install.

So my initial mistake was assuming 3D was on by default. The problem is not unique to my setup!

comment:12 Changed 4 years ago by dhcolesj

Would this cover KDE's Panel and basic window decorations failing?

comment:13 Changed 4 years ago by Clancy

I have the same problem now on Ubuntu 16.04.4 LTS

uname -a Linux xdm 4.13.0-41-generic #46~16.04.1-Ubuntu SMP Thu May 3 10:06:43 UTC 2018 x86_64 x86_64 x86_64 GNU/Linux

GA 5.2.12

VB 5.2.12 r122591

When 3D acceleration is enabled, even on the login screen, the top status bar icons are clickable, and show as highlighted, but the windows don't appear (ie. power icon, network, battery, etc). After signing in, some programs work as expected, but some (ie. terminal) have the same behavior as the attached video. They will open but the actual content window is invisible, and menu items are there in the top bar, but clicking one opens an invisible menu.

comment:14 Changed 4 years ago by michael

I am afraid that there is currently no one on the team with enough free time to investigate this (and no sign that it will change in the foreseeable future). It should be something which interested users with skills in OpenGL programming in C should be able to track down and fix. Questions (technical ones) or patches welcome on the vbox-dev mailing list.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use